Notifications
Clear all

Fatal Error version 2021.2

Page 1 / 2

Posts: 2
Topic starter
(@mcf64)
New Member
Joined: 3 weeks ago

Just updated from v. 2021.1 to 2021.2 and following error appears

Fatal error: Uncaught Error: Non-static method AdvancedIframeHelper::ai_endsWith() cannot be called statically in /homepages/39/d860316897/htdocs/afc/wp-content/plugins/advanced-iframe/includes/advanced-iframe-main-prepare.php:345 Stack trace: #0 /homepages/39/d860316897/htdocs/afc/wp-content/plugins/advanced-iframe/includes/advanced-iframe-main-prepare.php(511): AdvancediFramePrepareJs::aiPreparePdfJs('https://afc-aca...') #1 /homepages/39/d860316897/htdocs/afc/wp-content/plugins/advanced-iframe/advanced-iframe.php(657): include('/homepages/39/d...') #2 /homepages/39/d860316897/htdocs/afc/wp-content/plugins/advanced-iframe/advanced-iframe.php(1600): advancediFrame->do_iframe_script(Array, NULL) #3 /homepages/39/d860316897/htdocs/afc/wp-includes/class-wp-block.php(221): render_ai_gutenberg(Array, '', Object(WP_Block)) #4 /homepages/39/d860316897/htdocs/afc/wp-includes/blocks.php(799): WP_Block->render() #5 /homepages/39/d860316897/htdocs/afc/wp-includes/blocks.php(837): render_block(Array) #6 /homepages/39/d860316897/htdocs/afc/wp-includes/class-wp-hook.php(292): do_blocks('<!-- wp:ai/ai-b...') #7 /homepages/39/d860316897/htdocs/afc/wp-includes/plugin.php(212): WP_Hook->apply_filters('<!-- wp:ai/ai-b...', Array) #8 /homepages/39/d860316897/htdocs/afc/wp-includes/post-template.php(253): apply_filters('the_content', '<!-- wp:ai/ai-b...') #9 /homepages/39/d860316897/htdocs/afc/wp-content/themes/twentytwentyone/template-parts/content/content-page.php(29): the_content() #10 /homepages/39/d860316897/htdocs/afc/wp-includes/template.php(732): require('/homepages/39/d...') #11 /homepages/39/d860316897/htdocs/afc/wp-includes/template.php(676): load_template('/homepages/39/d...', false, Array) #12 /homepages/39/d860316897/htdocs/afc/wp-includes/general-template.php(204): locate_template(Array, true, false, Array) #13 /homepages/39/d860316897/htdocs/afc/wp-content/themes/twentytwentyone/page.php(17): get_template_part('template-parts/...') #14 /homepages/39/d860316897/htdocs/afc/wp-includes/template-loader.php(106): include('/homepages/39/d...') #15 /homepages/39/d860316897/htdocs/afc/wp-blog-header.php(19): require_once('/homepages/39/d...') #16 /homepages/39/d860316897/htdocs/afc/index.php(17): require('/homepages/39/d...') #17 {main} thrown in /homepages/39/d860316897/htdocs/afc/wp-content/plugins/advanced-iframe/includes/advanced-iframe-main-prepare.php on line 345
Topic Tags
6 Replies
TinyWebGallery
Posts: 418
Admin
(@admin)
Administrator
Joined: 12 years ago

Hi,

Which ph version do you use? The error is valid but it does not happen on any of my demos.

I will provide a fix today.

Best regards,

Michael

Reply
TinyWebGallery
Posts: 418
Admin
(@admin)
Administrator
Joined: 12 years ago

Do you use php 8 already? Seems there this is not allowed anymore. I have to adopt the code...

Best regards, Michael

Reply
TinyWebGallery
Posts: 418
Admin
(@admin)
Administrator
Joined: 12 years ago

Hi,

This issue was php 8. I did some code refactorings which where not working there.

I fixed the issue, tested and updated the version in codecanyon to 2021.3

Sorry for the inconvenience, Michael

Reply
Posts: 2
Topic starter
(@mcf64)
New Member
Joined: 3 weeks ago

works again (with version 2021.3)

Thanks a lot! and impressive reaction time, kudos!

Reply
Page 1 / 2