Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 18. Nov 2018, 03:32

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 5 posts ] 
Author Message
PostPosted: 29. May 2018, 04:24 
Offline

Joined: 27. May 2018, 05:21
Posts: 5
The caption
Quote:
The birds have started to come out here in Washington! Here is a beautiful relative to the bluebird/raven called a Stellar's Jay that has been visiting recently.


shows up as
Quote:
The birds have started to come out here in Washington! Here is a beautiful relative to the bluebird/raven called a Stellar’s Jay that has been visiting recently.


in my instance and I'm not seeing why.

EDIT: I've removed the XML file, and it seems the import process converts the single quotes to a fancy quote instead. I would tend to consider that to be a bug.

EDIT2: Even without any quotes at all in the IPTC data, TWG's import is still putting the escaped HTML for them into the XML files... I don't see how this is physically possible.


Top
 Profile  
 
PostPosted: 29. May 2018, 05:19 
Offline

Joined: 27. May 2018, 05:21
Posts: 5
Code:
iptc path/2018-04-23_00-48-48_Bh5LbONHmiV.jpg
theycallmedsp/2018-04-23_00-48-48_Bh5LbONHmiV.jpg:
 Tag      Name                 Type      Size  Value
 -------- -------------------- --------- ----  -----
 2:040    Special Instructions String      90  FBMD23000968010000395500003a7a0000e9970000eb490100baa60100cff00100c25c0200abb50200243e0300
 2:120    Caption/Abstract     String      77  Kat made homemade chili from scratch. Its the best darn chili Ive ever eaten!


Code:
<BILD><NAME>2018-04-23_00-48-48_Bh5LbONHmiV.jpg</NAME><WERT>Kat+made+homemade+chili+from+scratch.+It%C3%A2%C2%80%C2%99s+the+best+darn+chili+I%C3%A2%C2%80%C2%99ve+ever+eaten%21</WERT></BILD>


These tags that TWG are finding simply do not exist.

Even when manually removing those HTML escaped characters from the XML and refreshing the page, they are still shown.

Image


Attachments:
specialchars.PNG
specialchars.PNG [ 8.67 KiB | Viewed 62 times ]
Top
 Profile  
 
PostPosted: 29. May 2018, 11:50 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10918
Such things are cached. So make sure you remove the session cookie also if you manually edit the xml file and retry

So you read the captions from the IPTC only? Are they utf-8 encoded?
If yes. have you set $iptc_encoding = 'utf-8'; ?

Best, Michael


Top
 Profile  
 
PostPosted: 1. Jun 2018, 02:23 
Offline

Joined: 27. May 2018, 05:21
Posts: 5
TinyWebGallery wrote:
Such things are cached. So make sure you remove the session cookie also if you manually edit the xml file and retry

Thanks for the help, this is what I needed to do.


Top
 Profile  
 
PostPosted: 1. Jun 2018, 16:54 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10918
Please note that you can delete the session cache in the administration as well and also by clicking on the bandwidth icon.

Best, Michael


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron
powered by phpbb | Datenschutz/ Privacy policy