Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 23. Sep 2018, 14:08

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: 15. Feb 2016, 07:49 
Offline
User avatar

Joined: 15. Feb 2016, 06:19
Posts: 2
I just installed the latest version of TWG.
I found that TWG has a problem processing the photos from my Sony camera.
apache2/error.log
Code:
[Mon Feb 15 00:29:14.115444 2016] [:error] [pid 24071] [client 192.168.x.x:41125] PHP Fatal error:  Maximum execution time of 30 seconds exceeded in /var/www/twg23/inc/exifReader.inc.php on line 366, referer: http://study.klomp.ca/twg23/index.php?twg_album=2_Joshua&wg_album=2_Joshua&twg_show=DSC00253.JPG&wg_album=2_Joshua
counter/_mydebug.out
Code:
02.15.2016 0:29:14 (en) - ERROR 2 in /var/www/twg23/inc/imagecreate.inc.php, line 74: getimagesize(pictures/2_Joshua/DSC00281.JPG): failed to open stream: Permission denied

I've tried to rewrite the exif info with the ExifTool, but it seems unsuccessful, possibly because I cannot remove all exif data from the photo. :roll:
Images from other sources seem to behave properly.
Since I have a large number of photos from my Sony camera, I was wondering if there is another tool under Ubuntu that would solve this issue :?:

Thank you,
LinuxLover.


Last edited by LinuxLover on 16. Feb 2016, 17:53, edited 1 time in total.

Top
 Profile  
 
PostPosted: 15. Feb 2016, 23:41 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10895
Hi, I don't see a relation to exif data. I think that the issue is while reading exif data does not mean that the issue is there. Or do all images throw an error here?

How big are your images and how much php memory do you have?

Best, Michael


Top
 Profile  
 
PostPosted: 16. Feb 2016, 17:41 
Offline
User avatar

Joined: 15. Feb 2016, 06:19
Posts: 2
Thanks Michael,

Found the issue!
Code:
-rw--w---- 1 chris    chris     319209 Dec 10  2003 DSC00253.JPG
-rw--w---- 1 chris    chris     319842 Dec 24  2003 DSC00281.JPG
-rw--w---- 1 chris    chris     319228 Jun  7  2004 DSC00602 de Klomp mannen.JPG

These files have indeed the wrong permissions!
Group should be www-data and it should have been --rw-r-----
:? :oops:

LinuxLover :lol:


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
powered by phpbb | Datenschutz/ Privacy policy