Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 21. Sep 2018, 20:24

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 5 posts ] 
Author Message
PostPosted: 10. Nov 2011, 16:22 
Offline

Joined: 10. Nov 2011, 16:05
Posts: 6
I am running TWG (registered) on my own hosted apache2 server.
I have some problems with the installation check:
- Image Magick Support -> red
- ffmpeg Support -> red
- ffmpeg video support -> red


I tried several things but so fare I have no clue what the problem might be.
To test I gave the whole directory full access "chmod 777" but still doesn't work.
Could it be a virtual host problem? I am a newbie...

Any ideas what to test? Thank you.


Top
 Profile  
 
PostPosted: 11. Nov 2011, 02:58 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10895
Nothing to worry about.

this 2 are softwares your hoster has to install/provide.

image magick is an alternative to the build in library to modify images
and ffmpeg gives you to the option to create thumbnails from videos and to convert them.

image magick is something you maybe get if you ask your hoster about it ;).
ffmpeg you normally only get if you have your own server because it is really powerful. it can e.g. convert videos from avi to flv during upload.

Best,
Michael


Top
 Profile  
 
PostPosted: 12. Nov 2011, 12:52 
Offline

Joined: 10. Nov 2011, 16:05
Posts: 6
Hi Michael
thank you for the fast reply. The thing is I am hosting TWG on my own Ubuntu Server running apache2.
I have installed both packages:
apt-get install imagemagick ffmpeg

But still the check tells me that they are red...
Especially in the ffmpeg functions I am interested.


Top
 Profile  
 
PostPosted: 12. Nov 2011, 19:06 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10895
then you have to check where they are installed. You have to tell TWG where the executables are.

- Michael


Top
 Profile  
 
PostPosted: 13. Nov 2011, 00:04 
Offline

Joined: 10. Nov 2011, 16:05
Posts: 6
...hours later - I found the solution!
I don't know how it came there, but in my file:
/etc/php5/apache2/php.ini
under disable_functions was "shell_exec":
disable_functions = shell_exec

I removed the shell_exec and now it is working.

Thank you anyway for your help,
mesc


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
powered by phpbb | Datenschutz/ Privacy policy