Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 21. Jun 2018, 19:41

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 8 posts ] 
Author Message
PostPosted: 31. Jan 2008, 16:45 
Offline

Joined: 31. Jan 2008, 16:40
Posts: 3
hey,
my version is: TWG version 1.6.3.2

when i'm trying to open admin/index.php there is
Code:
Fatal error: Cannot redeclare posix_geteuid() in /home/cugok/public_html/cugok/galeria/admin/_include/fun_extra.php on line 409


any ideas how to solve it ?

i've just upload all files to my account and change chmod to 3 folders


Top
 Profile  
 
 Post subject:
PostPosted: 31. Jan 2008, 18:24 
Offline

Joined: 27. Jul 2007, 20:28
Posts: 136
sounds like a server configuration problem, perhaps?


Top
 Profile  
 
 Post subject:
PostPosted: 31. Jan 2008, 23:14 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10836
Some php installation do have this functions some not. I have a self written one if the one is not available.

Please use the version in the forum. There I have integrated a check that my functions ins only declared if the php does not have it.

Wait for RC2 - it will be online maybe today ;).

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 1. Feb 2008, 03:55 
Offline

Joined: 31. Jan 2008, 16:40
Posts: 3
still the same error after upload new version RC2

zubrex.pl/twg/admin/index.php - check here


Top
 Profile  
 
 Post subject:
PostPosted: 1. Feb 2008, 09:55 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10836
I checked you server configuration.

The problem is that the function is available in php but disabled in your php.ini in the section disable_functions.

I use the method function_exists that delivers false because the function was disabled.
But when I try to declare it php says it's already there (only disabled).

You can remove the codeblock that redefines this function.
i'll try to implment a workaround for this problem too.

Can you please remove this block

if( !(function_exists('posix_geteuid'))) {
function posix_geteuid() {
return false;
}
}

from admin/_include/fun_extra.php

and tell me if everything works fine then. (check if the log filecounter/_mydebug.out does exists and has any errors.).

Thanks,
Michael


Top
 Profile  
 
 Post subject:
PostPosted: 1. Feb 2008, 10:21 
Offline

Joined: 31. Jan 2008, 16:40
Posts: 3
Thank you Michael, it works ;)

There is no _mydebug.out in 'counter'


Top
 Profile  
 
 Post subject:
PostPosted: 1. Feb 2008, 11:14 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10836
Than it's o.k.

I will check the php.ini settings and if this function is diabled and I won't redeclare it then.
I'll add this to the 1.7 final.

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 1. Feb 2008, 18:36 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10836
I have updated rc2 and changed the file you have modified.
Can you please download rc2 again and replace the fun_extra.php and test again.

/Michael


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron
powered by phpbb | Datenschutz/ Privacy policy