Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 18. Jun 2018, 03:54

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 9 posts ] 
Author Message
PostPosted: 7. Aug 2007, 20:10 
Offline

Joined: 7. Aug 2007, 20:04
Posts: 4
Hi,

After the inital install, I am able to login to the admin with the default password provided by TWG. However, I am unable to reset the password. The htuser file is set to 777 and the admin screen verifies it is 'writable' in green at the top of the page.

Can you help me please?

Thanks


Top
 Profile  
 
 Post subject:
PostPosted: 7. Aug 2007, 20:24 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10832
any messages in the debug file?

can be found at counter/_mydebug.out if you cannot login to the backend.

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 7. Aug 2007, 20:25 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10832
have you savemode enabled? call info.php for details.

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 11. Aug 2007, 01:11 
Offline

Joined: 7. Aug 2007, 20:04
Posts: 4
thank you for your response.

how do I read the mydebug.out file?

i found this text:


08.07.2007 0:34:06 - ERROR 2 in Unknown, line 0: Unknown(): open(/var/php_sessions/sess_4cce51c43499ac0a118a41271a8eb532, O_RDWR) failed: No such file or directory (2)
08.07.2007 0:34:06 - ERROR 2 in Unknown, line 0: Unknown(): Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/var/php_sessions)
08.07.2007 0:34:06 - ERROR 2 in Unknown, line 0: Unknown(): open(/var/php_sessions/sess_4cce51c43499ac0a118a41271a8eb532, O_RDWR) failed: No such file or directory (2)
08.07.2007 0:34:06 - ERROR 2 in Unknown, line 0: Unknown(): Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/var/php_sessions)
08.07.2007 0:34:11 - ERROR 2 in Unknown, line 0: Unknown(): open(/var/php_sessions/sess_4cce51c43499ac0a118a41271a8eb532, O_RDWR) failed: No such file or directory (2)
08.07.2007 0:34:11 - ERROR 2 in Unknown, line 0: Unknown(): Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/var/php_sessions)


also, how do I enable savemode?

i found this line of code:

$php_recommended_settings = array(array ($GLOBALS["info_messages"] ["savemode"],'safe_mode',"OFF"),


Can you help me please?

Thanks


Top
 Profile  
 
 Post subject:
PostPosted: 12. Aug 2007, 12:58 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10832
o.k. - your php is not configured properly!

Your session save directory is not valid - you have to fix this first!

and about the savemode - the line you posted display and info. safemode off is the recommended setting!.

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 12. Aug 2007, 22:04 
Offline

Joined: 7. Aug 2007, 20:04
Posts: 4
thank you for your response.

how do i configure my php? make the session save directory valid?


Top
 Profile  
 
 Post subject:
PostPosted: 12. Aug 2007, 22:09 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10832
set the session save path correctly - ask google how to do this ;).

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 13. Aug 2007, 17:08 
Offline

Joined: 7. Aug 2007, 20:04
Posts: 4
Thank you. I found some instructions on my hosting service knowledge base. I will give it a try.

Here are the instructions they provided.

Question/Problem
Troubleshooting: My PHP-based application isn't allowing users to login. Why isn't it supporting sessions?


Answer/Solution

PHP requires that you set a path where session data can be saved. The path defaults to a location on the server, but as a shared host, using the default path means your sessions would potentially be viewable by other customers.

To avoid that situation, we recommend using a path that is inside your home directory. You can use any directory you would like, but we recommend your cgi-bin/tmp directory, as it is already setup to handle sessions appropriately.

To set the session save path:

Open your PHP.ini file through the PHP.ini editor
From your OPS Control Panel, determine your home directory (Services > Overview > Document Root). It should look like: /home/users/web/b1234/pow.username.
Find the "session.save_path" entry in your PHP.ini file and set it equal to your cgi-bin/tmp directory. It should look like: "/home/users/web/b1234/pow.username/htdocs/cgi-bin/tmp/", where /home/users/web/b1234/pow.username is your home directory, and /htdocs/cgi-bin/tmp/ is the path to your specific directory.


Top
 Profile  
 
 Post subject:
PostPosted: 13. Aug 2007, 17:10 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10832
seems like a good plan ;).


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron
powered by phpbb | Datenschutz/ Privacy policy