Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 24. Sep 2018, 19:35

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 23 posts ]  Go to page 1, 2  Next
Author Message
PostPosted: 15. Jun 2017, 07:18 
Offline

Joined: 15. Jun 2017, 07:14
Posts: 12
Hallo erstmal,

mir fällt auf, dass auf kleinen Displays - zB. Smartphones - die Auflösung der Bilder absolut grottig ist. Leider habe ich noch keine Option gefunden, mit der ich die Auflösung einstellen kann.
Am liebsten wäre mir sogar die volle Auflösung, zumindest wenn das gewählte Bild angezeigt wird.

Hab ich nur das passende HowTo bzw. eine passende Frage im Forum nicht gefunden, oder interessiert das sonst niemanden? :roll:

Kann mir jemand weiterhelfen?

Vielen Dank
Dan


Top
 Profile  
 
PostPosted: 16. Jun 2017, 00:07 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10896
Die Auflösung kannst du ganz normal in der Administration einstellen.
Da wird die max. pixel pro seite eingestellt.

Definiere grottig! Weil wenn ein bild auf 400x300 runtergerechnet wird dann ist das halt so. Wan es nicht gibt ist, das z.b. für retina Displays ein doppelt so grosses Bild gerendert wird.

Gruß, Michael


Top
 Profile  
 
PostPosted: 16. Jun 2017, 07:31 
Offline

Joined: 15. Jun 2017, 07:14
Posts: 12
Das mit der Auflösung habe ich schon gemacht, für die Desktop-anzeige ist das auch in Ordnung.
Wenn ich aber auf dem Smartphone ein Bild anzeigen lasse, bekomme ich das Bild zwar eingepasst auf dem Display angezeigt, aber leider wurde auch die Auflösung herunterskaliert - das heisst ein Bild mit eigentlich 6000x4000px wird auf z.B. 360x202px herunter skaliert, statt das Originalbild mit einer width:100% relativ zum Bildschirm anzuzeigen - also nicht die Datei selbst soll verändert werden, sondern nur die Ansicht/Anzeige.
Klar erhöhen sich die Ladezeiten, aber zumindest in der Einzelbildansicht möchte ich schon gern die volle Auflösung haben oder zumindest duch einen klick oder so das Originalbild anzeigen lassen.

MfG Dan


Top
 Profile  
 
PostPosted: 17. Jun 2017, 00:27 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10896
Hast du für mobile was anderes eingestellt? Weil ich hab nur ein Bild und auf mobile wird das aktuell einfach vom browser runterskaliert....

Click auf Originalbild kannst du sowieso einstellen.

Gruß,
Michael


Top
 Profile  
 
PostPosted: 17. Jun 2017, 15:33 
Offline

Joined: 15. Jun 2017, 07:14
Posts: 12
Ich habe jetzt erstmal auf die schnelle die setbrowser Abfrage auskommentierz, das hilft schon mal weiter.
Aber uns ist aufgefallen, dass das upload popup in Edge (Windows 10)nicht funktioniert ,selbst wenn ich auf HTML umschalte geht es nicht... Ich vermute das hängt auch mit der veralteten Browserweiche zusammen


Top
 Profile  
 
PostPosted: 18. Jun 2017, 21:39 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10896
Ich verstehe nicht, was die Browserweiche hiermit zu tun hat (welche ich wirklich mal aktualiseren werde im nächsten kleinen Update) weil es gibt nur eine Bildgröße auf der Detailseite.

Und was bedeutet geht nicht? Da hier auch keine Browserweiche im Spiel ist bräuchte ich hier mehr details!

Hast du http://www.tinywebgallery.com/en/faq.php#h57 schon gesehen? Weil genau hier wird nur über den browser skaliert. Heist wenn du hier Bilder mit 1000x1000 hast wird das auch mit width:100% runterskaliert...

Gruß, Michael


Top
 Profile  
 
PostPosted: 19. Jun 2017, 06:58 
Offline

Joined: 15. Jun 2017, 07:14
Posts: 12
Also, bevor ich die Scripts weiter durchgehe erstmal die Antwort auf deinen letzten Post...

In der mysession.inc.php wird die Datei setbrowser.inc.php includiert - die mysession.inc.php wiederum wird in den drei Dateien ajax.php, image.php sowie index.php aufgerufen - somit wird verständlicherweise immer eine Browserabfrage gemacht.
Kommentiere ich nun in der setbrowser.inc.php die Zeilen 48-74 aus, ändert sich das Verhalten auf jeder Seite mal mehr, mal weniger! Im Fall der mobilen Ansicht wird bei der Einzelbildansicht/Detailansicht (...&&twg_zoom=TRUE auf dem DesktopPC, ohne weiterführende Angaben auf dem Smartphone) zum Beispiel der Downloadlink gesetzt - ein klick auf das Bild startet den Download des Bildes - die Bildqualität ändert sich leider doch nicht wie gedacht, da muss ich letzte Woche wohl noch andere Einstellungen geändert haben.

"Geht nicht" heißt, durch die veraltete Browserweiche wird der Browser Edge nicht erkannt, daraufhin funktioniert der Upload nicht:
Image

http://www.tinywebgallery.com/en/faq.php#h57 wende ich an, das ändert aber nix an der Dateigröße in der Ansicht. Ich spiele jetzt noch ein bisschen damit und der "Größe der Web-Bilder" rum, um das für mich bestmögliche Ergebnis zu erzielen

MfG Dan


EDIT:
Habe nun das Problem reproduzieren können - sobald ich Zeile 48-74 in setbrowser.inc.php auskommentiere, werden die Bilder im Smartphone in voller Dateigröße geladen... lasse ich die Abfrage aktiv, werden die Bilder in extrem minimaler Dateigröße und somit auch in schlechter Auflösung angezeigt und auch Einstellungen wie zB. Anzeige im Popup sind nicht aktiv.

Folgende Einstellungen nutze ich zur Zeit:
    $encrypt_passwords=true;
    $twg_mobile_show_menu_items = true;
    $twg_mobile_show_rating = true;
    $twg_mobile_show_comments = true;
    $twg_mobile_show_counter=true;
    $twg_mobile_show_search=false;
    $twg_zoom=false;
    $compression_thumb=100;
    $show_clipped_images=true;
    $center_clipped_images_horizontal=true;
    $center_clipped_images_vertical=true;
    $resized_background_tolerance=100;
    $activate_lightbox_thumb=true;
    $activate_lightbox_thumb_full=true;
    $use_original_on_thumbspage=false;
    $activate_lightbox_topx=true;
    $activate_lightbox_topx_full=false;
    $use_original_on_topxpage=true;
    $activate_lightbox_image=true;
    $open_as_popup=false;
    $open_in_maximized_view=true;
    $responsive_align_center=true;
    $responsive_main_page=true;
    $responsive_main_page_padding_x=40;
    $responsive_main_page_padding_y=50;
    $responsive_thumb_page=true;
    $responsive_detail_page=true;
    $responsive_detail_page_full_slideshow=true;

    $small_pic_size= 1920;
    $resize_only_if_too_big= true;
    $use_small_pic_size_as_height= false;


Top
 Profile  
 
PostPosted: 24. Jun 2017, 00:20 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10896
Natürlich ändert sich durch die browser weiche was. In der config_internal.php sind jede Menge Einstellungen für tablet und smartphones.
Da hast du ja auch einige geändert. Z.b. gehen popups wegen dem swipe nicht...

Wie du richtig rausgefunden hast wird die browserweiche an ein paar stellen eingebunden. Jedoch für den upload nicht. Ist flash im edge installiert? Sonst schalt einfach auf den html5 modus um.

Warum jedoch durch das auskommentieren andere Bilder geladen werden sollen ist mir schleierhaft. Weil es gibt keine anderen ausser thumbnails und detail bilder...

Bei vernünftigen Browsern kommt der Upload dialog? Kommt beim edge ein Javascriptfehler?

Gruß, Michael


Top
 Profile  
 
PostPosted: 26. Jun 2017, 08:14 
Offline

Joined: 15. Jun 2017, 07:14
Posts: 12
Hallo,
die Sache mit dem Edge ist, dass Microsoft einen Flash Blocker integriert hat, welcher auf den meisten Seiten einen Button in der Symbolleiste aktiviert, mit dem man Flash für diese Seite freigeben kann.
Da in der Galerie das Upload-Feld per JS-Iframe geladen wird, aktiviert sich dieser Button nicht und somit wird nur die oben per Screenshot gezeigte Fehlermeldung angezeigt. Auch ein Umstellen der Uploadmethode von Flash auf HTML funktioniert nicht, es wird weiterhin diese Fehlermeldung angezeigt.
Hier wird das Problem beschrieben

Da die Option "Localhost-Loopback von Adobe Flash Player zulassen (dies kann ihr Gerät gefährden)" unter "about:flags" zu aktivieren auch keine Wirkung zeigt, scheint ein Zusammenspiel zwischen JS und Flash das Problem hervorzurufen!

Meiner Meinung nach gibt es 3 Lösungen für dieses Problem:
    1. veraltetes und verpöntes Flash raus nehmen
    2. das Uploadfeld in einer neuen Seite aufrufen, statt mit JS Popup zu arbeiten
    3. das Flash Uploadfeld versteckt auf jeder Seite laden, damit Edge rechtzeitig von der Verwendung von Flash auf dieser Seite "erfährt"

MfG Dan


PS: übrigens funktioniert "stripcontent" hier (http://www.tinywebgallery.com/demo/index.php?twg_album=01_Administration%2F01_admin&twg_show=409___Upload+-+TWG+Upload+Flash.gif&twg_lang=ch) auch nicht im Edge, und es wird auch der Button nicht angezeigt.


Top
 Profile  
 
PostPosted: 29. Jun 2017, 13:18 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10896
Ich muss mir das mal auf dem edge anschauen. Da dieser mit unter 2% Marktanteil läuft und die Upload funktionalität ja mit allen anderen Browser geht sehe ich das aktuell nicht zeitkritisch.

1. Hast du eine registrierte Version? Weil nur dort ist der html5 uploader fürs Frontend freigeschaltet.

1. Genau dafür ist der hhtml5 uploader ja da!
2. Da das popup ja einen iframe muss ich mal mal anschauen, ob schon ein anderes Einbinden hier weiterhilft.
3. keine Option!

stripcontent schau ich mir mal an. Weil dort wird eigentlich auch nur der flash für den Strip geladen. Hier kannst du einfach auf die nicht Flash variante umschalten..

Gruß, Michael


Top
 Profile  
 
PostPosted: 29. Jun 2017, 13:57 
Offline

Joined: 15. Jun 2017, 07:14
Posts: 12
Hallo Michael,

jepp, habe die registrierte Version - Standard Edition Lizenz. Auch im Firefox wird trotz
Code:
$admin_default_upload_method='html'
der Flash-Uploader geöffnet!

Übrigens lief Edge im Februar schon mit 5,55% Marktanteil 8) :roll: - aber darum gehts nicht, wer Windows 10 hat und sich nicht wirklich mit "Computern" auskennt, nutzt leider auch Edge... das führt schonmal zu Problemen.

MfG Dan


Top
 Profile  
 
PostPosted: 29. Jun 2017, 16:39 
Offline

Joined: 15. Jun 2017, 07:14
Posts: 12
So, Edgefehler behoben - habe ihn in die "$html5_upload_mobile_only" Abfrage eingebaut:

/i_frames/i_upload.php

Zeilen 58:
Code:
$show_html_upload = $twg_mobile || $isTablet || strstr($ua, 'edge');


Dabei hab ich folgenden Fehler entdeckt:

/i_frames/i_upload.php
Dein
Quote:
include "../inc/setbrowser.ini.php";
in Zeile 24 haut nicht hin... 1. heisst die zu inkludierende Datei setbrowser.inc.php, 2. wird die richtige Datei schon vorher inkludiert, sodass der 1. Fehler nicht aufgefallen, da trotzdem die abgefragten Werte vorhanden sind!



Quote:
PS:

Auch in Chrome wird die Abfrage, ob Flash auf dieser Seite zugelassen werden soll nicht aufgerufen... man muss umständlich in chrome://settings/content die Domain zulassen!!!

MfG


Last edited by Dan on 30. Jun 2017, 07:54, edited 1 time in total.

Top
 Profile  
 
PostPosted: 29. Jun 2017, 21:03 
Offline

Joined: 15. Jun 2017, 07:14
Posts: 12
Nun nochmal zu der Bildqualität...
In der mobilen Ansicht werden nur sehr kleine Bilder angezeigt. Wenn ich die Bilder dann mit den Fingern heranzoomen möchte, werden sie total verpixelt...
Offensichtlich bewirkt $twg_mobile = $enable_mobile_detection && $detect->isMobile(); in Zeile 51 der setbrowser.inc.php bzw. die irgendwann in irgendeiner Datei folgende Abfrage des reinen Vorhandenseins von $twg_mobile, dass das Lightbox-Plugin nicht ausgeführt wird - Leider bekommt man die Bildqualität/Bildgröße nur für das Lightbox-Plugin in den Einstellungen geregelt, für die HTML-Ansicht gilt das dann nicht.

Ich habe nun schon auf die schnelle versucht alle Dateien nach Aufrufen der Variable $twg_mobile zu durchsuchen und bin auch auf einige gestoßen, aber keine Änderung hat mir geholfen, das Lightbox-Plugin für die mobile Ansicht zu aktivieren... Hast Du auf die Schnelle eine Idee, welche Datei ich mir vornehmen muss, oder muss ich direkt ins JS eingreifen?

MfG und einen schönen Abend wünsche ich!


Top
 Profile  
 
PostPosted: 30. Jun 2017, 10:02 
Offline

Joined: 15. Jun 2017, 07:14
Posts: 12
Dan wrote:
Nun nochmal zu der Bildqualität...
In der mobilen Ansicht werden nur sehr kleine Bilder angezeigt. Wenn ich die Bilder dann mit den Fingern heranzoomen möchte, werden sie total verpixelt...
Offensichtlich bewirkt $twg_mobile = $enable_mobile_detection && $detect->isMobile(); in Zeile 51 der setbrowser.inc.php bzw. die irgendwann in irgendeiner Datei folgende Abfrage des reinen Vorhandenseins von $twg_mobile, dass das Lightbox-Plugin nicht ausgeführt wird - Leider bekommt man die Bildqualität/Bildgröße nur für das Lightbox-Plugin in den Einstellungen geregelt, für die HTML-Ansicht gilt das dann nicht.

Ich habe nun schon auf die schnelle versucht alle Dateien nach Aufrufen der Variable $twg_mobile zu durchsuchen und bin auch auf einige gestoßen, aber keine Änderung hat mir geholfen, das Lightbox-Plugin für die mobile Ansicht zu aktivieren... Hast Du auf die Schnelle eine Idee, welche Datei ich mir vornehmen muss, oder muss ich direkt ins JS eingreifen?

MfG und einen schönen Abend wünsche ich!



Guten morgen...

habe nun eine Lösung gefunden, zumindest für Smartphones ist nach folgenden Anpassungen die Lightbox-Ansicht aktiviert:

setspecials.inc.php:
Zeile 65 und Zeile 70 auskommentieren und in Zeile 69 $enable_download auf true setzen:
Code:
    //$default_is_fullscreen = $open_in_maximized_view = $enable_maximized_view = $twg_mobile_use_maximized_view;
    if ($twg_mobile_use_maximized_view) {
        $use_round_corners = false;
    }
    $enable_download = true; // needed to activate swipe !
    //$activate_lightbox_image = $activate_lightbox_thumb = !$twg_mobile_use_maximized_view;

Ich werde das ganze noch auf nem Tablet (hab ich jetzt leider nicht dabei) testen, aber evtl. muss dafür in Zeile 86 ebenfalls $enable_download auf true gesetzt sowie Zeile 88 auskommentiert werden.



Kannst du evtl. in einer nächsten Version eine Abfrage in die setspecials.inc.php einbauen à la:
Code:
   if(!isset($lbinmobile)){
      $default_is_fullscreen = $open_in_maximized_view = $enable_maximized_view = $twg_mobile_use_maximized_view;
   }
   if(!isset($lbinmobile)){
      $enable_download = false; // needed to activate swipe !
   }else{
      $enable_download = true; // swipe funzt trotzdem !
   }
   if(!isset($lbinmobile)){
      $activate_lightbox_image = $activate_lightbox_thumb = !$twg_mobile_use_maximized_view;
   }

Dann könnte man in der my_config.php $lbinmobile setzen und somit die lightbox aktivieren.

MfG Dan


Top
 Profile  
 
PostPosted: 30. Jun 2017, 14:19 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10896
Schau ich mir mal an

$admin_default_upload_method='html' ist übrigens falsch.

$html5_upload_mobile_only=false;

ist das richtige. Und alle weiteren Einstellungen für
$html5_upload

sind für den html5 uploader. Deine Einstallung ist nur für die Administration.

Gruß, Michael


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 23 posts ]  Go to page 1, 2  Next

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
powered by phpbb | Datenschutz/ Privacy policy