Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 18. Jun 2018, 13:18

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 9 posts ] 
Author Message
PostPosted: 14. Nov 2017, 15:32 
Offline

Joined: 20. Feb 2009, 11:04
Posts: 118
Location: Germany, NRW
Hallo,

da Flash ja mittlerweile immer "unbeliebter" wird, stellt sich mir die Frage, wie Besucher die Filme in meiner Galerie abspielen können, auch wenn sie nicht Flash im Browser aktiviert haben (Fehlermeldung: The flash could not be loaded. Install/activate/update the flash plugin to watch this video.).
Beim Upload kann man ja bereits auf Flash verzichten. Gibt es beim Videoabspielen auch eine Möglichkeit?

_________________
Gruß
Dirk

Urlaubsinfos+Bilder: Griechenland, Portugal, Spanien,
USA, Karibik, Niederlande, Frankreich und Deutschland
Homepage: https://www.travel-infopoint.de/
HP-Forum: https://forum.travel-infopoint.de


Top
 Profile  
 
PostPosted: 14. Nov 2017, 16:07 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10833
Natürlich. HTML5 oder youtube per iframe einbinden.
Beides im video howto beschrieben.

http://www.tinywebgallery.com/demo/twg_album/01_Administration~02_html5_player

Gruß, Michael


Top
 Profile  
 
PostPosted: 17. Nov 2017, 12:36 
Offline

Joined: 20. Feb 2009, 11:04
Posts: 118
Location: Germany, NRW
Die video.php sieht jetzt wie folgt aus:
<?php
$video_size_x=640;
$video_size_y=480;
$video_player="IFRAME";
$video_autostart=false;
$video_flash_site="http://www.youtube.com/embed/";
$video_autostart_parameter="&autoplay=0";
$video_show_dl_link=false;
$show_rotation_buttons=false;
?>

Funktioniert in Firefox, Edge und Chrome.
Leider nicht beim Internet-Explorer 11.

Was muss ich machen, damit eine Kompatibilität ohne Flash mit allen gängigen Browsern gegeben ist?

_________________
Gruß
Dirk

Urlaubsinfos+Bilder: Griechenland, Portugal, Spanien,
USA, Karibik, Niederlande, Frankreich und Deutschland
Homepage: https://www.travel-infopoint.de/
HP-Forum: https://forum.travel-infopoint.de


Top
 Profile  
 
PostPosted: 17. Nov 2017, 16:31 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10833
Hast du nen Link. weil das ist das direkte include von youtube. Das sollte auch auf em IE funktionieren.

Gruß, Michael


Top
 Profile  
 
PostPosted: 17. Nov 2017, 16:55 
Offline

Joined: 20. Feb 2009, 11:04
Posts: 118
Location: Germany, NRW
http://www.travel-infopoint.de/nordamerika/bildergalerie/index.php?twg_album=usa%2Flasvegas%2FLas+Vegas+-+Filme

_________________
Gruß
Dirk

Urlaubsinfos+Bilder: Griechenland, Portugal, Spanien,
USA, Karibik, Niederlande, Frankreich und Deutschland
Homepage: https://www.travel-infopoint.de/
HP-Forum: https://forum.travel-infopoint.de


Top
 Profile  
 
PostPosted: 17. Nov 2017, 17:26 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10833
der IE switcht auf version 5 - muss ich mal schauen warum er auf den schwachsinn kommt. Weil er wirft einen Javascript fehler.
Wenn ich auf Edge stelle ist alles gut.


Top
 Profile  
 
PostPosted: 18. Nov 2017, 02:00 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10833
setz mal $use_ie_compability_mode=false;

Gruß, Michael


Top
 Profile  
 
PostPosted: 23. Nov 2017, 14:46 
Offline

Joined: 20. Feb 2009, 11:04
Posts: 118
Location: Germany, NRW
Hab das jetzt mal in die video.php gesetzt.
Das Video läuft jetzt auch mit IE 11, aber die Farbinformationen für Kopf- und Fussteile sind nicht mehr vorhanden (weiss in allen Browsern, auch auf einem Android-Smartphone).

_________________
Gruß
Dirk

Urlaubsinfos+Bilder: Griechenland, Portugal, Spanien,
USA, Karibik, Niederlande, Frankreich und Deutschland
Homepage: https://www.travel-infopoint.de/
HP-Forum: https://forum.travel-infopoint.de


Top
 Profile  
 
PostPosted: 25. Nov 2017, 17:58 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10833
Komisch. Das setzt nur ein Flag für IE. Die anderen Browser sollen das gar nicht kennen.
Ich muss mir dann da auch mal die Browsererkennung anschauen. Weil das sollte die eigentlich nur für alle IEs setzen.

Gruß, Michael


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron
powered by phpbb | Datenschutz/ Privacy policy