Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 20. Jun 2018, 07:25

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 14 posts ] 
Author Message
 Post subject: error http - 500
PostPosted: 26. Jan 2015, 15:23 
Offline

Joined: 23. Jan 2015, 18:39
Posts: 8
Hi all and sorry for my bad English.
I have two problems:
1) I can’t see the remote folder in flash uploader (and also the path is missing on the title zone as marked with a red rectangle)
2) when I try to upload an image, the progress bar is ok, but at the end of the process I get the “http-500” error
I attached a screenshot.
Attachment:
error.jpg
error.jpg [ 38.73 KiB | Viewed 622 times ]


I have the same behavior if I use backend and also if I use frontend.
This is the first installation.
I’m using Joomla 2.5.24 and JFUploader 3.2.1
I already tried with tfu_faq_1 but I can’t resolve the problem.
I haven’t any tfu.log file and I uploaded images without using any firewall (but I don’t know my internet service provider has…..)
Many thanks for any help.


Top
 Profile  
 
 Post subject: Re: error http - 500
PostPosted: 26. Jan 2015, 16:15 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10833
Error 500 is a server error. These are reported to the server error log.
Have you access to this file?

Best, Michael


Top
 Profile  
 
 Post subject: Re: error http - 500
PostPosted: 26. Jan 2015, 17:05 
Offline

Joined: 23. Jan 2015, 18:39
Posts: 8
Do you mean the "apache web server" log file?
Or php log file?
Please can you tell me more about these file?
At the moment I don't know how to retrieve these logs.
Any other solution?
If there aren't other solutions, I will ask my friends if they can teach me how to retrieve these log file and i will post as soon as possible (maybe 4 or 5 days.....).
Many thanks.


Top
 Profile  
 
 Post subject: Re: error http - 500
PostPosted: 26. Jan 2015, 17:34 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10833
apache error log file is the one you need. Many hosters offer that you download the last e.g. 500 lines of this file.

Have you enabled the full debug? Because you maybe get some additional infos there. Getting some infos why the server listing does not work would be the first step.

Best, Michael


Top
 Profile  
 
 Post subject: Re: error http - 500
PostPosted: 26. Jan 2015, 18:14 
Offline

Joined: 23. Jan 2015, 18:39
Posts: 8
Now I enabled the following options:
Enable upload debug
Enable enhanced debug
and I uploaded an image again, but the file tfu.log is not present because I checked into:
Info / Limits / Register page and there was "No debug found"
via ftp on tfu remote directory but there isn't any log file.

If you need it I will try to get the apache error log file, but I think I will take some days.


Top
 Profile  
 
 Post subject: Re: error http - 500
PostPosted: 26. Jan 2015, 18:46 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10833
but if you call tfu_login.php directly you don't get an error?

Best, Michael


Top
 Profile  
 
 Post subject: Re: error http - 500
PostPosted: 26. Jan 2015, 19:00 
Offline

Joined: 23. Jan 2015, 18:39
Posts: 8
I called the tfu_login.php in my browser and this is the answer:

"You server is configured properly to access the needed files of JFU.
Please go to the Joomla Administration of JFU to see your server limits."


Top
 Profile  
 
 Post subject: Re: error http - 500
PostPosted: 26. Jan 2015, 21:23 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10833
then you need to check the server log file what is causing the http 500


Top
 Profile  
 
 Post subject: Re: error http - 500
PostPosted: 26. Jan 2015, 23:36 
Offline

Joined: 23. Jan 2015, 18:39
Posts: 8
I tried to upload file from another computer from another network and finally i get an error in the Info / Limits / Register page and this is the log:

01.26.2015 17:58:37 - Config call, illegal direct access or missing session settings - your browser has to be closed to get a new session. Please check your session_save_path if you get this error all the time or create the folder session_cache in the tfu folder to activate the session workaround.
01.26.2015 18:01:43 - Config call, illegal direct access or missing session settings - your browser has to be closed to get a new session. Please check your session_save_path if you get this error all the time or create the folder session_cache in the tfu folder to activate the session workaround.
01.26.2015 18:23:14 - Config call, illegal direct access or missing session settings - your browser has to be closed to get a new session. Please check your session_save_path if you get this error all the time or create the folder session_cache in the tfu folder to activate the session workaround.
01.26.2015 18:23:17 - Config call, illegal direct access or missing session settings - your browser has to be closed to get a new session. Please check your session_save_path if you get this error all the time or create the folder session_cache in the tfu folder to activate the session workaround.
01.26.2015 18:23:19 - Config call, illegal direct access or missing session settings - your browser has to be closed to get a new session. Please check your session_save_path if you get this error all the time or create the folder session_cache in the tfu folder to activate the session workaround.
01.26.2015 18:23:26 - Config call, illegal direct access or missing session settings - your browser has to be closed to get a new session. Please check your session_save_path if you get this error all the time or create the folder session_cache in the tfu folder to activate the session workaround.

Any idea?


Top
 Profile  
 
 Post subject: Re: error http - 500
PostPosted: 27. Jan 2015, 10:16 
Offline

Joined: 23. Jan 2015, 18:39
Posts: 8
I found in my php.ini there is the following parameter:
session.save_path = /tmp

Then I changed permission of /tmp from RWX R-X R-X to RWX RWX RWX

I tried upload again and i got a new error (not more http 500) the following:
"Errore Http 403/406: Copia il file .htaccess fornito nella directory di twg_flash_uploader.swf."

I created the .htaccess using the link in the upload page but now flash uploader doesn't work anymore: there is a warning pop-up with the message:
Attachment:
new error.jpg
new error.jpg [ 41.42 KiB | Viewed 598 times ]



Any idea?
Thanks.


Top
 Profile  
 
 Post subject: Re: error http - 500
PostPosted: 27. Jan 2015, 10:28 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10833
Than most likely the command to disable mod_security are not allowed/recognized by your server.
You would have to ask your hoster how to disable mod_security for the folder where the .swf file is located.

Best,
Michael


Top
 Profile  
 
 Post subject: Re: error http - 500
PostPosted: 27. Jan 2015, 11:31 
Offline

Joined: 23. Jan 2015, 18:39
Posts: 8
In "Installation of the JFUploader" page there is written:
"There could be problem with the installation when your server does have safe mode active. To install JFU with safe mode properly please Use the safe mode patch"

I would ask:
safe mode and mod_security are the same?
installing patch can solve the problem?
where can I download this patch?

If you think this patch can't solve the problem, I will ask my hoster how to disable mod_security for the folder where the .swf file is located.

Many thanks.


Top
 Profile  
 
 Post subject: Re: error http - 500
PostPosted: 27. Jan 2015, 12:43 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10833
This are two different things. safe mode is something from php, mod_security a module of Apache.

Best, Michael


Top
 Profile  
 
 Post subject: Solved: error http - 500
PostPosted: 5. Feb 2015, 13:28 
Offline

Joined: 23. Jan 2015, 18:39
Posts: 8
I solved the problem: I set 755 permission to ALL files and ALL directories under com_jfuploader and now it works!!
Best regards.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 14 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
powered by phpbb | Datenschutz/ Privacy policy