Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 18. Jun 2018, 13:26

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: 24. Aug 2010, 12:54 
Offline

Joined: 24. Aug 2010, 12:20
Posts: 1
the problem:

search engines are trying send parameters in their requests witch are not existing in the system. So the engines are detecting sites witch are responding on each request a 200 ok header.

such sites mostly become bad rated. sites responding a 404 header in case of responding at invalid request parameters are rated much better

you twg is build so that it is responding in case of requests like eg this:
Quote:
/index.php?twg_album=syzjrryexhjx


a header 200 ok - although - the album (directory) "syzjrryexhjx" doesn't exists.

The twg for such cases is informing admittedly the user about fact of no existing album - but the search engine became no info in form of response 404 "file not found" but 200 OK - so the search engines are collecting hundreds of bad links to the twg - site.

All that sites have the same content - the information about no existing album and instructions about handling this error.

a mass of sites with the same content nevertheless matters that search engines will possible excluding the website from index.

the solution would be, to check before sending the first response header or output to the client, if the sent by client request is valid and sending a 404 header in case of invalid request.


Top
 Profile  
 
 Post subject:
PostPosted: 24. Aug 2010, 17:11 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10833
how should I make a difference between a valid and an invalid request?

If a user has e.g. an old bookmark then he gets a 404?

Or do you mean that I should send 404 as response code and still display my album not found page?

- Michael


Top
 Profile  
 
 Post subject:
PostPosted: 24. Aug 2010, 22:43 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10833
Hi,

I have added the 404 response. Do you want to test this version?
Please send me an e-mail then.

- Michael


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
powered by phpbb | Datenschutz/ Privacy policy