Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 16. Dec 2018, 17:21

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 6 posts ] 
Author Message
PostPosted: 31. Jan 2018, 17:19 
Offline

Joined: 31. Jan 2018, 17:09
Posts: 3
So I just bought the Pro version.

The page I'm trying to integrate is an old php page and the urls work with parameters. The page that should be in the iframe is on the same domain! Like this
"http://www.my-wordpress-website.com/site-to-integrate/index1.php?action=subpage"

Mapping the page url works fine. However I want to exclude the whole "http://www.my-wordpress-website.com/site-to-integrate/index1.php?action=" part and only keep the parameter value. I want my result to look like this:
"http://www.my-wordpress-website.com/iframe-page/?page=subpage"

Here's my shorcode

Code:
[advanced_iframe securitykey="****" use_shortcode_attributes_only="true" src="http://www.my-wordpress-website.com/site-to-integrate/index1.php" width="100%" height="600" id="advanced_iframe" map_parameter_to_url="page" add_iframe_url_as_param="same" add_iframe_url_as_param_prefix="www.my-wordpress-website.com%2Fsite-to-integrate%2Findex1.php%3Faction%3D" onload_resize_delay="2" resize_on_element_resize="#main" enable_external_height_workaround="false" ]


Sadly it just wont cut away the prefix value. It will still add the entire iframe url to my "?page=" parameter.

Whats wrong?


Top
 Profile  
 
PostPosted: 31. Jan 2018, 19:21 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10956
please decode the parameter and use
www.my-wordpress-website.com/site-to-integrate/index1.php?action=

only.

Best, Michael


Top
 Profile  
 
PostPosted: 1. Feb 2018, 16:21 
Offline

Joined: 31. Jan 2018, 17:09
Posts: 3
Thank you! That did the trick!
Solved.


Top
 Profile  
 
PostPosted: 1. Feb 2018, 17:39 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10956
:).


Top
 Profile  
 
PostPosted: 13. Feb 2018, 16:39 
Offline

Joined: 31. Jan 2018, 17:09
Posts: 3
Okay now I have a follow-up problem. Trimming the url works as intended, however when I try to directly access that page I get a server "http" not found error. Edge will give me this: "Please make sure that you are using the correct adress: http://http"

I've tried url_forward_parameter="" but this will only work if the forwared parameter and the mapped parameter are not the same. The problem is that then when I navigate to another subpage it will add the mapped parameter behind the original one, basically giving me something like this: "http://www.my-wordpress-website.com/iframe-page/?page=subpage&action=othersubpage"

Is it possible to have both parameter mapping and forwarding work together?


Top
 Profile  
 
PostPosted: 13. Feb 2018, 18:55 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10956
I don't really understand the problem.

but please check
http://www.tinywebgallery.com/blog/advanced-iframe/advanced-iframe-pro-demo/url-features#h49

This is the much more advanced way to may anything from the parent url to the iframe url.

Best, Michael


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
powered by phpbb | Datenschutz/ Privacy policy