Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 15. Dec 2018, 09:32

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 10 posts ] 
Author Message
PostPosted: 2. Jul 2017, 22:18 
Offline

Joined: 15. May 2016, 21:44
Posts: 70
Hi
After updating from v7.4.1 to v7.4.3 (and implementing https) the map_parameter_to_url is not working anymore. My shortcode look like this:
Code:
[advanced_iframe securitykey="696a4ef4xxcxcxcxcxc18393" use_shortcode_attributes_only="true" src="https://www.hafdal.dk/tng/cemeteries.php" width="100%" height="800" scrolling="auto" id="legstadaleit1" name="legstadaleit" map_parameter_to_url="page" add_iframe_url_as_param="same" resize_on_ajax_jquery="false" ]


My iframe is here: http://www.hafdal.dk/legstadaleit/gagnagrunnur/?lang=is&page=undefined and if you try to click some of the links inside the iframe you can see that no page url is being added.
Best regards
Rakel


Top
 Profile  
 
PostPosted: 3. Jul 2017, 22:23 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10955
is the https the problem?

you can also use the placeholders in the src:

https://www.hafdal.dk/tng/cemeteries.php?page={query-page}

Best, Michael


Top
 Profile  
 
PostPosted: 4. Jul 2017, 00:35 
Offline

Joined: 15. May 2016, 21:44
Posts: 70
Hi again Michael
I changed my code to this:
Code:
[advanced_iframe securitykey="696a4efsfdafdafdafdasfdas5446cd18393" use_shortcode_attributes_only="true" src="https://www.hafdal.dk/tng/cemeteries.php?page={query-page}" width="100%" height="800" scrolling="auto" id="legstadaleit1" name="legstadaleit" map_parameter_to_url="page" add_iframe_url_as_param="same" resize_on_ajax_jquery="false" ]


Still have problems with the map_parameter_to_url.
Also I noticed that the automatic iframe resize no longer works.

All this happened when I changed my src to https instead of http.
Best regards
Rakel


Top
 Profile  
 
PostPosted: 4. Jul 2017, 13:04 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10955
you main page is still http?

http://www.hafdal.dk/legstadaleit/gagnagrunnur/?lang=is&page=undefined

because the link above already seems invalid to me. If you only change half of the setup you have a completely different scenario! mixing http with https! Then you suddenly need cross origin communication!

So what is the entry link. because above I already get an error! If I use different links I get errors in the Javascript console about mixed content!

also you have errors like:
Mixed Content: The page at 'https://www.hafdal.dk/tng/headstones.php?country=Canada&state=Manitoba&county=R.+M.+of+Lakeview&tree=Tree2' was loaded over HTTPS, but requested an insecure script 'http://cdn.jsdelivr.net/wp/wp-slimstat/trunk/wp-slimstat.js'. This request has been blocked; the content must be served over HTTPS.

So you have different problems with your https change also!

Best, Michael


Top
 Profile  
 
PostPosted: 9. Jul 2017, 23:01 
Offline

Joined: 15. May 2016, 21:44
Posts: 70
You are absolutely correct. I thought I had changed my website to https (I have problems with my memory) but when I checked I could see that it wasn't. After fixing that, I no longer had issues.

However I still have an issue with the automatic iframe resize, it does not work. See here: https://www.hafdal.dk/legstadaleit/database/?page=s|www.hafdal.dk%2Ftng%2Fgetperson.php%3FpersonID%3DI4179%26tree%3DTree2

Best regards
Rakel


Top
 Profile  
 
PostPosted: 9. Jul 2017, 23:08 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10955
It does not work because you still have mixed content there:

Mixed Content: The page at 'https://www.hafdal.dk/legstadaleit/database/?page=s|www.hafdal.dk%2Ftng%2Fgetperson.php%3FpersonID%3DI4179%26tree%3DTree2' was loaded over HTTPS, but requested an insecure script 'http://www.hafdal.dk/legstadaleit/wp-content/plugins/advanced-iframe/js/ai_external.js'. This request has been blocked; the content must be served over HTTPS.

ai_external.js also needs to be loaden from a https site!.

Best, Michael


Top
 Profile  
 
PostPosted: 11. Jul 2017, 04:33 
Offline

Joined: 15. May 2016, 21:44
Posts: 70
Ah! Of course!
I have now changed that and the iframe resize is working, but.....
When a page loads there is a scrollbar on the iframe, not scrollable but still... any way to remove that scrollbar? It doesn't really change anything so if it is not possible, that is okay. It just annoys me a little :roll: :lol:


Top
 Profile  
 
PostPosted: 11. Jul 2017, 17:38 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10955
I don't see a scrollbar. you can simply set scrolling="no" to remove the scrollbar.

Best, Michael


Top
 Profile  
 
PostPosted: 11. Jul 2017, 21:14 
Offline

Joined: 15. May 2016, 21:44
Posts: 70
Brilliant! Thank you!!


Top
 Profile  
 
PostPosted: 12. Jul 2017, 16:24 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10955
You are welcome.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron
powered by phpbb | Datenschutz/ Privacy policy