Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 19. Aug 2019, 22:47

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 8 posts ] 
Author Message
PostPosted: 4. Jul 2019, 22:41 
Offline

Joined: 4. Jul 2019, 22:29
Posts: 4
I have uses Advanced iFrame for abut 2 years with no problems. I have a wordpress website and I use LearnDash as my LMS. LearnDash recently upgraded to a new version of their plugin. Now when I try to insert a link nothing happens/appears. Current courses that include a link still work fine, but I can't replace or insert a new link.

Her is what a current functional link looks like: [advanced_iframe securitykey="99073a2b284a7ae9a6d36111a36b552b93cd5c33" src="/Presentations/MIPPEssentialsHKHPCL/MIPPEssentialsIntroductionSessionHKHPCL/index.html" width="100%" height="600"]

I contacted LearnDash and this was their response:

This is something that you need to bring up with the Advanced iFrame Plugin team. Surely something changed in LD 3.0 which is affecting the display. This way they can tell us what change broke the display and we can correct or otherwise advise them on how they should adjust their code.

Can someone help me??

Mark


Top
 Profile  
 
PostPosted: 4. Jul 2019, 23:46 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 11153
can you provide a full link/url that works and one that does not?

Best, Michael


Top
 Profile  
 
PostPosted: 4. Jul 2019, 23:54 
Offline

Joined: 4. Jul 2019, 22:29
Posts: 4
Thanks for getting involved.

https://accurateergonomics.com/lessons/mipp-essentials-introduction-session-hkhp-cl-wd/

I am really not a web guru. I think this is what you want.

I cant =send you one that does not work, because it will not even paste a link anymore.

Mark


Top
 Profile  
 
PostPosted: 5. Jul 2019, 07:48 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 11153
Hi,

if i click on your link i get redirected to
https://accurateergonomics.com/courses/ and there is no iframe.

I don't understand what "because it will not even paste a link anymore." means. where?
Because below you only posted a shortcode..

I still think it is very strange that if someone is updating an plugin and than it does not work and then another plugin which runs for 2 years should be the problem...

Best, Michael


Top
 Profile  
 
PostPosted: 5. Jul 2019, 22:51 
Offline

Joined: 4. Jul 2019, 22:29
Posts: 4
Hi,

When I (Mark) click on the link I sent you it takes me to a course/module, then the presentation starts (it is a powerpoint file converted for the lms).

Here it is again...

https://accurateergonomics.com/lessons/mipp-essentials-introduction-session-hkhp-cl-wd/

When I build a course I open a window/editor similar to this in learndash. In that box I click on the Advanced iFrame button and typically it inserts a link. Then I add the language/directions that link the new iFrame link to my server.

When I click on it now, nothing happens...

However, if I copy a link from another course and paste it in a new one, the link works...???

Looks like this: [advanced_iframe securitykey="99073a2b284a7ae9a6d36111a36b552b93cd5c33" src="/Presentations/MIPPEssentialsCLSP/MIPPEssentialsModuleThreeHKHPCLSP/index.html" width="100%" height="600"]

Mark


Top
 Profile  
 
PostPosted: 8. Jul 2019, 09:21 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 11153
so you mean that they have their own editor and there is also an "add" advanced iframe button?
and this does not work anymore? So can you not simply add the whole short code by yourself?

I can only support the default editors of Wordpress.

Best, Michael


Top
 Profile  
 
PostPosted: 9. Jul 2019, 01:17 
Offline

Joined: 4. Jul 2019, 22:29
Posts: 4
Hi Michael, here is the response I got from LearnDash...

Indeed it looks like something in the Advanced iFrame plugin is causing this.

When attempting to use the button, there's a JavaScript error being thrown:

The error is coming from this URL: https://accurateergonomics.com/wp-content/plugins/advanced-iframe/js/ai_editor_button.js?ver=457033

(404 no found).

I tested on a regular post as well and seems the button isn't working there either.

Since this is a live site, I didn't want to deactivate all plugins to see if there's a plugin conflict between LearnDash and Advanced iFrame.

If there is something in LearnDash, our devs would be happy to look into fixing this if Advanced iFrame devs can share what might be causing this.

Kindly, Rashid - LearnDash.com


Top
 Profile  
 
PostPosted: 11. Jul 2019, 00:57 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 11153
Please check why https://accurateergonomics.com/wp-content/plugins/advanced-iframe/js/ai_editor_button.js

is missing! is it in the normal release! If not install it from the plugin zip again!

Best, Michael


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: Bing [Bot] and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
powered by phpbb | Datenschutz/ Privacy policy