Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 25. Sep 2018, 14:54

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 6 posts ] 
Author Message
PostPosted: 18. Jun 2017, 05:35 
Offline
User avatar

Joined: 13. Apr 2015, 18:55
Posts: 50
Hai Michael,

All our sites are now running fine with the external workaround in http.
Slowly but surely I thought I got every scenario covered...
But then one of my customers wanted https on his wordpress site and webshop....
So I switched everything to https

- The website containing the iFrame is https --> https://www.broekmans.nl/webshop
- The iFrame site is https --> https://webshop-wordpress.broekmans.nl
- The external_ai.js is available at https://www.broekmans.nl/wp-content/plugins/advanced-iframe/js/ai_external.js
- Added the postmessage vars in the pages...

But somehow it does not work....

I added the following vars in the page:
<script>
var updateIframeHeight = true;
var keepOverflowHidden = false;
var resize_on_element_resize_delay = "200";
var element_to_measure = "container";
var usePostMessage = true;
var dataPostMessage = true;
</script>
<script src="https://www.broekmans.nl/wp-content/plugins/advanced-iframe/js/ai_external.js"></script>

Any clue what goes wrong and how I can get this to work?
regards and thanx again, Marc

_________________
Greetings from sunny Curaçao!


Last edited by marcverkade on 24. Jun 2017, 18:20, edited 1 time in total.

Top
 Profile  
 
PostPosted: 18. Jun 2017, 21:47 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10896
var dataPostMessage = true;

is the error! this is a feature to send data from the iframe to the partent
This is a string and you defined a boolean. And therefore you get an exception which then breaks the whole script...

Simply remove it.

Best, Michael


Top
 Profile  
 
PostPosted: 19. Jun 2017, 06:02 
Offline
User avatar

Joined: 13. Apr 2015, 18:55
Posts: 50
Errr... It is on your page!
http://www.tinywebgallery.com/blog/advanced-iframe/advanced-iframe-pro-demo/external-workaround-with-post-message#e51

<script>
var iframe_id = "example51";
var updateIframeHeight = "true";
var hide_page_until_loaded_external = "true";
var iframe_hide_elements = "#iframe-header,#iframe-footer,#some-images";
var iframe_content_id = "#iframe-content";
var iframe_content_styles = "color:#ff0000";
/* This is the difference to example 6 */
var usePostMessage = true;
var dataPostMessage = true;

</script>

_________________
Greetings from sunny Curaçao!


Top
 Profile  
 
PostPosted: 19. Jun 2017, 06:09 
Offline
User avatar

Joined: 13. Apr 2015, 18:55
Posts: 50
Hai Michael,

I already had tried "true" before but since that was not working I searched and found your page and tried that (see post before).

I have adjusted the vars as you said but still no luck.
Any other clue why auto-height is not working?

This is what the site has now:
<script>
var updateIframeHeight = "true";
var keepOverflowHidden = "false";
var resize_on_element_resize_delay = "200";
var usePostMessage = "true";
var element_to_measure = "container";
</script>
<script src="https://www.broekmans.nl/wp-content/plugins/advanced-iframe/js/ai_external.js"></script>

_________________
Greetings from sunny Curaçao!


Top
 Profile  
 
PostPosted: 19. Jun 2017, 06:16 
Offline
User avatar

Joined: 13. Apr 2015, 18:55
Posts: 50
Aha... Forget my last message!
The site was also running in http.... I had to specify https explicitly...

At https://www.broekmans.nl it does resize (Great stuff, major thanx!)
At http://www.broekmans.nl it does not resize (which is logic!)

Perhaps adjust your page and add quotes so other people do not have the same issue:
http://www.tinywebgallery.com/blog/advanced-iframe/advanced-iframe-pro-demo/external-workaround-with-post-message#e51

var usePostMessage = true; --> "true"
var dataPostMessage = true; --> "true"

Major thanx again for your great product and support!
Regards, Marc

_________________
Greetings from sunny Curaçao!


Top
 Profile  
 
PostPosted: 23. Jun 2017, 23:52 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10896
I fixed the demos.

var usePostMessage = true;

is correct btw!

Thanks.

Best, Michael


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
powered by phpbb | Datenschutz/ Privacy policy