Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 13. Dec 2018, 03:52

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 15 posts ] 
Author Message
PostPosted: 10. Sep 2017, 04:30 
Offline

Joined: 10. Sep 2017, 04:26
Posts: 11
Dear Michael, I purchased Advanced iFrame Pro and can’t get it to work as I need it to. It will be something I am not doing but I don’t understand what to do next.

What I’d like it to do is display each relevant forum link in the address bar as if it was operating outside of a frame so that the forum URLs can be bookmarked/emailled.

I have the following shortcode in this page. I want to pass each forum URL to the address field as stated.

[advanced_iframe securitykey=”my security key” use_shortcode_attributes_only=”true” src=”http://m49.siteground.biz/~epi4dogs/forum/index.php” width=”100%” height=”600″ scrolling=”no” id=”advanced_iframe” onload_resize=”true” store_height_in_cookie=”true” resize_on_ajax_jquery=”false”map_parameter_to_url=”page” add_iframe_url_as_param=”same”]

No matter what i do the page URL remains the same.

I am using this example http://www.tinywebgallery.com/blog/advanced-iframe/advanced-iframe-pro-demo/add-iframe-url-to-parent/add-iframe-url-as-param-same-domain

Can you advise please?

thank you,

Craig


Top
 Profile  
 
PostPosted: 10. Sep 2017, 13:50 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10955
http://m49.siteground.biz/~epi4dogs/forum-embed/ does work somehow.

But it seems you have a missing space is the config!

I recommend to enable the check of the short code on the introduction tab.

Best, Michael


Top
 Profile  
 
PostPosted: 23. Sep 2017, 08:05 
Offline

Joined: 10. Sep 2017, 04:26
Posts: 11
Thanks Michael,

I got the URL to pass through to the address bar and have each url unique which is great and I have only one issue to resolve.

I need to enable permanent URLs. At present URLs do not appear to be universal in that I think they're being governed by a session ID? (I'm not a programmer so am happy o be wrong). What this means is that if I email someone a link to an individual thread for example, the link will resolve in taking the recipient to the forum homepage and not the individual thread.

Example: this thread link when emailed to another person (or put in another browser)
http://m49.siteground.biz/~epi4dogs/forum-embed/=http%3A%2F%2Fm49.siteground.biz%2F~epi4dogs%2Fforum%2Fviewtopic.php%3Ff%3D2%26t%3D5%26sid%3D95025276070a84c61aba6d60985ab91e

Resolves as http://m49.siteground.biz/~epi4dogs/forum-embed/

How can I enable permanent URLs?


Top
 Profile  
 
PostPosted: 24. Sep 2017, 21:27 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10955
http://m49.siteground.biz/~epi4dogs/forum-embed/=http%3A%2F%2Fm49.siteground.biz%2F~epi4dogs%2Fforum%2Fviewtopic.php%3Ff%3D2%26t%3D5%26sid%3D95025276070a84c61aba6d60985ab91e

is missing the like page=
map_parameter_to_url="page"

is not seen in the shortcode. Have you enabled the check of the shortcode?

Best, Michael


Top
 Profile  
 
PostPosted: 27. Dec 2017, 02:25 
Offline

Joined: 10. Sep 2017, 04:26
Posts: 11
Hi Michael,

I didn't quite understand your reply last time so had to put this to one side, but I now have the time to try and get it working properly.

With the check enabled I get the following message;

====
User agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:52.0) Gecko/20100101 Firefox/52.0

Headers of http://m49.siteground.biz/~epi4dogs/forum/index.php:
HTTP/1.1 200 OK
Server: nginx
Date: Wed, 27 Dec 2017 00:14:12 GMT
Content-Type: text/html; charset=UTF-8
Connection: keep-alive
Cache-Control: private, no-cache="set-cookie"
Expires: Wed, 27 Dec 2017 00:14:12 GMT
Set-Cookie: phpbb3_zwxye_u=1; expires=Thu, 27-Dec-2018 00:14:12 GMT; path=/; domain=www.epi4dogs.com; HttpOnly
Set-Cookie: phpbb3_zwxye_k=; expires=Thu, 27-Dec-2018 00:14:12 GMT; path=/; domain=www.epi4dogs.com; HttpOnly
Set-Cookie: phpbb3_zwxye_sid=845679556190ff95f1cac882085a6e34; expires=Thu, 27-Dec-2018 00:14:12 GMT; path=/; domain=www.epi4dogs.com; HttpOnly
Host-Header: 192fc2e7e50945beb8231a492d6a8024

The page does exist and no X-Frame-Options header was found. But there can still be a iframe blocker script on this page. Go here for a full check.

====

When I use the Free iframe checker v2.0http://www.tinywebgallery.com/blog/advanced-iframe/free-iframe-checker all I get is this error 'This seems not like a valid url. Please enter a valid url.'

I am at a loss to know what to do. I have been through all the options the majority of which seem very technical for the simple thing I want to achieve. I just want to pass URLs from the forum in the frame to the header. That's all I want advanced iFrame to do. It needs to be done in a persistent form so that they can be bookmarked and remain valid.

Appreciate your advice. I have installed the latest version 7.5.2.

Craig


Last edited by MrClicky on 31. Dec 2017, 00:20, edited 2 times in total.

Top
 Profile  
 
PostPosted: 27. Dec 2017, 18:24 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10955
I asked you to enable the internal check of the shortcode: This is the 2nd paramter of the options: "Check shortcode". You enabled the debug :).

in you shortcode you have:
resize_on_ajax_jquery=”false”map_parameter_to_url=”page”
But you forgot a space!
resize_on_ajax_jquery="false" map_parameter_to_url="page"

is correct. The "Check shortcode" would have told you this.
This is not enabled by default because this would kill wrong existing but still somehow working shortcodes!

Best, Michael


Top
 Profile  
 
PostPosted: 28. Dec 2017, 07:08 
Offline

Joined: 10. Sep 2017, 04:26
Posts: 11
Quote:
I asked you to enable the internal check of the shortcode: This is the 2nd paramter of the options: "Check shortcode". You enabled the debug

After enabling the internal check of the shortcake nothing happened so I enabled the debug.

I am just using the shortcode [advanced_iframe securitykey="98af2de36f8925e18977dfxxx"] so am not sure what you're referring to regarding the space.

Regardless, I uninstalled the plugin and reinstalled fresh. After changing the cookie settings in phpBB forum I've been able to remove the session ID so that is solved.

I have one more question though; when the URL is passed through to the framed address it converts symbols (/ # = etc) to percentages/numbers.

For example;

This:
http://m49.siteground.biz/~epi4dogs/forum/viewtopic.php?f=2&t=1

Becomes this when framed:
http://m49.siteground.biz/~epi4dogs/forum-embed/=http%3A%2F%2Fm49.siteground.biz%2F~epi4dogs%2Fforum%2Fviewforum.php%3Ff%3D2

The problem is that the framed link when emailed or pasted into a new window results in a 404.

How can I make Advanced iFrame resolve the framed link it generates as a persistent link to the page it is displaying in the frame?


Top
 Profile  
 
PostPosted: 28. Dec 2017, 10:00 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10955
Hi,

I'm referring to the shortcode you posted:

[advanced_iframe securitykey=”my security key” use_shortcode_attributes_only=”true” src=”http://m49.siteground.biz/~epi4dogs/forum/index.php” width=”100%” height=”600″ scrolling=”no” id=”advanced_iframe” onload_resize=”true” store_height_in_cookie=”true” resize_on_ajax_jquery=”false”map_parameter_to_url=”page” add_iframe_url_as_param=”same”]

and there is the problem that
resize_on_ajax_jquery=”false”map_parameter_to_url=”page” has a missing space!

the problem of
http://m49.siteground.biz/~epi4dogs/forum-embed/=http%3A%2F%2Fm49.siteground.biz%2F~epi4dogs%2Fforum%2Fviewforum.php%3Ff%3D2
is that it should be
http://m49.siteground.biz/~epi4dogs/forum-embed/page=http%3A%2F%2Fm49.siteground.biz%2F~epi4dogs%2Fforum%2Fviewforum.php%3Ff%3D2
-> "page" is missing.

and this is because map_parameter_to_url="page" is not set properly.

On my example page you find the minimum shortcode:
advanced_iframe securitykey="your key" src="http://www.tinywebgallery.com/blog/e33/page1.html" use_shortcode_attributes_only="true" id="example1" height="150" width="310" map_parameter_to_url="page" add_iframe_url_as_param="same"]

So the problem is not the encoding. This is actually needed that it is a valid url!

after that try using add_iframe_url_as_param_prefix="m49.siteground.biz/~epi4dogs/forum/" also to the shortcode! then the page= paramter is getting much shorter as "m49.siteground.biz/~epi4dogs/forum/" is then added to each url and only e.g. page=viewforum.php%3Ff%3D2 does remain.

Best, Michael


Top
 Profile  
 
PostPosted: 28. Dec 2017, 10:25 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10955
btw. I will add the default "page" for map_parameter_to_url if add_iframe_url_as_param is set. This makes it easier to configure this feature.

Also on the basic tab there is a "generate shortcode" button. You can use this to show me all your current settings!

Best, Michael


Top
 Profile  
 
PostPosted: 31. Dec 2017, 00:45 
Offline

Joined: 10. Sep 2017, 04:26
Posts: 11
I added m49.siteground.biz/~epi4dogs/forum/ to the 'Prefix for iframe ur' in Advanced Settings but without luck. Is this the correct place to add it?

Also, here is the shortcode generated in Basic Settings:

[advanced_iframe securitykey="98af2de36f8925e18977dfe28fa1811cc406a697" use_shortcode_attributes_only="true" src="http://m49.siteground.biz/~epi4dogs/forum/" width="100%" height="600" scrolling="no" id="advanced_iframe" add_iframe_url_as_param="same" add_iframe_url_as_param_prefix="m49.siteground.biz/~epi4dogs/forum/" onload_resize="true" store_height_in_cookie="true" resize_on_ajax_jquery="false" ]


Top
 Profile  
 
PostPosted: 31. Dec 2017, 17:14 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10955
Please check my last posts.

map_parameter_to_url="page"

is still missing.

store_height_in_cookie="true" resize_on_ajax_jquery="false"

is not needed.

add_iframe_url_as_param_prefix="m49.siteground.biz/~epi4dogs/forum/"
looks fine to me.

Best, Michael


Top
 Profile  
 
PostPosted: 1. Jan 2018, 03:03 
Offline

Joined: 10. Sep 2017, 04:26
Posts: 11
this is the shortcode after I made the above changes to the best of my understanding.

[advanced_iframe securitykey="98af2de36f8925e18977dfe28fa1811cc406a697" use_shortcode_attributes_only="true" src="http://m49.siteground.biz/~epi4dogs/forum/" width="100%" height="600" scrolling="no" id="advanced_iframe" map_parameter_to_url="m49.siteground.biz/~epi4dogs/forum/" add_iframe_url_as_param="same" add_iframe_url_as_param_prefix="m49.siteground.biz/~epi4dogs/forum/" onload_resize="true" resize_on_ajax_jquery="false" ]

http://m49.siteground.biz/~epi4dogs/forum-embed/

Further thoughts?

thanks


Top
 Profile  
 
PostPosted: 2. Jan 2018, 23:24 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10955
sure. Read my last post. You have not changed what I told you.

[advanced_iframe securitykey="98af2de36f8925e18977dfe28fa1811cc406a697" use_shortcode_attributes_only="true" src="http://m49.siteground.biz/~epi4dogs/forum/" width="100%" height="600" scrolling="no" id="advanced_iframe" map_parameter_to_url="page" add_iframe_url_as_param="same" add_iframe_url_as_param_prefix="m49.siteground.biz/~epi4dogs/forum/" onload_resize="true"]

should work.

I'm not sure with add_iframe_url_as_param_prefix and the ~ there as this is not in my url whitelist!
So try with an without this attribute.
But the important this is map_parameter_to_url="page" which you missed in your short codes so far.

so you should have a ?page=.... in the url like you see here:
http://www.tinywebgallery.com/blog/advanced-iframe/advanced-iframe-pro-demo/add-iframe-url-to-parent/add-iframe-url-as-param-same-domain?page=www.tinywebgallery.com%2Fblog%2Fe33%2Fpage2.html


Best, Michael


Top
 Profile  
 
PostPosted: 3. Jan 2018, 05:07 
Offline

Joined: 10. Sep 2017, 04:26
Posts: 11
Hmm, ok. I have made changes as I said to the best of my understanding. I am not a programmer and find some of the speculation in your posts a little confusing.

I have tried again but can't replicate your example URL.

Perhaps it would be easier for you to show/or tell me exactly what settings need to be changed and to what. Here is a PDF of the current settings
http://www.shoosh.com.au/squizz/Advanced%20iFrame%20Pro%20%E2%80%B9%20Epi4Dogs%20%E2%80%94%20WordPress.pdf (I'd attach it but the board rejected PDF extensions).

Perhaps if you could mark up the changes then not only would I know it will work but I might learn something...?

thnx

craig@shoosh.com.au


Top
 Profile  
 
PostPosted: 3. Jan 2018, 10:37 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10955
Have you not used the shortcode from the last posts directly in your page?

Because if you set
use_shortcode_attributes_only="true"
then ALL settings you make in the administration are ignored.

What is the shortcode you have in your page?

So please simply use the whole shortcode from my last post. The you have exactly what you have to use. Without any changes!
You don't have to be a programmer. This are just attributes to set.

From the settings in the administration:
"URL forward parameter" should be empty. This is a completely different feature!
"Map parameter to url" should be "page". Like I have written you in all my previous posts.
"Add iframe url as param" -> Same
"Prefix for iframe ur" -> "m49.siteground.biz/~epi4dogs/forum/" -> but don't use this for now. This is an optimisation!

You need to understand that in the administration are ONLY defaults. And in the short code you can overwrite most of them. and if you use use_shortcode_attributes_only="true" in the shortcode NONE of the defaults are used - only the things you define in the shortcode are used.



Best, Michael


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 15 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron
powered by phpbb | Datenschutz/ Privacy policy