Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 19. Sep 2018, 22:28

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 42 posts ]  Go to page Previous  1, 2, 3
Author Message
PostPosted: 31. Jul 2018, 13:09 
Offline

Joined: 20. Apr 2018, 03:10
Posts: 23
For unknown reason, your email was not delivered to the email accounts I gave.
Can you please send me a downloading link, then notify me the link URL via email
chushanxiaocao@gmail.com
Thank you!


Top
 Profile  
 
PostPosted: 31. Jul 2018, 21:53 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10892
done.
Please tell me when you have downloaded it.

Best, Michael


Top
 Profile  
 
PostPosted: 1. Aug 2018, 13:10 
Offline

Joined: 20. Apr 2018, 03:10
Posts: 23
Thank you Michael, I've downloaded it.
Have a nice one!


Top
 Profile  
 
PostPosted: 7. Aug 2018, 15:07 
Offline

Joined: 20. Apr 2018, 03:10
Posts: 23
Hi Michael,
The new version works a treat!!!
Thank you so much!
(Sorry for not replying earlier due to the vacation)


Top
 Profile  
 
PostPosted: 7. Aug 2018, 20:35 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10892
Great. Hope this new version will help others as well. I ill release this after my vacation then.

Best, Michael


Top
 Profile  
 
PostPosted: 7. Aug 2018, 21:41 
Offline

Joined: 20. Apr 2018, 03:10
Posts: 23
Hi
I have another question:
The following page has a string appended like this
http://www.icdd.com/folder/first.aspx?id=abc
the id's value is easily got by using ASP.NET function Request.QueryString("id")

But when the above page was embedded in the advanced iframe using the following code.
[advanced_iframe src="http://www.icdd.com/folder/first.aspx" width="100%" height="200px" use_shortcode_attributes_only="true" onload_resize="true" resize_on_element_resize="#content"]

The page URL was changed into
http://www.icdd.com/index.php/ppxrd-first/

If append a string, it became like this
http://www.icdd.com/index.php/ppxrd-first/?id=abc
Now, the id's value can NOT be gotten by using Request.QueryString("id")

Thank you in advance for any suggestion.


Top
 Profile  
 
PostPosted: 7. Aug 2018, 23:19 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10892
Not really understand. But if you want to pass variables form the parent to the iframe you have to configure this:
http://www.tinywebgallery.com/blog/advanced-iframe/advanced-iframe-pro-demo/url-features#h49

Best, Michael


Top
 Profile  
 
PostPosted: 5. Sep 2018, 20:10 
Offline

Joined: 20. Apr 2018, 03:10
Posts: 23
Page History Problem

The first(parent) page http://www.icdd.com/index.php/ppxrd-first/
is embedded in the advanced iframe using the following code.
[advanced_iframe src="http://www.icdd.com/assets/ppxrd/first.aspx" width="100%" height="20px" use_shortcode_attributes_only="true" onload_scroll_top="true" onload_resize="true" resize_on_element_resize="#content" map_parameter_to_url="page" add_iframe_url_as_param="same"]

we start from the first page with url http://www.icdd.com/index.php/ppxrd-first/
1, clicking on the Go to second page, you will be brought to second.aspx with the following URL
http://www.icdd.com/index.php/ppxrd-first/?page=www.icdd.com/assets/ppxrd/second.aspx%3Fid%3Dsecondpage

2, clicking on the Go to third page, you will be brought to third.aspx with the following URL
http://www.icdd.com/index.php/ppxrd-first/?page=www.icdd.com/assets/ppxrd/third.aspx%3Fid%3Dthirdpage

so far so good

Now clicking on the browser BACK button or arrow once, you will be brought to second.aspx from third.aspx
then clicking on the browser BACK button or arrow once, you will be brought to first.aspx from second.aspx

so far so good

Now please repeat 1 and 2. You will be brought to third.aspx again.
This time, clicking on the browser BACK button or arrow once, you will be brought to the first.aspx from third.aspx, NOT to the second.aspx.This IS NOT I want. It should be to the second.aspx
Please help.
Thank you in advance!


Top
 Profile  
 
PostPosted: 5. Sep 2018, 21:56 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10892
The browser back functionality is a browser functionality. There is no code from me involved.
Can you reproduce this on different browsers? e.g. chrome, FF and IE?
I assume they all behave a little bit different.

Best, Michael


Top
 Profile  
 
PostPosted: 6. Sep 2018, 15:15 
Offline

Joined: 20. Apr 2018, 03:10
Posts: 23
Thank for suggesting test of various browsers.
I am sorry for not telling I used Firefox browser.

Good news is Chrome, IF and Edge don't have this issue.

To compare, you can test this page that is embedded in the advanced iframe
http://www.icdd.com/assets/ppxrd/first.aspx
Firefox doesn't have back functionality problem.

But when the abvove page is embedded in the advanced iframe, the following is its URL
www.icdd.com/index.php/ppxrd-first/
Then, you will see the problem.

Thank you!


Top
 Profile  
 
PostPosted: 7. Sep 2018, 22:27 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10892
@chushanxiaocao I think this is nothing I can fix. You maybe achtually report this issue to Firefox as a bug. They mabe fix this then.
@AdamDilRaish What is your problem?

Best, Michael


Top
 Profile  
 
PostPosted: 8. Sep 2018, 02:30 
Offline

Joined: 20. Apr 2018, 03:10
Posts: 23
Thank you Michael!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 42 posts ]  Go to page Previous  1, 2, 3

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
powered by phpbb | Datenschutz/ Privacy policy