Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 23. Oct 2017, 08:11

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 8 posts ] 
Author Message
PostPosted: 7. Apr 2011, 23:43 
Offline

Joined: 7. Apr 2011, 22:39
Posts: 4
The names of my folders are displayed as latin-1 but they are utf-8 (e.g. the name Björn looks like Björn).

Could this be fixed? (PHP 5.2.6 on Debian 5.0)

Another problem is that I cannot use https because the action attribute of the login form begins with 'http://' regardless of what protocol is used. (I found the $_SERVER['SERVER_PORT']-variable has the value 80 when I'm using https which of course goes to port 443 - weird...).

Regards


Top
 Profile  
 
PostPosted: 8. Apr 2011, 09:32 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10499
which language file do you use? The encoding is specified there.

Are the folder name directly read from disk or from a foldername.txt? - Then please make sure that your files are saved in UTF-8.

TWG does completely run with UTF-8 so öäü are normally no problem.

And which login do you mean? Because at actions I don't specify the protocol. This is done by the server.
and if $_SERVER['SERVER_PORT'] = 80 then you server configuration seems not to be right.


- Michael


Top
 Profile  
 
PostPosted: 8. Apr 2011, 14:44 
Offline

Joined: 7. Apr 2011, 22:39
Posts: 4
TinyWebGallery wrote:
which language file do you use? The encoding is specified there.
de
Quote:
Are the folder name directly read from disk or from a foldername.txt?
Directly from disk. Seems I have to create a foldername.txt for each folder.
Quote:
And which login do you mean? Because at actions I don't specify the protocol. This is done by the server.
I mean the admin login.

In admin/_include/login.php in the login form a function make_link(...) is called (defined in admin/_include/fun_extra.php) which uses a variable $GLOBALS["script_name"] which is defined in admin/_config/conf.php.

I added
Code:
$GLOBALS["script_name"] = $_SERVER['PHP_SELF'];
which fixes it for here and now.
Quote:
$_SERVER['SERVER_PORT'] = 80 then you server configuration seems not to be right.
Seems to be a buggy PHP-Version.


Top
 Profile  
 
PostPosted: 9. Apr 2011, 00:25 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10499
German should work fine - because I'm German and always test in English and German.
Maybe it is an encoding Problem from the file system TWG is running.

Do you have any details here?
And does using a foldername.txt work?

If you like you can already use the 1.8.5 preview from the forum. There the folder name can be set in the frondend and the foldername.txt is created automatically.

admin/_config/conf.php. should be file if the port is set right.

If you change it be aware if you update TWG this config file is overwritten.

Best,
Michael


Top
 Profile  
 
PostPosted: 11. Apr 2011, 17:50 
Offline

Joined: 7. Apr 2011, 22:39
Posts: 4
Quote:
Maybe it is an encoding Problem from the file system TWG is running.

It's a Debian 5.0 (lenny) Linux which's default file system encoding is utf-8. When i execute the following php-script in the twg install dir:
Code:
<?php
header
('Content-Type: text/plain; charset=UTF-8');
$dir = "./pictures/";

if ($dh = opendir($dir)) {
    while (($file = readdir($dh)) !== false) {
        echo "filename: $file : filetype: " . filetype($dir . $file) . "\n";
    }
    closedir($dh);
}
?>

everything looks fine. I don't know what happens to the filenames in twg...
Quote:
And does using a foldername.txt work?
Yes.
Quote:
admin/_config/conf.php. should be file if the port is set right.

The port-variable was indeed set incorrectly due to a mistake in the server configuration. It works now.


Top
 Profile  
 
PostPosted: 11. Apr 2011, 17:56 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10499
Then please set

$filesystem_encoding = "";

to utf-8.

- Michael


Top
 Profile  
 
PostPosted: 12. Apr 2011, 12:24 
Offline

Joined: 7. Apr 2011, 22:39
Posts: 4
TinyWebGallery wrote:
Then please set

$filesystem_encoding = "";

to utf-8.

Works. Thank you!

Sorry, I just should have read the config file.


Top
 Profile  
 
PostPosted: 12. Apr 2011, 13:03 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10499
too many config options ;)....

- Michael


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO