Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 13. Dec 2017, 11:20

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 7 posts ] 
Author Message
PostPosted: 7. Dec 2011, 06:58 
Offline

Joined: 3. Dec 2011, 19:42
Posts: 6
I was bulk loading images via SMB and tried to browse twg at the same time. The system hung up with the error:
12.06.2011 23:48:45 (en) - ERROR 2 in var/www/twg186/inc/filefunctions.inc.php, line 1104: readdir() expects parameter 1 to be resource, boolean given

I've cleared all cache, rotation, session info... but the error still occurs. Is there anything else I can do to fix this?


Top
 Profile  
 
PostPosted: 7. Dec 2011, 10:34 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10571
Da scheint das Verzeichnis nicht gelesen werden zu können.

Ist der Fehler immer noch da. evtl. hat php hier ein Verzeichnis temporär irgendwie gelockt.

- Michael


Top
 Profile  
 
PostPosted: 7. Dec 2011, 15:15 
Offline

Joined: 3. Dec 2011, 19:42
Posts: 6
No. My pictures directory is not writable. At least not by twg. Another error I can share is what is shown on the web page:

Fatal error:Maximum execution time of 30 seconds exceeded in /var/www/twg186/inc/filefunctions.inc.php on line 1960.

Jay


Top
 Profile  
 
PostPosted: 7. Dec 2011, 15:21 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10571
This is the important one.

the script needs to much time to go through all directories and fails.

You should enable the cache of TWG!

- Michael


Top
 Profile  
 
PostPosted: 7. Dec 2011, 21:17 
Offline

Joined: 3. Dec 2011, 19:42
Posts: 6
It looks like this is different.

I narrowed the number of pictures by linking into the directories instead of starting at the root. I narrowed it down to some of the directories that I loaded last night. I created a single link to one of those directories with only 9 photos in it. The application still hung.

I thought this may be related to the pictures contained.... so I deleted all the photos. It still hung.

The directory name is: "12-18-2010"

Do the dashes in the directory name cause issues?

Jay


Top
 Profile  
 
PostPosted: 7. Dec 2011, 23:01 
Offline

Joined: 3. Dec 2011, 19:42
Posts: 6
Please close this case. This was a permissions issue. My upload program was not making the images readable by everyone. Somehow, this tripped up TWG.

Jay


Top
 Profile  
 
PostPosted: 7. Dec 2011, 23:39 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10571
;).


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO