Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 1. Oct 2022, 20:43

This forum is readonly now. Please use the new forum if you don't find the answer to your question here. The new forum is at https://www.tinywebgallery.com/blog/forum/


All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 20 posts ]  Go to page Previous  1, 2
Author Message
 Post subject:
PostPosted: 19. May 2006, 11:12 
Offline

Joined: 16. May 2006, 12:05
Posts: 13
Location: Norway
TinyWebGallery wrote:
do you really need utf-8?

Thing is, I use UTF-8 for the enitre site (as UTF-8 is the preferred encoding to use nowadays). And the XHTML 1.0 Transitional does not allow different encodings in one page. Maybee it's different when using iFrames..? I don't know.

Should I use ISO-8859-1? I guess I could change the charset for the parent file (fotoalbum.php) to match that. In that case, should I set charset to ISO-8859-1 in the language file, or is that adapted from the charset of the parent file? Of course, I would remove the current charset setting in the language file.

Are there any major changes in the latest version? I have 1.4.1 running now. Do you recommend an upgrade?

Paal


Top
 Profile  
 
 Post subject:
PostPosted: 19. May 2006, 11:29 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 11232
Hi,

I know about the utf-8 issue - I was thinking about switching to utf-8 the whole app - but most of the sites that use TWG run still with 8859-1 or -15

I have tested utf-8 with greek - If you stay in one encoding you are fine!
Normaly I convert everything (title, comments) that have set the charset in html characters. This enables e.g. when you enter greek comments you still see them properly when using german language.

Because of security issues I have reworked this part in 1.4.2 (enter <script> as caption in 1.4.1 !!) and you see (set a new title fixes this).

therefore - yes - upgrade.
Do you want to support all languages? or only a couple? then you could store all the language files in utf-8.

I tested this with German - works fine.


Top
 Profile  
 
 Post subject:
PostPosted: 19. May 2006, 19:12 
Offline

Joined: 16. May 2006, 12:05
Posts: 13
Location: Norway
I found out why Firefox gave me problems... Firefox itselv was set to select English language if available. And of course TWG has support for this..

So I set Firefox to load Norwegian by default, and all is good. Also, the encoding problems were related to that, since the language_en.php was not UTF-8. Now I've set all language_xx.php's to UTF-8, and all seems good :D

Thanks again for all help!
Now I'll ask the site owner (I'm just the admin) to register (or I'll do it for him). Also, I'll register a license to myself as well soon.

I have my own personal site (#removed_broken_link), and I'm planning on setting up a site for the Tuba Quartet I play with at #removed_broken_link. Can I use the same license for both sites? Since they are on the same domain, just different subdomains? And since both sites will belong to me?

Paal


Top
 Profile  
 
 Post subject:
PostPosted: 20. May 2006, 11:14 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 11232
where you using my updated 1.4.2 version?

About registration - within one domain you ony need one registration - but you have too add the subdomain like a multidomain.

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 20. May 2006, 16:28 
Offline

Joined: 16. May 2006, 12:05
Posts: 13
Location: Norway
I was on 1.4.1, but same prob. after upgrade to 1.4.2. But as said, wasn't a problem with TWG. Problem was that Opera and Firefox on my computer both had English as "default" language for browsing. So since TWG offers auto detection of language my browsers told TWG to display site in english.
I changed default language for my browsers (on my computer) to Norwegian, and hence TWG displays in my preferred language.

In short: problem wasn't TWG, but my local setting.

P


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 20 posts ]  Go to page Previous  1, 2

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron
powered by phpbb | Datenschutz/ Privacy policy