Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 28. Nov 2022, 19:24

This forum is readonly now. Please use the new forum if you don't find the answer to your question here. The new forum is at https://www.tinywebgallery.com/blog/forum/


All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 16 posts ]  Go to page 1, 2  Next
Author Message
PostPosted: 1. Jun 2006, 19:57 
Hey there!

First of all i have to say: Great work in approving the php include

this version works nice with my CMS.....however i have encountered a small problem with adding comments to an picture:

when i hit the save button in the comment iframe i get a wrong redirect....it redirects me to the index.php in the TWG folder and not to the file where i included the gallery...the comment itself is added and i can see it when i look in the gallery again.

Hope you can help and thanks in advance!

Keep up the good work, this gallery is really great :)


Top
  
 
 Post subject:
PostPosted: 1. Jun 2006, 22:33 
found another small problem:

when stopping a slideshow it takes me to the
wrong place too....instead of using the name of
the file where the gallery was included it picks the index.php from the twg folder

example:

i have a file called gallery.php where i included the gallery...the gallery itself is in the subfolder twg

link to start the slideshow is right:

gallery.php?twg_album=......

stop link is: twg/index.php?twg_album=......

seems to be the same problem as the one above


Top
  
 
 Post subject:
PostPosted: 1. Jun 2006, 23:02 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 11232
I'll check this - maybe I missed to pass the parameter for the root to this call - about which slideshow are you talking?

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 1. Jun 2006, 23:07 
you mean the slideshow type?

i have set slideshow type variable $twg_slide_type to "FALSE" so it should
be the normal version


Top
  
 
 Post subject:
PostPosted: 2. Jun 2006, 08:20 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 11232
Hi,

I tested php include and the comments and the slidshow jump back to the page where they should (in my case an include.php one level higher then TWG installation).

Have you set $php_include to true and the $install_dir ?

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 2. Jun 2006, 11:51 
yeah $php_include is true and $install_dir is set to to twg/


Top
  
 
 Post subject:
PostPosted: 2. Jun 2006, 15:02 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 11232
o.k. - seem your cms does something else - please open index.php

line 54:
$twg_root = $_SERVER['PHP_SELF'];

make an

echo $twg_root;

below that!

if you then start the gallery you get an output about where I return to.

Please tell me what you get there!

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 2. Jun 2006, 15:46 
okay, have done that:

as output i get the path to my gallery.php starting from document root....
/mypage/gallery.php


Top
  
 
 Post subject:
PostPosted: 2. Jun 2006, 15:57 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 11232
thats good.

I put this in the session an get in again in the i_kommentar.php

open i_frames\i_kommentar.php and add

echo $twg_root;

in line 55 or 56 ;).

Then open the comments iframe.
then the "root" page should be displayed. - tell me what is says.

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 2. Jun 2006, 17:13 
done! :wink:

output in the comments iframe is: twg/../index.php


Top
  
 
 Post subject:
PostPosted: 2. Jun 2006, 17:24 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 11232
That's the problem.

In the inc/mysession.inc.php I have:

if (isset($_SESSION['twg_root'])) {
$twg_root = trim($_SESSION['twg_root']);
} else if (isset($twg_root)) {
$_SESSION['twg_root'] = trim($twg_root);
} else {
// this is only backup -
$twg_root = $install_dir . "../index.php";
}

therefore normally it should be set in the index.php to the session and available in the i_kommentare.php

mybe your cms does prevent this somehow.
if you change
$twg_root = $install_dir . "../index.php";

to your location of the include you should be fine.

But it would still be interesting why this does not work!

does the login work? or private galleries - they work with session variables too!

Have you disabled cookies?

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 2. Jun 2006, 18:01 
okay, i will try that :)

have not tested login or private galleries yet but i can do if you want....will report back as soon as i tested it

Cookies are enabled....

could be that is has something to do with the CMS too....i am using CMS like Postnuke...its called MDPro


Top
  
 
 Post subject:
PostPosted: 2. Jun 2006, 18:07 
I think it is related to that - maybe they do something with the session ...

Try private login or login - or options are they saved? or just another language .. everything stored in the session.


Top
  
 
 Post subject:
PostPosted: 19. Jul 2006, 15:15 
Hi,

sorry that i have not reported back for some time.

I tried private gallery and get an error too....it tries to open twg/i_frames/index.php


Top
  
 
 Post subject:
PostPosted: 19. Jul 2006, 15:29 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 11232
After you enter the password you mean?

can you change any of the options?

I think you would have to adapt the iframes manually to point to the correct root. But if the session does not work many other this would not work either.

I still recomend you try the iframe include.

/Michael


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 16 posts ]  Go to page 1, 2  Next

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron
powered by phpbb | Datenschutz/ Privacy policy