Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 19. Oct 2017, 00:08

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 10 posts ] 
Author Message
 Post subject: Slideshow caption color
PostPosted: 3. Feb 2012, 19:17 
Offline

Joined: 3. Feb 2012, 19:12
Posts: 5
I am using the "Dark" skin. When you view the pictures individually, the caption is in white (needed for dark background). However, if you start the slideshow, the same captions are in black. Not too visible. I've not been able to locate where I might change the caption to white during the slideshow. Any help? TIA.


Top
 Profile  
 
PostPosted: 4. Feb 2012, 01:35 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10496
Look in the iframes folder. There is the stylesheet for the iframes.
But I don't know if I have a separate selector to set this. You might have to change this directly in the code.

If you have problems to set this please let me know.

- Michael


Top
 Profile  
 
PostPosted: 4. Feb 2012, 03:25 
Offline

Joined: 3. Feb 2012, 19:12
Posts: 5
All my attempts at altering items in iframes.css have failed so far. I still have dark text on the slideshow. I've looked through i_slideshow.php and am not sure what I would change here. (I've only dabbled in php and am no expert). Sorry, it's hard to jump into mature code like this an know exactly where to change one small item. If you have any additional suggestions, I'd love to try them.

Thanks,
Janner


Top
 Profile  
 
PostPosted: 4. Feb 2012, 15:48 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10496
the style you should change is
twg_Caption

by default there is no color set.

- Michael


Top
 Profile  
 
PostPosted: 4. Feb 2012, 17:59 
Offline

Joined: 3. Feb 2012, 19:12
Posts: 5
I tried changing that style in /i_frames/iframe.css prior to posting my last reply with no success.

/* font settings for the caption text */
.twg_Caption {
font-family: Verdana, Arial, Helvetica, sans-serif;
font-size: 12px;
min-height:15px;
color: #FFFFFF;
}

I've tried
Quote:
color: white;
also.
I've deleted and rebuilt the image cache. Am I choosing the wrong style property to alter?
I've tried this in both Firefox and IE.

Sorry to be a bother, but I'm not sure what else to try at this point,


Top
 Profile  
 
PostPosted: 4. Feb 2012, 19:25 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10496
Rebuild in the cache has nothing to do with this.

Maybe the css is simply cached in the browser or a proxy. So deleting the browser cache and loading it with Control + F5 can solve your Problem.
Or call the iframe.css directly in the browser and check if you see the updated version.

- Michael


Top
 Profile  
 
PostPosted: 7. Feb 2012, 23:30 
Offline

Joined: 3. Feb 2012, 19:12
Posts: 5
This isn't a computer cache issue. I've tried it on a brand new machine and it still has a black slideshow caption. I have opened the file from inside the browser and it's the correct one. Guess I'm just going to live with it, or change to another skin. I happen to like dark skins for displaying photos, but that stupid problem will haunt me if I leave it. I also tried increasing the font size and it didn't appear to respond either.

I did have one other question regarding the language flags and dropdown. Is there any way to remove both? Living in the US, my audience is pretty much all English speaking - not British English or German. For me, I'd prefer to remove all evidence of language stuff.

Jan

/* font settings for the caption text */
.twg_Caption {
font-family: Verdana, Arial, Helvetica, sans-serif;
font-size: 16px;
min-height:15px;
color: #FFFFFF;
}


Top
 Profile  
 
PostPosted: 8. Feb 2012, 00:05 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10496
I just checked.

For the slideshow I include the style.css and my_style.css.
So simply use this style in the normal css of TWG.

About languages.

set
$enable_language_selector=false;

or delete all language files except the one you like.

- Michael


Top
 Profile  
 
PostPosted: 8. Feb 2012, 00:09 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10496
And the .twg_Caption was actually missing in the black skin as well.

I added this and it will be set in the next version of TWG.

- Michael


Top
 Profile  
 
PostPosted: 9. Feb 2012, 00:52 
Offline

Joined: 3. Feb 2012, 19:12
Posts: 5
Thanks, I was finally able to get my white slideshow captions and remove the language flags. I appreciate your help. Glad you'll be able to fix the dark caption issue for others in the next release. Now I get to have fun tweaking things to look even better since the basics are all working.

Thanks again,
Jan


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO