Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 16. Oct 2018, 03:29

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 7 posts ] 
Author Message
PostPosted: 15. May 2016, 21:49 
Offline

Joined: 15. May 2016, 21:44
Posts: 64
Hi
Sorry for asking this question, but I've read the instructions over and over and I can't seem to get this to work.

I want to have my entire gallery password protected, and so I have created an empty 'private.txt' file and uploaded into the gallery root folder. After that I have tried several different things but nothing has worked for me so far :roll:

Can someone tell me what I should add to the 'config.php' file to get this to work??

Thanks in advance!!!
xega :)


Top
 Profile  
 
PostPosted: 15. May 2016, 21:59 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10904
an empty private.txt?

See:
http://www.tinywebgallery.com/en/faq.php#h12
->
New 1.7: You can use a private.txt in the 'pictures' folder! Then a global login window is shown. You have to place all passwords (users for user based galleries) that have to have access in this file.
New 1.8.5: You can now use a private.png in the pictures folder. If you have defined a private.txt in this folder you can use a big image which covers the whole browser. You can create a nice entry page for your protected gallery this way.

See http://anna-dempfle.de/index.php

Best, Michael


Top
 Profile  
 
PostPosted: 15. May 2016, 22:19 
Offline

Joined: 15. May 2016, 21:44
Posts: 64
Wow you are fast!

Sorry, I read through the FAQ point 12 and I'm still confused. I'm used to working with Joomla, this kind of setup is new to me.

But anyway I edited the file 'private.txt', added just the text 'testing', saved the file and uploaded it into the pictures folder. Now I get prompted for a password but 'testing' doesn't work.


Top
 Profile  
 
PostPosted: 15. May 2016, 22:36 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10904
make sure there are no spaces before or after the password.

Or have you set $encrypt_passwords=true?
Because than you have to use encrypted passwords


Top
 Profile  
 
PostPosted: 15. May 2016, 22:50 
Offline

Joined: 15. May 2016, 21:44
Posts: 64
There are no spaces before or after the password.

Just to be absolutely sure, I made a clean installation of TWG and the only thing I did was change the password from 'twg_admin' to 'testing'. I then uploaded the 'private.txt' file (with only the single word 'testing' in it), to the pictures folder. I get the login window but again, I am unable to enter the correct password.


Top
 Profile  
 
PostPosted: 15. May 2016, 23:06 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10904
can you place this file to a sub folder? So that this is protected like
http://www.tinywebgallery.com/demo/inde ... offset=0,4
the 3rd album?

Best, Michael


Top
 Profile  
 
PostPosted: 15. May 2016, 23:13 
Offline

Joined: 15. May 2016, 21:44
Posts: 64
Thank you again!

I figured out what the problem was. It was the file encoding of my 'private.txt'. As soon as I used your 'private' file and entered my password into that, everything worked :D

Thank you very much for helping me on a sunday!!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
powered by phpbb | Datenschutz/ Privacy policy