Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 23. Oct 2017, 22:46

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 12 posts ] 
Author Message
PostPosted: 3. Mar 2014, 17:34 
Offline

Joined: 3. Mar 2014, 17:29
Posts: 3
Hi

I am running TWG on port 8080 behind my router.
The router is mapping its port 80 to port 8080 on my webserver.
Everything is running fine except for the link that is generated by TWG for the full size images.
It always adds :8080 to the hostname, which of course can not be reached outside my LAN.

I assume this to be a bug?
Any ideas how it can be fixed / worked around?

Thanks
Best
Markus


Top
 Profile  
 
PostPosted: 4. Mar 2014, 14:19 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10501
Can you tell me exacly which images you mean.
I use the port only at a few places but it is might be added somehtere automatically because your server runs with 8080.

Best, Michael


Top
 Profile  
 
PostPosted: 4. Mar 2014, 15:00 
Offline

Joined: 3. Mar 2014, 17:29
Posts: 3
Hi

i.e. if I click on the zoomed pic.
The resulting link that does not work looks like

http://host.at:8080/i_frames/i_popup.ph ... G_NAME.JPG

Best
Markus


Top
 Profile  
 
PostPosted: 4. Mar 2014, 15:19 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10501
o.k.

Please open inc/filefunctions.inc.php and search for
function getTWGHttpRoot($dirfix = '', $useport = true)
Then change useport to false:
function getTWGHttpRoot($dirfix = '', $useport = false)

Save and retry.

Best, Michael


Top
 Profile  
 
PostPosted: 5. Mar 2014, 07:00 
Offline

Joined: 3. Mar 2014, 17:29
Posts: 3
Great, thank you.
That did the job!


Top
 Profile  
 
PostPosted: 5. Mar 2014, 17:35 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10501
I'll add a switch into the next version also.

Best, Michael


Top
 Profile  
 
PostPosted: 2. May 2014, 05:33 
Offline

Joined: 2. May 2014, 05:30
Posts: 3
Dragging this one back up...

I've got a somewhat related question/problem when using TWG. I'm running internally and externally on 8080. Using http://hostname.com:8080 works fine for just about everything (thumbnails, etc, all work). Clicking on an image to launch it full screen, however, fails to append :8080 in the launched browser window. Messing with the $useport option does not seem to have any effect on the behavior... suggestions?


Top
 Profile  
 
PostPosted: 2. May 2014, 10:55 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10501
Fullscreen means when the original image is used or a popup?

Best, Michael


Top
 Profile  
 
PostPosted: 2. May 2014, 14:08 
Offline

Joined: 2. May 2014, 05:30
Posts: 3
The popup window that is launched after clicking the large thumbnail version of an image.
i.e.: http://hostname.com/i_frames/i_popup.php?twg_album=albumname&twg_show=Untitled-04.jpg


Top
 Profile  
 
PostPosted: 2. May 2014, 20:52 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10501
o.k. - i'll check the code there...


Top
 Profile  
 
PostPosted: 3. May 2014, 09:32 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10501
I checked the code and the behavoir is not logical. Because the popup opens with a link that is created from the link that renders the image itself (image.php is replaced by i_frames/i_popup.php). So you should not see the detail image also...

Can you check if the link that is defined at the id="adefaultslide" ?

And how is the setup for the download of an image?

Best, Michael


Top
 Profile  
 
PostPosted: 12. May 2014, 04:11 
Offline

Joined: 2. May 2014, 05:30
Posts: 3
Oops, didn't have the useport setup correctly, looks like its' working now. Thanks!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 12 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO