Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 24. Oct 2017, 13:28

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: Constant password prompt
PostPosted: 3. Jun 2014, 13:38 
Offline

Joined: 3. Jun 2014, 13:27
Posts: 3
I am having a very similar issue as this thread: http://www.tinywebgallery.com/forum/web-photo-gallery-support-f1/endless-password-request-t3519.html?hilit=password

I am getting absolutely no error messages, but as soon as I turn on caching of directories, I get a constant password prompt. When I type in the password for a private folder, the screen turns white with another password prompt. This also happens logging in as admin, but after 2 or 3 attempts it logs in. Not so with the private folders.

Other than that everything works beautifully.

I'm using the latest XAMPP server and TWG 2.1

Thanks


Top
 Profile  
 
PostPosted: 5. Jun 2014, 12:37 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10502
wich setting have you changed for the caching?

So after 2-3 attemps it works? Seems something is wrong with the session.

Does it happen with all browsers?

Best, Michael


Top
 Profile  
 
PostPosted: 5. Jun 2014, 13:23 
Offline

Joined: 3. Jun 2014, 13:27
Posts: 3
The very first setting in TWG Configuration is "Enable session caching of directories and files." which says it "Should be enabled after the setup is done!". As soon as I turn that setting on, it is impossible to log into a protected folder and I can only log in as admin if I enter the password, physically close the window and reopen it. Then the "Administration" option shows in the menu. After clicking that, it goes to a white screen asking for a password again. After entering the password then it lets me in.

If I turn off the "Enable session caching of directories and files." option, it works fine. This happens with all browsers.

Edit : After playing with it a while, it starts asking for a password for everything I click with the "Enable session caching of directories and files." option turned off, but lets me continue until I click a picture or album. :?


Last edited by SuperChicken on 5. Jun 2014, 13:30, edited 1 time in total.

Top
 Profile  
 
PostPosted: 5. Jun 2014, 13:29 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10502
Strange. Because this setting is normally turned on afte the 3rd request anyway.
Have you the same behaviour after you click on the bandwidth icon (which resets the cache...).

Is this online somewhere? Fell free to send a pm.

Bet, Michael


Top
 Profile  
 
PostPosted: 5. Jun 2014, 13:52 
Offline

Joined: 3. Jun 2014, 13:27
Posts: 3
I left a PM for you. After playing with it a bit, it's doing strange things... One time it let me in and after a click or two it prompted for a password again.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO