Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum
http://www.tinywebgallery.com/forum/

Sometimes images are not in sync
http://www.tinywebgallery.com/forum/wordpress-flash-uploader-f15/topic3134.html
Page 1 of 1

Author:  finalwebsites [ 25. Oct 2011, 12:39 ]
Post subject:  Sometimes images are not in sync

Hi,

I'm using the latest version and also the current version of Wordpress.
The upload works fine and most images are available in the library after a minute or something.

I have trouble with a few images, for example:

logo-unibet.jpg works fine but not logo-unibet-2.jpg (same image but a little bit smaller)

While writing this post I tried to upload the files:
bingocams-klein.jpg
logo-unibet-klein.jpg

They are in my list (WP flash upload screen) and they are also on my server
Screen server location: http://imm.io/aJBS
screen WFU: http://imm.io/aJC7

Do you have an idea what is here the problem? I checked also the database

Thanks
Olaf

Author:  finalwebsites [ 25. Oct 2011, 13:14 ]
Post subject:  Re: Sometimes images are not in sync

My previous trial stopped after the upload was done (no sync process)

I renamed the files to: unibet-logo.jpg and logo-bingocams.jpg and it worked.

Is there something strange what happen while syncing the files?
It seems to be a problem with double leading file name parts.

Author:  TinyWebGallery [ 25. Oct 2011, 14:36 ]
Post subject:  Re: Sometimes images are not in sync

I have a simple detection of the thumbnails Wordpress does generate.
Maybe you file naming just fits in this filter.

I will try with your filenames and let you know.

In the config you can disable this detection! Please change the setting and retry.

Best,
Michael

Author:  finalwebsites [ 25. Oct 2011, 15:03 ]
Post subject:  Re: Sometimes images are not in sync

Hi Michael,

I will try this setting, is using that setting a risk?
How about later plugin updates, do you replace the config file?

btw. it's definitely like:

1. upload: cover-casino.jpg -> okay
2. upload cover-casino-jack.jpg -> went wrong
3. upload cover-casinojack.jpg -> okay

Author:  TinyWebGallery [ 25. Oct 2011, 15:16 ]
Post subject:  Re: Sometimes images are not in sync

WFU simply does not try to automatically detect thumbnails in the upload directory.

If you e.g. copy files from one wordpress install to the other then all thumbnails are copied as well.

then the thumbnails are not in the media library as thumbnails (this is checked as well).
and then thumbnails are treated as normal images.

My detection is simple right now. Files starting with the same prefix and then one that contiunues with a - it the thumbnail. And this is the detection you can turn off.

I think this detection can be improved to -<numbers>x<numbers> are thumbnails only...
I check this for the next version.

The config is in the database. So an update is no problem...

- Michael

Author:  finalwebsites [ 25. Oct 2011, 15:36 ]
Post subject:  Re: Sometimes images are not in sync

Hi,

I changed that option on the settings page and it works as it should.

Right the patter should be like:

Code:
'/^[a-z0-9\-]*([0-9]{1,}x[0-9]{1,})\.(jpe?g|gif|png)$/'


Thanks!

Author:  TinyWebGallery [ 25. Oct 2011, 16:12 ]
Post subject:  Re: Sometimes images are not in sync

I will only check the size part with an expression and always check if there is a file with the same name because if you e.g.
have a file 123-800x600.jpg it will not be imported although this is the original.

I'll add this to 2.15 which will be available soon.

- Michael

Author:  mude [ 27. Oct 2011, 17:10 ]
Post subject:  Re: Sometimes images are not in sync

TinyWebGallery, it really helped. thanks for the advice

Author:  TinyWebGallery [ 30. Oct 2011, 17:43 ]
Post subject:  Re: Sometimes images are not in sync

Get WFU 2.15 - it is now implemented.

- Michael

Page 1 of 1 All times are UTC + 1 hour [ DST ]
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/