Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

TWG installation Check 1.8.6
Page 1 of 1

Author:  mesc [ 10. Nov 2011, 16:22 ]
Post subject:  TWG installation Check 1.8.6

I am running TWG (registered) on my own hosted apache2 server.
I have some problems with the installation check:
- Image Magick Support -> red
- ffmpeg Support -> red
- ffmpeg video support -> red

I tried several things but so fare I have no clue what the problem might be.
To test I gave the whole directory full access "chmod 777" but still doesn't work.
Could it be a virtual host problem? I am a newbie...

Any ideas what to test? Thank you.

Author:  TinyWebGallery [ 11. Nov 2011, 02:58 ]
Post subject:  Re: TWG installation Check 1.8.6

Nothing to worry about.

this 2 are softwares your hoster has to install/provide.

image magick is an alternative to the build in library to modify images
and ffmpeg gives you to the option to create thumbnails from videos and to convert them.

image magick is something you maybe get if you ask your hoster about it ;).
ffmpeg you normally only get if you have your own server because it is really powerful. it can e.g. convert videos from avi to flv during upload.


Author:  mesc [ 12. Nov 2011, 12:52 ]
Post subject:  Re: TWG installation Check 1.8.6

Hi Michael
thank you for the fast reply. The thing is I am hosting TWG on my own Ubuntu Server running apache2.
I have installed both packages:
apt-get install imagemagick ffmpeg

But still the check tells me that they are red...
Especially in the ffmpeg functions I am interested.

Author:  TinyWebGallery [ 12. Nov 2011, 19:06 ]
Post subject:  Re: TWG installation Check 1.8.6

then you have to check where they are installed. You have to tell TWG where the executables are.

- Michael

Author:  mesc [ 13. Nov 2011, 00:04 ]
Post subject:  Re: TWG installation Check 1.8.6

...hours later - I found the solution!
I don't know how it came there, but in my file:
under disable_functions was "shell_exec":
disable_functions = shell_exec

I removed the shell_exec and now it is working.

Thank you anyway for your help,

Page 1 of 1 All times are UTC + 1 hour [ DST ]
Powered by phpBB® Forum Software © phpBB Group