Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum
http://www.tinywebgallery.com/forum/

Upload pictures - Firefox: Status Error : io - IE works fine
http://www.tinywebgallery.com/forum/web-photo-gallery-support-f1/upload-pictures-firefox-status-error-io-ie-works-fine-t3188.html
Page 1 of 1

Author:  mesc [ 20. Dec 2011, 14:16 ]
Post subject:  Upload pictures - Firefox: Status Error : io - IE works fine

If I try to upload pictures the "TWG Flash Uploader" starts. I can select a new picture and as soon as I click on "Upload" new "Status: Upload started. Please wait..." after some seconds Status changes to "Error : io"
Usually the Flash Plugin crashes after this message.
I am using Firefox 8.0 with latest Flash 11.1.102.55.
I am hosting TWG on my own server at home so I have full control over any php or apache2 config files.

Upload works without problems with IExplorer 9.0.4...

Any suggestion?

Author:  TinyWebGallery [ 20. Dec 2011, 15:12 ]
Post subject:  Re: Upload pictures - Firefox: Status Error : io - IE works

Which firewall/antivirus you are using?

Have you already enabled the upload debug?
Are there messages in the error log of the server?
Have you tried the .htaccess file?

- Michael

Author:  mesc [ 20. Dec 2011, 15:57 ]
Post subject:  Re: Upload pictures - Firefox: Status Error : io - IE works

Server is running on Ubuntu 11.10, no software firewall nor antivirus.

Do you mean:
$enable_enhanced_debug=true; ???

Output Debug File:
12.20.2011 14:48:12 - Action:dir; Directory: __/__/pictures/upload
Request: /admin/upload/tfu_file.php?action=dir&dir=&ts=1324388893867&tfu_rn=1321465760889341841624381646731&tfu_is_flash_10=1&tfu_ut=-1&TFUSESSID=un0ut504a0gie4bo53slf8j693
Stack: tfu_file.php:57:tfu_debug:Action:dir; Directory: ../../pictures/upload
Current memory usage: 2890 KB

Apache2 Error log file (as soon as the Upload Dialog appears, no new errors if I click 'Upload' button):
[Tue Dec 20 14:52:09 2011] [error] [client 138.###.###.##] client denied by server configuration: /var/www/twg/admin/upload/lang/en.xml

I have following lines in my .htaccess file:
<FilesMatch "\.(txt|xml|log)$">
Order deny,allow
Deny from all
</FilesMatch>

The server is running on port 443 with a self-made certificate. I have to ignore the warning if I open the page with any browser (Firefox or IExplorer).

Author:  TinyWebGallery [ 20. Dec 2011, 16:40 ]
Post subject:  Re: Upload pictures - Firefox: Status Error : io - IE works

>>> The server is running on port 443 with a self-made certificate. I have to ignore the warning if I open the page with any browser (Firefox or IExplorer).

Firefox does not work with selfmade certificates.
See the howto about running the flash with https.

- Michael

Author:  mesc [ 20. Dec 2011, 17:18 ]
Post subject:  Re: Upload pictures - Firefox: Status Error : io - IE works

This one?
2. How to configure the flash to work with HTTPS or if you get a 404 all the time!

There you write:
"But normally the problem is a IE problem only."
But on my system it works fine with IE but not with Firefox...

I tried:
$upload_file= "https://www.tinywebgallery.com:443/path/tfu_upload.php";

but no success....

Is it possible to switch the frontend upload method to a html upload form?

Author:  TinyWebGallery [ 20. Dec 2011, 17:22 ]
Post subject:  Re: Upload pictures - Firefox: Status Error : io - IE works

And if you read the part before then the problem with the certificate is described. So with firefox you need a vaild one!

In the frontend you cannot switch to html upload because the whole right management is not impemented for a fallback.

- Michael

Page 1 of 1 All times are UTC + 1 hour [ DST ]
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/