Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 24. Oct 2017, 11:33

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 5 posts ] 
Author Message
PostPosted: 14. Dec 2006, 07:28 
Offline

Joined: 14. Dec 2006, 07:04
Posts: 1
Three times now TWG has created a _vti_cnf directory somewhere under the pictures directory and I cannot delete it or any files that may be put there.

Also, every now and then the page will go spastic and be constantly reloaded. I have to exit the browser (or tab) and reenter the site.

The last spastic session created this in the debug file (partial list)

Quote:
12.13.2006 22:16:36 - ERROR 2 in /web/photos/admin/.include/fun_extra.php, line 318: unlink(/home/.sites/143/site2/web/photos/pictures/1_Family/_vti_cnf/Jazz Fest.jpg): Permission denied

12.13.2006 22:16:36 - ERROR 2 in /web/photos/admin/.include/fun_extra.php, line 318: unlink(/home/.sites/143/site2/web/photos/pictures/1_Family/_vti_cnf/foldername_de.txt): Permission denied

12.13.2006 22:16:36 - ERROR 2 in /web/photos/admin/.include/fun_extra.php, line 318: unlink(/home/.sites/143/site2/web/photos/pictures/1_Family/_vti_cnf/image.txt): Permission denied

12.13.2006 22:16:36 - ERROR 2 in /web/photos/admin/.include/fun_extra.php, line 318: unlink(/home/.sites/143/site2/web/photos/pictures/1_Family/_vti_cnf/Mardi Gras Group.jpg): Permission denied


If you visit www.lafleurhome.net and enter the photo album, select Misc Photos and you will see the bogus directory. If you click on it, all sorts of strange things happen. Right now, the _vti_cnf directory has a copy of every file in the parent directory and none can be deleted via FTP or by the TWG admin programs. Permission denied.

This is a friend's site and I'm just now getting the hang of all the bells and whistles in TWG, but this problem needs to be resolved. The host is a friend of his.

One final thing, in the Normal view of the file structure, I see all the original directories created by TWG installer have UID/GID of apache(48)/apache(48), the three _vti_cnf directories and their files have nobody(99)/site2(502).

Any suggestions.


Top
 Profile  
 
 Post subject:
PostPosted: 14. Dec 2006, 10:01 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10502
Hi,

interesting - the problem is that if TWG would create this directories they would have different user rights.
I have checked my whole code - I don't create this folders.

But I asked google! This are folders created by frontpage - maybe frontpage extensions are running on this host!

The problem is that TWG does detect these directories and does think that they are normal directories. And accessing them fails and TWG is stuck - you have to close the browser.


now it's how to solve this :).

easy - you can tell TWG which folder it should ignore!

in the config.php you find a setting called:

$exclude_directories=array("CVS","thumbs","data.pxp");
extend this to:
$exclude_directories=array("CVS","thumbs","data.pxp","_vti_cnf");

would work. BUT you should set this my_config.php! (for easier update of TWG)

if you put it in config.php or in the TWG Admin simply use:

$exclude_directories[]="_vti_cnf";

This adds this dir to the exclude array :).

I have added this directory to my local build too - it will be in the exclude list in the next build.

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 8. Jan 2007, 18:11 
Offline

Joined: 8. Jan 2007, 18:00
Posts: 1
i have this exact problem and yes i use frontpage. i did everything you said to do, and i am still getting the same problems. i included it both in the config.php and the myconfig.php

any other ideas? you can see it here
www.firedupyouth.org/media/gallery/index.php

i need this fixed soon, so any help would be greatly appreciated. thanks


Top
 Profile  
 
 Post subject:
PostPosted: 8. Jan 2007, 18:36 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10502
but what is your problem?

I checked the gallery - seems to work fine.

The directories are not a TWG problem - it's because of Frontpage!!! Frontpage creates them.
Adding this to the config leads only TWG to work properly.

I don't know how to delete this dirs because they are not created by TWG and cannot be removed with php at all because it's a different owner.
Best solution is to use any other tool except frontpage - because they are all better ;).

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 8. Jan 2007, 18:37 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10502
And you should delete the folder_de.txt in the pictres folder ;).

And maybe the problem was that after you have entered the exclude dir you did not close the browser - because then the cache of the directory reading was not refreshed ;).

/Michael


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO