Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 19. Oct 2017, 10:55

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: Problem with watermark
PostPosted: 10. Aug 2005, 23:30 
Offline

Joined: 10. Aug 2005, 15:04
Posts: 3
Hey there,

I have a problem with placing text on the pictures if I include TWG in my page. On my local installation (with xampp on win) everything works fine. Also if I use TWG standalone. But if I include TWG as script in my page and put it on my webspace no text appears. It seems like the ttf-file could not be found. Any hints? Thanks in advance.

Greetings!
Klaus-Peter


Top
 Profile  
 
 Post subject:
PostPosted: 11. Aug 2005, 08:18 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10497
Hi,

Seem's the function imagettftext does not exist on the host system

In the gd section should be:
FreeType Support enabled
FreeType Linkage with freetype

Call the info.php. TWG makes some tests and tells you if the function is available.

You can check the xml/_mydebug.out if there is an error message related to the watermark.

You should still be able to use an image as watermark. If you don't use an antialized font and change the $transparency there is almost no difference to a text.

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 11. Aug 2005, 11:07 
Offline

Joined: 10. Aug 2005, 15:04
Posts: 3
Hi Michael,

with info.php everything looks fine in the gd section. _mydebug.out said "Could not find/open font".
If I use twg stand-alone everythin works fine.
For the moment the solution is to change the twg index.php to adapt my layout. But I intend to use twg with cms.

Best Greetings!
Klaus-Peter


Top
 Profile  
 
 Post subject:
PostPosted: 11. Aug 2005, 11:55 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10497
Al right,

I think I know

go to
$font
in config.php - there is the $install_dir
if you have changed the install_dir - it does not work anymore.

The warermark stuff ist used from image.php - not index.php (the one where install_dir is needed).

Remove the $install_dir from
$font

(and from the watermark images too!).

Please let me know if it works then. I just don't understand why it work on your local machine when you integrate it ...

/michael


Top
 Profile  
 
 Post subject:
PostPosted: 11. Aug 2005, 12:53 
Offline

Joined: 10. Aug 2005, 15:04
Posts: 3
Yeah, that's it!
Before your hints I tried to move the font-file anywhere. Also I removed the dot from the filename. But I hadn't the idea to remove the install_dir.
Maybe it works lokal because the font is installed in my windows.
Anyway, MANY THANKS!
If you like, have a look at www.kostian.net

Best Greetings!
Klaus-Peter


Top
 Profile  
 
 Post subject:
PostPosted: 11. Aug 2005, 14:45 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10497
Hi,

I'm not really satisfied where the i_frames open - Can you please send me your include page per mail?

Because in the bottom part was a pixel that was used for some measurement and therefore adjusting things. If you see the maximized view (maximierte Ansicht), you know what I mean

I'm thinking of placing this pixel inside the picture area.
Because otherwise it gets removed too quickly :).

You can include the twg as well - I don't have to make any adjustments then.

An you should include the twg in a table! - It uses 100% of the height - if you don't put a table around it uses 100% + the stuff you have on top ...

/michael


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO