Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 19. Oct 2017, 20:12

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 9 posts ] 
Author Message
 Post subject: 1.5.4 bug?
PostPosted: 23. Oct 2006, 15:08 
Offline

Joined: 12. Mar 2006, 12:28
Posts: 14
Hi,

I just upgraded to 1.5.4, from 1.5.2, and also registrered TWG. But now I seem to have some dificulties, sometimes it seems like twg is crashing my webserver (apache2) by quickly reloading one page over and over again. It's not consistent in all my albums, some are working ok...


Also I have noticed the following in my debug.txt :

10.23.2006 14:45:42 - ERROR 2 in /www/jule/website/twg15/admin/helper.php, line 28: mkdir() [<a href='function.mkdir'>function.mkdir</a>]: Permission denied

10.23.2006 14:45:46 - ERROR 2 in /website/twg15/inc/filefunctions.inc.php, line 1794: opendir(../pictures/Vinter 2006) [<a href='function.opendir'>function.opendir</a>]: failed to open dir: Permission denied


Top
 Profile  
 
 Post subject:
PostPosted: 23. Oct 2006, 16:23 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10497
what is in the Vinter 2006 directory?

video's? or are you trying to store the xml files in pictures folder. Because then you have to set the permissions of the pictures folder right.

If you have a folder that is reloading please give me an url - this should not happen at all - i'll take a look.

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 23. Oct 2006, 19:29 
Offline

Joined: 12. Mar 2006, 12:28
Posts: 14
In "Vinter 2006" there is a couple of subfolders which holds the pictures (ie. no pictures is stored directly below "Vinter 2006")

For the constant reload "feature" ;) Try looking at the following website :
#removed_broken_link?twg_ ... C_0483.JPG
choose a couple of pictures from the scroll bar at the bottom, then it seems like the browser is hanging, and the following is shown in the error log for apache

[Mon Oct 23 19:01:32 2006] [error] [client 83.93.97.250] File does not exist: /var/www/dummy, referer: #removed_broken_link
[Mon Oct 23 19:01:55 2006] [error] server reached MaxClients setting, consider raising the MaxClients setting

Regards
Thomas


Top
 Profile  
 
 Post subject:
PostPosted: 23. Oct 2006, 19:40 
Offline

Joined: 12. Mar 2006, 12:28
Posts: 14
another thing that I noticed, is that memory consumption is rather huge... I have memory limit set to 32Mb in php, and still I hit the limit (This hasn't been a problem before?) pictures are 2-3Mb each:

(from debug.txt)

10.23.2006 19:37:01 - File 'pictures/Byrsted/DSC_0496.JPG' is too big - it uses ~ 38193152KB. The memory limit is 33554432KB. Check the info for the maximum resolution! Please resize the image with an external tool or increate the php memory!

10.23.2006 19:37:02 - File 'pictures/Byrsted/DSC_0497.JPG' is too big - it uses ~ 38193152KB. The memory limit is 33554432KB. Check the info for the maximum resolution! Please resize the image with an external tool or increate the php memory!

------

A side note, i have now increased the memory limit to 64Mb, and now it is not reloading the page?

/ Thomas


Top
 Profile  
 
 Post subject:
PostPosted: 23. Oct 2006, 23:08 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10497
2-3 MB are quite big images - because php's gd lib need's lots of memory for an image (because it works with the uncompressed images in memory AND copies it in memory = 2 times the size of uncompressed size).

About this being a problem - I cannot do somehing about this :) - it's the gd-lib :(

call the info.php - it tells you what is the max. resolution you can use

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 24. Oct 2006, 08:52 
Offline

Joined: 12. Mar 2006, 12:28
Posts: 14
I know that 2-3Mb is big, but the server is on my local network, so it's easier to just upload the pictures directly from the camera :) (resolution is 3008x2000 pixels).

Total size of the album is 5Gb, for 4941 pictures :) (Yeah, I like to take LOT's of pictures :wink:)


Top
 Profile  
 
 Post subject:
PostPosted: 24. Oct 2006, 09:06 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10497
resolution is only a problem when the cache images are created the first time - if you have enough php memory ...

if you check your config you see what I estimate what's the max. resolution that should work.

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 24. Oct 2006, 09:36 
Offline

Joined: 12. Mar 2006, 12:28
Posts: 14
Ok, so the "constant reloading" is solved now (Being me using too large pictures :))..

And I also found the problem of the errors in debug.txt, my twg install folder was owned by root, so "TestParentdir" in admin/helper.php fails in generating the folder ../__TWG_TEST__

And the Vinter 2006 directory was missing the Read flag in permissions (How that got removed, I don't know..)...

So it seems like everything is working now..

Regards
Thomas


Top
 Profile  
 
 Post subject:
PostPosted: 24. Oct 2006, 11:02 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10497
good - I'll "hide" the error message fro the root dir because it's a test only and depending on the result I do something already.

Have fun using TWG,

Michael


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO