Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 15. Dec 2017, 23:49

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 52 posts ]  Go to page Previous  1, 2, 3, 4  Next
Author Message
PostPosted: 27. Sep 2011, 14:45 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10573
auf der Hauptseite? die funktion ist in TWG definert und sollte in der my_config schon funktionieren.

- Michael


Top
 Profile  
 
PostPosted: 27. Sep 2011, 14:48 
Offline

Joined: 8. Sep 2010, 21:41
Posts: 53
Galerie geht, aber ich kann mich nicht mehr einloggen.
Fehler kommt beim Login und auch Direktaufruf über ..admin/index.php

Thomas


Top
 Profile  
 
PostPosted: 27. Sep 2011, 15:11 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10573
Da must ja auch nicht hin - es ist ja zunächst das starten und stoppen der slideshow interressant.

erstmal die _mydebug.out löschen -> zur slideshow starten stoppen. _mydebug.out posten.

- Michael


Top
 Profile  
 
PostPosted: 27. Sep 2011, 22:26 
Offline

Joined: 8. Sep 2010, 21:41
Posts: 53
So jetzt aber:
Debug gelöscht und Slideshow start/stop - neue debug.out:

09.27.2011 22:22:09 (de) - ERROR 2048 in htdocs/Gallery/inc/filefunctions.inc.php, line 1419: date() [_a href='function.date'_function.date_/a_]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CEST/2.0/DST' instead
Request: /index.php?twg_album=Pullmancity_2010&twg_show=DSC01871.JPG&twg_slideshow=true&topic=bildergalerie
Stack: filefunctions.inc.php:1394:output:ERROR 2048 in htdocs/Gallery/inc/filefunctions.inc.php, line 1419: date() [<a href='function.date'>f:/homepages/9/d109708114/htdocs/Gallery/counter/_mydebug.out
Stack: filefunctions.inc.php:1452:debug:ERROR 2048 in htdocs/Gallery/inc/filefunctions.inc.php, line 1419: date() [<a href='function.date'>f
Stack: ::on_error:2048:date() [<a href='function.date'>function.date</a>]: It is not safe to rely on the system's timezone :/homepages/9/d109708114/htdocs/Gallery/inc/filefunctions.inc.php:1419:Array( [data] => /index.php [debug_file] => /homepages/9/d109708114/htdocs/Gallery/counter/_my
Stack: filefunctions.inc.php:1419:date:m.d.Y G:i:s
Stack: filefunctions.inc.php:1394:output:/index.php:/homepages/9/d109708114/htdocs/Gallery/counter/_mydebug.out
Stack: my_config.php:71:debug:/index.php
Stack: config.php:482:include:/homepages/9/d109708114/htdocs/Gallery/my_config.php
Stack: index.php:28:require:/homepages/9/d109708114/htdocs/Gallery/config.php
Stack: gallery.php:2:include:/homepages/9/d109708114/htdocs/Gallery/index.php
Stack: index.php:98:include:/homepages/9/d109708114/htdocs/includes/dyn_content/gallery.php
09.27.2011 22:22:09 (de) - /index.php
Request: /index.php?twg_album=Pullmancity_2010&twg_show=DSC01871.JPG&twg_slideshow=true&topic=bildergalerie
Stack: filefunctions.inc.php:1394:output:/index.php:/homepages/9/d109708114/htdocs/Gallery/counter/_mydebug.out
Stack: my_config.php:71:debug:/index.php
Stack: config.php:482:include:/homepages/9/d109708114/htdocs/Gallery/my_config.php
Stack: index.php:28:require:/homepages/9/d109708114/htdocs/Gallery/config.php
Stack: gallery.php:2:include:/homepages/9/d109708114/htdocs/Gallery/index.php
Stack: index.php:98:include:/homepages/9/d109708114/htdocs/includes/dyn_content/gallery.php
09.27.2011 22:22:10 (de) - ERROR 2048 in htdocs/Gallery/inc/filefunctions.inc.php, line 1419: date() [_a href='function.date'_function.date_/a_]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CEST/2.0/DST' instead
Request: /Gallery/i_frames/i_slideshowjquery.php?twg_album=Pullmancity_2010&twg_show=DSC01871.JPG&topic=bildergalerie
Stack: filefunctions.inc.php:1394:output:ERROR 2048 in htdocs/Gallery/inc/filefunctions.inc.php, line 1419: date() [<a href='function.date'>f:/homepages/9/d109708114/htdocs/Gallery/counter/_mydebug.out
Stack: filefunctions.inc.php:1452:debug:ERROR 2048 in htdocs/Gallery/inc/filefunctions.inc.php, line 1419: date() [<a href='function.date'>f
Stack: ::on_error:2048:date() [<a href='function.date'>function.date</a>]: It is not safe to rely on the system's timezone :/homepages/9/d109708114/htdocs/Gallery/inc/filefunctions.inc.php:1419:Array( [data] => /Gallery/i_frames/i_slideshowjquery.php [debug_file] => /homepages/9/d1097081
Stack: filefunctions.inc.php:1419:date:m.d.Y G:i:s
Stack: filefunctions.inc.php:1394:output:/Gallery/i_frames/i_slideshowjquery.php:/homepages/9/d109708114/htdocs/Gallery/counter/_mydebug.out
Stack: my_config.php:71:debug:/Gallery/i_frames/i_slideshowjquery.php
Stack: config.php:482:include:/homepages/9/d109708114/htdocs/Gallery/my_config.php
Stack: i_basic.inc.php:26:include:/homepages/9/d109708114/htdocs/Gallery/config.php
Stack: i_slideshowjquery.php:19:include:/homepages/9/d109708114/htdocs/Gallery/i_frames/i_basic.inc.php
09.27.2011 22:22:10 (de) - /Gallery/i_frames/i_slideshowjquery.php
Request: /Gallery/i_frames/i_slideshowjquery.php?twg_album=Pullmancity_2010&twg_show=DSC01871.JPG&topic=bildergalerie
Stack: filefunctions.inc.php:1394:output:/Gallery/i_frames/i_slideshowjquery.php:/homepages/9/d109708114/htdocs/Gallery/counter/_mydebug.out
Stack: my_config.php:71:debug:/Gallery/i_frames/i_slideshowjquery.php
Stack: config.php:482:include:/homepages/9/d109708114/htdocs/Gallery/my_config.php
Stack: i_basic.inc.php:26:include:/homepages/9/d109708114/htdocs/Gallery/config.php
Stack: i_slideshowjquery.php:19:include:/homepages/9/d109708114/htdocs/Gallery/i_frames/i_basic.inc.php
09.27.2011 22:22:11 (de) - ERROR 2048 in htdocs/Gallery/inc/filefunctions.inc.php, line 1419: date() [_a href='function.date'_function.date_/a_]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CEST/2.0/DST' instead
Request: /Gallery/image.php?twg_browserx=793&twg_browsery=585&fontscale=1&twg_xmlhttp=r
Stack: filefunctions.inc.php:1394:output:ERROR 2048 in htdocs/Gallery/inc/filefunctions.inc.php, line 1419: date() [<a href='function.date'>f:/homepages/9/d109708114/htdocs/Gallery/counter/_mydebug.out
Stack: filefunctions.inc.php:1452:debug:ERROR 2048 in htdocs/Gallery/inc/filefunctions.inc.php, line 1419: date() [<a href='function.date'>f
Stack: ::on_error:2048:date() [<a href='function.date'>function.date</a>]: It is not safe to rely on the system's timezone :/homepages/9/d109708114/htdocs/Gallery/inc/filefunctions.inc.php:1419:Array( [data] => /Gallery/image.php [debug_file] => /homepages/9/d109708114/htdocs/Gallery/cou
Stack: filefunctions.inc.php:1419:date:m.d.Y G:i:s
Stack: filefunctions.inc.php:1394:output:/Gallery/image.php:/homepages/9/d109708114/htdocs/Gallery/counter/_mydebug.out
Stack: my_config.php:71:debug:/Gallery/image.php
Stack: config.php:482:include:/homepages/9/d109708114/htdocs/Gallery/my_config.php
Stack: image.php:30:require:/homepages/9/d109708114/htdocs/Gallery/config.php
09.27.2011 22:22:11 (de) - /Gallery/image.php
Request: /Gallery/image.php?twg_browserx=793&twg_browsery=585&fontscale=1&twg_xmlhttp=r
Stack: filefunctions.inc.php:1394:output:/Gallery/image.php:/homepages/9/d109708114/htdocs/Gallery/counter/_mydebug.out
Stack: my_config.php:71:debug:/Gallery/image.php
Stack: config.php:482:include:/homepages/9/d109708114/htdocs/Gallery/my_config.php
Stack: image.php:30:require:/homepages/9/d109708114/htdocs/Gallery/config.php
09.27.2011 22:22:21 (de) - ERROR 2048 in htdocs/Gallery/inc/filefunctions.inc.php, line 1419: date() [_a href='function.date'_function.date_/a_]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CEST/2.0/DST' instead
Request: /Gallery/i_frames/i_slideshowjquery.php?twg_album=Pullmancity_2010&twg_show=DSC01884.JPG&topic=bildergalerie
Stack: filefunctions.inc.php:1394:output:ERROR 2048 in htdocs/Gallery/inc/filefunctions.inc.php, line 1419: date() [<a href='function.date'>f:/homepages/9/d109708114/htdocs/Gallery/counter/_mydebug.out
Stack: filefunctions.inc.php:1452:debug:ERROR 2048 in htdocs/Gallery/inc/filefunctions.inc.php, line 1419: date() [<a href='function.date'>f
Stack: ::on_error:2048:date() [<a href='function.date'>function.date</a>]: It is not safe to rely on the system's timezone :/homepages/9/d109708114/htdocs/Gallery/inc/filefunctions.inc.php:1419:Array( [data] => /Gallery/i_frames/i_slideshowjquery.php [debug_file] => /homepages/9/d1097081
Stack: filefunctions.inc.php:1419:date:m.d.Y G:i:s
Stack: filefunctions.inc.php:1394:output:/Gallery/i_frames/i_slideshowjquery.php:/homepages/9/d109708114/htdocs/Gallery/counter/_mydebug.out
Stack: my_config.php:71:debug:/Gallery/i_frames/i_slideshowjquery.php
Stack: config.php:482:include:/homepages/9/d109708114/htdocs/Gallery/my_config.php
Stack: i_basic.inc.php:26:include:/homepages/9/d109708114/htdocs/Gallery/config.php
Stack: i_slideshowjquery.php:19:include:/homepages/9/d109708114/htdocs/Gallery/i_frames/i_basic.inc.php
09.27.2011 22:22:21 (de) - /Gallery/i_frames/i_slideshowjquery.php
Request: /Gallery/i_frames/i_slideshowjquery.php?twg_album=Pullmancity_2010&twg_show=DSC01884.JPG&topic=bildergalerie
Stack: filefunctions.inc.php:1394:output:/Gallery/i_frames/i_slideshowjquery.php:/homepages/9/d109708114/htdocs/Gallery/counter/_mydebug.out
Stack: my_config.php:71:debug:/Gallery/i_frames/i_slideshowjquery.php
Stack: config.php:482:include:/homepages/9/d109708114/htdocs/Gallery/my_config.php
Stack: i_basic.inc.php:26:include:/homepages/9/d109708114/htdocs/Gallery/config.php
Stack: i_slideshowjquery.php:19:include:/homepages/9/d109708114/htdocs/Gallery/i_frames/i_basic.inc.php



-Thomas


Top
 Profile  
 
PostPosted: 28. Sep 2011, 09:50 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10573
o.k. die Variable wird korrekt gesetzt.

Das mit dem Datum sollte nicht sein. Kommt das immer?

Ich schau mal, dass wenn die Variable nicht gesetzt ist (scheint in der session verloren zu gehen) eine alternative genommen wird.
Dann sollte es auch bei dir gehen.

Mal schauen, ob ich das heute abend mal hinbekomme.

- Michael


Top
 Profile  
 
PostPosted: 28. Sep 2011, 10:08 
Offline

Joined: 8. Sep 2010, 21:41
Posts: 53
Hallo Michael,

das kann ich dir jetzt nicht beantworten, da ich gestern nur speziell diese eine Aufzeichnung gemacht habe, sprich unmittelbar vor dem Start die debug gelöscht und gleich nach dem Stop ausgelesen, ohne weiter zu klicken.
Das müsste ich dann ggf auch nochmal probieren, wenn du weitere Infos brauchst.
Deswegen brauchst aber jetzt nicht alles andere liegen lassen, weiß eh nicht ob ich diese Woche da nochmal vernünftig dazu komme, eher WE.
Gibst einfach kurz bescheid, sobald du eine Lösung hast.

Könnte das Problem auch die Ursache für das Loginproblem sein ?

-Thomas


Top
 Profile  
 
PostPosted: 28. Sep 2011, 10:23 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10573
Ich denke nicht. Die eine debug Zeile kannst du wieder rausnehmen.

das mit dem date kann auch sein, weil die debug auch das datum verwendet und ich normalerweise das setzen der Zeitzone nur da habe, wo ich es normalerweise brauche.

- Michael


Top
 Profile  
 
PostPosted: 28. Sep 2011, 10:36 
Offline

Joined: 8. Sep 2010, 21:41
Posts: 53
Ich meinte nicht den Login in Verbindung mit der Debug, sondern im "normalen" Betrieb die Weiterleitung zur Übersicht. Da hab ich ja einen weissen Bildschirm mit Anmeldefenster und es wird nicht weiter navigiert. Die Session startet aber, denn starte ich dann im Standalone bin ich bereits angemeldet, also funktioniert die Übergabe schon.

-Thomas


Top
 Profile  
 
PostPosted: 28. Sep 2011, 11:26 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10573
Ist schon klar. Aber die Variable, die ich dort benötige scheint bei dir nicht korrekt gesetzt zu werden.
Bei nicht php include weis ich die - bei php include eben nicht.

Ich werd mal eine backup Variable machen, die du dann direkt in der config setzen kannst.

- Michael


Top
 Profile  
 
PostPosted: 28. Sep 2011, 11:46 
Offline

Joined: 8. Sep 2010, 21:41
Posts: 53
alles klar, dank dir


Top
 Profile  
 
PostPosted: 28. Sep 2011, 22:52 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10573
Aktuelisier TWG mal mit dem aktuellen patch und dann setze

$config_twg_root auf die Datei, wo du TWG einbindest. Und zwar den kompletten pfad vom browser startend mit /

- Michael


Top
 Profile  
 
PostPosted: 29. Sep 2011, 14:53 
Offline

Joined: 8. Sep 2010, 21:41
Posts: 53
Hallo Michael,
das ging ja fix. Ok probier es heute Abend aus.

wenn ich das jetzt richtig verstanden habe, in der my_config

$config_twg_root="includes/dyn_content/gallery.php";

setzen?!

So liegt die Datei auf dem Server


-Thomas


Top
 Profile  
 
PostPosted: 29. Sep 2011, 15:00 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10573
glaub ich nicht - TWg liegt ja unter /Gallery/
dass müste das eher /gallery.php sein.

Der rest ist ja vom Server nicht sichtbar.

- Michael


Top
 Profile  
 
PostPosted: 29. Sep 2011, 23:33 
Offline

Joined: 8. Sep 2010, 21:41
Posts: 53
Geil,geil,geil

Mit

$config_twg_root="index.php";

geht die Slideshow jetzt wunderbar :D
Tausend Dank für den Patch!

Jetzt noch der Login: nach Anmeldung kommt folgendes:

Multiple Choices
The document name you requested (/Gallery/i_frames/index.php) could not be found on this server. However, we found documents with names similar to the one you requested.
Available documents:

/Gallery/i_frames/index.htm?twg_album=&twg_show=&topic=bildergalerie (common basename)
Please consider informing the owner of the referring page about the broken link.

Kann es sein, dass hier ein Link noch nicht ganz passt?

-Thomas


Top
 Profile  
 
PostPosted: 29. Sep 2011, 23:37 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10573
ich denk immer noch

$config_twg_root="/gallery.php";

sollte es heißen. Ohne den / bleibst du ja im aktuellen Verzeichnis und deine Datei in die du die TWG includest ist ja nicht die index.php oder?

- Michael


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 52 posts ]  Go to page Previous  1, 2, 3, 4  Next

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO