Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 24. Oct 2017, 02:06

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 25 posts ]  Go to page Previous  1, 2
Author Message
 Post subject: Re: SEO & Adressleiste
PostPosted: 7. Sep 2014, 13:41 
Offline

Joined: 15. Aug 2014, 19:35
Posts: 99
Hallo Michael,
da mir das mit dem php-include nicht so richtig Ruhe lässt, muss ich doch noch einmal nachhaken.
Also, ich habe twg ja bislang mit deinem Modul integriert, was ja auch funktioniert.
Nun habe ich mal parallel einen Menüpunkt "Testgalerie" eingerichtet, und in der Konfig $php_include=true; & $install_dir="../twg/"; hinzugefügt.
Das sollte ja auch richtig sein, da der absolute Pfad /html/picsforjoo/twg lautet.

So, nun habe ich unter der Testgalerie einen Beitrag erstellt, und in dem Beitrag nichts weiter als ein Blank Modul. Im Blank Modul ist include 'twg/index.php' als php eingetragen.

Wie neulich schon gezeigt, sieht das ganze dann so aus: http://www.picsforjoo.de/testgalerie
Was mich am meisten stört ist die Tatsache, dass twg ein Passwort fordert, obwohl keines vergeben ist außer für den Admin Bereich, welches nicht genommen wird.
Was mir aber auch aufgefallen ist, der Zähler zeigt nur einen Besucher...
Setze ich aber den Eintrag in der Konfig auf $install_dir="twg/"; dann zeigt mir die Galerie die tatsächlichen Besucher, zur Zeit um die 1700.
Dafür geht dann die eigentliche, mit Modul eingebundene nicht mehr :-(
Nehme ich den Eintrag $install_dir="twg/"; ganz raus, funktioniert die iframe Lösung, aber die php iclude Lösung findet keine Index.php.

Aber bedeutet das nicht, dass es ein grundsätzliches Pfadproblem ist?
Bzw. warum beeinflusst der Konfig Parameter beide Möglichkeiten?

Und css oder Bootstrap hin oder her, warum verlangt twg nach einem Passwort?

Dass es Darstellungsprobleme geben kann hab ich ja verstanden, aber es scheint doch irgendetwas anderes nicht zu stimmen, oder?

Ich möchte ja nur erreichen, dass twg bestmöglich mit den zur Verfügung stehenden Möglichkeiten funktioniert... und das tut es noch nicht zufriedenstellend, da per iframe jede Galerie oder Untergalerie den selben Pfad in der Adresszeile zeigt, und man keinen Link zu einer Untergalerie oder sogar einem einzelnen Bild weitergeben kann.

Vielleicht kannst du dir das ja nochmal ansehen?

Vielen Dank.


Top
 Profile  
 
 Post subject: Re: SEO & Adressleiste
PostPosted: 7. Sep 2014, 21:29 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10502
du willst auf die Installation per iframe und php include zugreifen? Das geht auf keinen Fall.
Ich teste gerade TWG 2.2 mit php include. I testet immer mit twg/ als Pfad. Evtl. git es ein Problem mit ../twg/ an der Stelle.
Ich hab noch ne was bei twg/ zu fixen und dann kann ich mir das mit ../twg/ anschauen.

Wenn du das gemischt brauchst, must du twg_stanalone=true dort hinzufügen, wo es ohne php_include passen soll. Wenn du php include verwendest kannst du TWg auch in einem neuen Window öffenen. Das brauchst du evtl.

Gruß, Michael


Top
 Profile  
 
 Post subject: Re: SEO & Adressleiste
PostPosted: 7. Sep 2014, 22:13 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10502
Ich hab es jetzt auch bei mir mit ../twg/ getestet und das geht auch.
Wichtig ist, dass du immer den session cache löscht. Also auf das Bandbreitensymbol klickst oder das in der Administration machst. Sonst passt kein Pfad...

Gruß, Michael


Top
 Profile  
 
 Post subject: Re: SEO & Adressleiste
PostPosted: 7. Sep 2014, 22:20 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10502
Was mich mehr stört ist, dass gar keine Albums da sind. Passt da evtl. das basedir nicht zusammen?
Das mit dem login window ist evtl. weil meine Styles und das Javascript überschrieben werden. Dann wird der halt plötzlich angezeigt.


Top
 Profile  
 
 Post subject: Re: SEO & Adressleiste
PostPosted: 8. Sep 2014, 16:36 
Offline

Joined: 15. Aug 2014, 19:35
Posts: 99
Nein, ich benötige natürlich nicht beide Möglichkeiten ;-)
Nur will ich ja solange das mit php include noch nicht geht, die Galerie weiter per iframe anzeigen lassen.
Sobald es funktioniert, würde ich ja auf die php Variante zurückkommen und als Pfad nur $install_dir="twg/"; in der Konfig eintragen.
Da mir ja dabei die tatsächlichen Besucher angezeigt werden, scheint das ja zu passen. Und die iframe Lösung brauche ich ja nicht zusätzlich.

ABER, ja das mit dem Passwort und den fehlenden Galerien... Genau das ist auch mein Problem.
Was meinst du mir basedir?
Wie gesagt, der absolute Pfad lautet /html/picsforjoo/twg, wenn dir das weiterhilft. Und dort wird ja die index.php wohl auch gefunden, halt nur per Passwort ausgeblendet...?


Top
 Profile  
 
 Post subject: Re: SEO & Adressleiste
PostPosted: 10. Sep 2014, 00:00 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10502
Hast du globale Passworte?

Ich hab mit php include bei mir alles getestet und das geht ohne Probleme.
Aber ich denke auch, dass du beim css vom bootstrap und twg noch richtig viel arbeit vor dir hast.

hast du den basisordner von TWG für die Bilder geändert? weil der ist mit basedir festgelegt.

Gruß,
Michael


Top
 Profile  
 
 Post subject: Re: SEO & Adressleiste
PostPosted: 10. Sep 2014, 01:10 
Offline

Joined: 15. Aug 2014, 19:35
Posts: 99
Globale Passworte?
Also ich habe eines für den Adminbereich der twg festgelegt, und das ist zufällig das gleiche wie für meinen Joomla Login...
Aber das kann sich doch nicht beißen, oder?
Andere Passworte habe ich nicht vergeben, oder was genau meinst du mit global?

Also der Ordnerpfad ist unverändert, bei mir also /html/picsforjoo/twg/pictures

Ich werde das die Tage nochmal auf einer anderen Seite probieren, mit einem ganz simplen Template und einer ganz frischen twg Testinstallation.
Melde mich dann nochmal, ob es damit dann funktioniert oder ob auch nicht.
Falls dir noch etwas dazu einfällt, ich bin für jeden Tipp dankbar ;-)


Top
 Profile  
 
 Post subject: Re: SEO & Adressleiste
PostPosted: 10. Sep 2014, 16:44 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10502
nein. Man kann globale Passwörter für die ganze Galerie festlegen.

Gruß, Michael


Top
 Profile  
 
 Post subject: Re: SEO & Adressleiste
PostPosted: 10. Sep 2014, 17:00 
Offline

Joined: 15. Aug 2014, 19:35
Posts: 99
Gut, das habe ich ja nicht. Sonst könnte ich ja egal wie nicht auf die Galerie zugreifen.
Ich melde mich die Tage nochmal, wenn ich twg auf einer anderen Seite getestet habe.
VG, Wolfgang


Top
 Profile  
 
 Post subject: Re: SEO & Adressleiste
PostPosted: 11. Sep 2014, 18:46 
Offline

Joined: 15. Aug 2014, 19:35
Posts: 99
So, ich habe jetzt mal auf meiner Seite www.starrost.de getestet, und hier ist es jetzt so, dass bei gleicher Konfiguration ($php_include = true; & $install_dir="../twg/";) gar nichts angezeigt wird. Hab auch $install_dir="./twg/"; $install_dir="/twg/"; $install_dir="twg/"; probiert, bei allen das gleiche. Nämlich nüscht :-(
Als Template habe ich es mit dem simplen Beez versucht, und auch mit einem ganz einfachen anderen. Beide ohne Bootstrap.
Kannst ja mal selber schauen, oben im Menü Galerie (mit php include), alternativ dazu die Testgalerie (mit iframe).

Hast du es denn auch unter Joomla getestet, und wenn ja mit welchem Template?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 25 posts ]  Go to page Previous  1, 2

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO