Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 24. Oct 2017, 04:07

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 7 posts ] 
Author Message
PostPosted: 24. Oct 2014, 20:36 
Offline

Joined: 15. Aug 2014, 19:35
Posts: 99
Hallo Michael,

auch auf die Gefahr hin dass ich nerve, das ist nicht meine Absicht....
Aber mir lässt die Integration in meine Joomla Seite keine Ruhe, und ich raff es glaub ich nicht richtig.

Also, mal der Reihe nach die Fakten:
Mein Pfad zur twg ist:
/html/picsforjoo/twg
Darin befindet sich dann der Ordner pictures wie es vorgesehen ist.

In der twg Konfiguration habe ich eingetragen:
$php_include=true;
$install_dir='../twg/';

In dem Beitrag wo die Galerie erscheinen soll habe ich dieses https://blackdale.com/index.php/extensions/blank blank Modul integriert, und darin folgenden php Code eingetragen:
include "../twg/index.php"
(öffnen und schliessen des PHP Tags ist bei diesem Modul nicht vorgesehen, dies geschieht selbstständig)

Nun habe ich schon alle denkbaren Konstellationen erfolglos ausprobiert, wie in einem anderen Thread schon mal beschrieben.

In deinen FAQ verweist du auf die Datei example_php_include.php und schreibst dazu:
Quote:
TWG kann direkt in vorhandene php-Seiten oder Content-management-Systeme eingebunden werden. Wenn Sie dazu „include index.php“ verwenden wollen (ein Beispiel dafür, wie das geht, finden Sie in der Datei „example_php_include.php“) müssen Sie die beiden nachstehenden Einstellungen vornehmen:
$php_include=true
$install_dir="<relative(!) path to the twg installation>/"; - The / at the end is important! If you e.g. have twg installed in the directory twg relative to your main file then use $install_dir="twg/". If you have installed TWG in a parallel directoy you have e.g. to use $install_dir="../twg/".

In dem readme im Ordner examples steht geschrieben:
Quote:
There are the 3 configs of the demos in this folder (my_config.php*)
The pictures folder ($basedir) of the config files is "../pictures"
if you use these configs please change this back to "pictures".

&
Quote:
The example* files are examples how-to integrate TWG. copy them into the main folder to see how they work!


Ich würde twg zu gerne mit include einbinden, aber ich bekomme es nicht gebacken.

Nun habe ich folgende Fragen:
    Hast du denn das auch schon mal mit einer aktuellen Joomla Version getestet?
    Muss ich die example_php_include.php irgendwo auf meinem Server ablegen?
    Wenn ja, dann wo und unter welchem Namen?
    Oder habe ich ein grundsätzliches Pfadproblem?

Vielleicht findest du ja auch ganz spontan eine Lösung...
VG, Wolfgang


Top
 Profile  
 
PostPosted: 25. Oct 2014, 13:03 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10502
Zu deinen Fragen:
- Nein. Ich integriere das immer per iframe weil die Stylesheets und alle Javascripts zusammenzubringen ist mir zu viel Arbeit.
- Nein.

Pfadproblem. schau halt einfach mal im code wo z.B. die css Dateien gesucht werden und wo sie wirklich sind.

Gruß, Michael


Top
 Profile  
 
PostPosted: 25. Oct 2014, 16:33 
Offline

Joined: 15. Aug 2014, 19:35
Posts: 99
Sorry, verstehe ich nicht :-(

In welchem Code soll ich nach welchen css Dateien suchen???

Also die einzige Konstellation wo auf die Galerie zugegriffen wird ist die , wenn ich in der Konfiguration $install_dir='twg/'; und in dem blank module include "twg/index.php"; eintrage.
Dann wird zumindest auf die richtigen Besucherzahlen zugegriffen, allerdings ist das dann die Konstellation in der twg ein (nicht vergebenes) Passwort fordert :-(


Top
 Profile  
 
PostPosted: 25. Oct 2014, 17:28 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10502
Hast du das online? dann schau ich schnell.
Weil anscheinend passt ja der Pfad noch nicht...

Aber selbst wenn denke ich nicht, das du so richtig glücklich wirst weil ja alle Styles von Joomla dann vorher geladen sind. Und von den Javascripts ganz zu schweigen. Weil mit Joomla kommt ja auch jQuery usw. mit... Da ist auf jeden Fall für eine der beiden Apps die falsche jQuery Version am laufen...


Top
 Profile  
 
PostPosted: 25. Oct 2014, 17:34 
Offline

Joined: 15. Aug 2014, 19:35
Posts: 99
Ja, jetzt hab ich es kurz wieder online:
http://www.picsforjoo.de/testgalerie


Top
 Profile  
 
PostPosted: 25. Oct 2014, 17:58 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10502
Es werden keine css Dateien gefunden.
Was mich wundert ist, dass aber die js Dateien und auch das iframe.

Evtl. ist das auch ein Problem mit dem SEO urls vom Joomla. Weil für meinen JFUploader muste ich das auch komplett berücksichtigen weil die Pfad ja über eine .htaccess geändert werden und nicht mehr so sind wie vorher... Zusammen mit meinen Seo pfaden wird das eher chaotisch.


Top
 Profile  
 
PostPosted: 25. Oct 2014, 18:06 
Offline

Joined: 15. Aug 2014, 19:35
Posts: 99
Hab es jetzt erst mal wieder umgestellt, damit die normale Galerie wieder funktioniert.
Genau das wundert mich ja auch, dass ein Teil geladen wird, aber nicht die eigentliche Galerie. Stattdessen diese Passwortabfrage...

Ich werde Morgen mal mit den SEO Einstellungen von Joomla spielen, vielleicht liegt ja das Problem wirklich darin.
Falls dir noch eine Lösung dazu einfällt, ich bin für jeden Vorschlag offen ;-)

Schönen Abend noch,
VG


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: Bing [Bot] and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO