Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 24. Oct 2017, 11:32

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 11 posts ] 
Author Message
PostPosted: 27. Nov 2011, 14:53 
Offline

Joined: 23. Nov 2011, 12:14
Posts: 14
Hallo,
um mehr Speicher zu haben, habe ich mir einen Root-Server angemietet und TWG dort installiert. Nach der Installation erhalte ich folgende Meldung:
TWG erfolgreich installiert und darunter:
Not Found The requestet document was not found on this server.

Rufe ich meine Url auf: www.billau1.de/index.php erhalte ich die Meldung:
Fatal error: require() [function.require]: Failed opening required '/var/www/vhosts/billau1.de/httpdocs/config.php' (include_path='.:') in /var/www/vhosts/billau1.de/httpdocs/index.php on line 28

Jetzt habe ich allerdings nicht so viel Ahnung vom Root-Server, aber an was könnte das liegen?
Danke
Gerhard


Top
 Profile  
 
PostPosted: 27. Nov 2011, 22:54 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10502
sind überhaupt alle Dateien drauf? Weil selbst die info.php wird nicht gefunden...

- Michael


Top
 Profile  
 
PostPosted: 27. Nov 2011, 23:27 
Offline

Joined: 23. Nov 2011, 12:14
Posts: 14
Nein, es waren nicht alle Dateien da. Ich habe jetzt die zip-Datei entpackt und mauelle rüberkopiert. Jetzt ist auch die info.php da.
Ich erhalte aber folgende Fehlermeldung:
11.27.2011 22:23:38 (en) - ERROR 2 in lau1.de/httpdocs/admin/_include/init.php, line 272: file_exists() [_a href='function.file-exists'_function.file-exists_/a_]: open_basedir restriction in effect. File(__/.) is not within the allowed path(s): (/var/www/vhosts/billau1.de/httpdocs/:/tmp/)
11.27.2011 22:23:38 (en) - ERROR 2 in lau1.de/httpdocs/admin/_include/init.php, line 285: is_dir() [_a href='function.is-dir'_function.is-dir_/a_]: open_basedir restriction in effect. File(/var/www/vhosts/billau1.de/httpdocs) is not within the allowed path(s): (/var/www/vhosts/billau1.de/httpdocs/:/tmp/)
11.27.2011 22:23:42 (en) - ERROR 2 in lau1.de/httpdocs/admin/_include/init.php, line 272: file_exists() [_a href='function.file-exists'_function.file-exists_/a_]: open_basedir restriction in effect. File(__/.) is not within the allowed path(s): (/var/www/vhosts/billau1.de/httpdocs/:/tmp/)
11.27.2011 22:23:42 (en) - ERROR 2 in lau1.de/httpdocs/admin/_include/init.php, line 285: is_dir() [_a href='function.is-dir'_function.is-dir_/a_]: open_basedir restriction in effect. File(/var/www/vhosts/billau1.de/httpdocs) is not within the allowed path(s): (/var/www/vhosts/billau1.de/httpdocs/:/tmp/)

Worauf lässt das schliesen?
Danke
Gerhard


Top
 Profile  
 
PostPosted: 27. Nov 2011, 23:42 
Offline

Joined: 23. Nov 2011, 12:14
Posts: 14
Irgendwie haben meine Ordner keine Schreibrechte.
Muss ich die denn manuell setzen?
Beim shared-server war das alles ok.
Gruss Gerhard


Top
 Profile  
 
PostPosted: 27. Nov 2011, 23:56 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10502
bei dir sind basedir restriktionen gesetzt. das heist, das deinen Dateien keine Dateien in übergeordneten Dateien aufrufen dürfen.
Das solltest du ändern.

Wegen Rechten kann ich dir nichts sagen. ist auf jedem server anders...

- Michael


Top
 Profile  
 
PostPosted: 28. Nov 2011, 14:43 
Offline

Joined: 23. Nov 2011, 12:14
Posts: 14
Also nach der Neuinstallation mit der Kopieren-Methode scheint TWG zu laufen.
Aber der Fehler in der Debug-Datei kommt immer noch.
Ich habe inder php.ini gesetzt:
save_mode = off
open_basedir = off

aber es hat nichts genützt. Es kommt immer noch der gleiche Feher.
Bitte um Hilfe was ich noch tun kann.
Danke
Gerhard


Top
 Profile  
 
PostPosted: 28. Nov 2011, 14:54 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10502
Evtl. hilft ja das lesen der Dokumentation von open_basedir.

weil Off ist hier kein gültiger Wert - must du 'none' verwenden...

- Michael


Top
 Profile  
 
PostPosted: 29. Nov 2011, 10:31 
Offline

Joined: 23. Nov 2011, 12:14
Posts: 14
Also zuerst habe ich open_basedir none in der php.ini gesetzt, ohne Erfolg.
Dann in der httpd.conf, einmal mit:
php_admin_value open_basedir none und einmal nur mit
open_basedir none

Alles ohne Erfolg, die Fehlermeldugn in der Debug-Datei kommt immer noch.
Weis jemand weiter?

Danke Gerhard


Top
 Profile  
 
PostPosted: 29. Nov 2011, 11:01 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10502
Frag doch einfach mal bei den Jungs nach, wo du deinen Server hast. Weil die haben das anscheinend ja eingerichtet.
bzw. gib einfach mal das Verzeichnis an, wo er motzt...

- Michael


Top
 Profile  
 
PostPosted: 29. Nov 2011, 11:13 
Offline

Joined: 23. Nov 2011, 12:14
Posts: 14
Also motzen tut er im Verzeichnis:
11.29.2011 10:09:50 (en) - ERROR 2 in lau1.de/httpdocs/admin/_include/init.php, line 272: file_exists() [_a href='function.file-exists'_function.file-exists_/a_]: open_basedir restriction in effect. File(__/.) is not within the allowed path(s): (/var/www/vhosts/billau1.de/httpdocs/:/tmp/)


Top
 Profile  
 
PostPosted: 29. Nov 2011, 13:31 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10502
gib halt einfach dein root Verzeichnis an.

- Michael


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 11 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: Google [Bot] and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO