Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 20. Oct 2017, 01:53

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 28 posts ]  Go to page 1, 2  Next
Author Message
PostPosted: 27. Apr 2011, 09:53 
Offline

Joined: 27. Apr 2011, 09:38
Posts: 9
Hallo Michael,
habe ein Problem im IE 9.0 (32 und 64 Bit), iE 9 verkleinert im iframe immer auf die Größe des angezeigten Bildes, im Hauptmenü und auch im Flash Menü. Im Firefox funkt. alles - Darstellung in voller Größe im iframe.
Dem iframe habe ich eine fixe Größe vorgegeben - width="960px" height="690px"


www.austrianbengals.com/galerie.html

Bitte um Hilfe,

mfg, herbert


Top
 Profile  
 
PostPosted: 27. Apr 2011, 11:39 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10497
was passiert, wenn du was anderes in den iframe packst?

- Michael


Top
 Profile  
 
PostPosted: 27. Apr 2011, 12:10 
Offline

Joined: 27. Apr 2011, 09:38
Posts: 9
#removed_broken_link

ein Bild mit 960pix breite,

wird im Firefox ein wenig verkleinert, im IE 9 ein wenig nach rechts verschoben aber in der vollen Größe dargestellt.

im firefox bei mouseover erscheind eine lupe zum vergrößern, nach dem anklicken gleiches Erscheinungsbild wie im IE 9.


Top
 Profile  
 
PostPosted: 27. Apr 2011, 12:28 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10497
Den ie9 hab ich nicht hier.
Muss ich mir heute Abend mal anschauen.

Aber der iframe selbst sollte sich nicht verändern.

- Michael


Top
 Profile  
 
PostPosted: 27. Apr 2011, 12:39 
Offline

Joined: 27. Apr 2011, 09:38
Posts: 9
habe dir 4 screenshots hochgeladen, so siehts dann aus


Top
 Profile  
 
PostPosted: 27. Apr 2011, 12:40 
Offline

Joined: 27. Apr 2011, 09:38
Posts: 9
und das 4.


Top
 Profile  
 
PostPosted: 27. Apr 2011, 12:43 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10497
o.k.

Du kannst im Stylesheet style.css

wo du

html, body.twg {
vertical-align:top;
height:100%;
margin: 0px;
padding: 0px;
}

findest

html, body.twg {
vertical-align:top;
width: 960px;
height: 690px;
margin: 0px;
padding: 0px;
}

daraus machen.

- Michael


Top
 Profile  
 
PostPosted: 27. Apr 2011, 13:00 
Offline

Joined: 27. Apr 2011, 09:38
Posts: 9
schon um Klassen besser, danke, jedoch Einrückung des unteren Rahmens (bei Flash) und kein Vollformat in den "Galerien"


Top
 Profile  
 
PostPosted: 27. Apr 2011, 13:29 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10497
you can try to set the height in

td.twg_info {

this is the inner content only. So this might be 920px.

There you can set the background of the inner one as well.
So set this and the color of the body to the border color.

Then you don't see a difference between the browsers anymore.

I'll check for 1.8.5 and test for IE9 then at home.

- Michael


Top
 Profile  
 
PostPosted: 28. Apr 2011, 08:07 
Offline

Joined: 27. Apr 2011, 09:38
Posts: 9
Hallo Michael,

habs fürs erste hinbekommen mit diesen Änderungen:

/* Needed for IE to resizes tables to the full height */
html, body.twg {
vertical-align:top;
width: 960px;
height: 690px;
margin: 0px;
padding: 0px;
}

und

.twg_100_prozent {
width: 100%;
height:636px;
}

und in der TWG Konfig: Höhe des IFrames für den IE: 100

hoffe das funktioniert auch mit niedrigeren IE Versionen, danke


Top
 Profile  
 
PostPosted: 28. Apr 2011, 08:58 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10497
gut.

leider hat meine installation vom ie9 mit allen windows updates gestern sehr lange gedauert.
Ich hab mal ein paar iframes getestet und das scheint nicht nur bei TWG ein Problem zu sein.

Aber ohne iframe scheint alles gut auszusehen.
Mal schauen, ob ich eine dynamische Lösung finde.

- Michael


Top
 Profile  
 
PostPosted: 30. Apr 2011, 01:04 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10497
So,

ich hab das bei mir mit dem ie9 getestet und das Problem hatte ich so nicht. Nur auf meiner Demo 2 hatte ich
beim iframe die breite nicht angegeben, was zu einem unschönen Effekt führt.

Kannst du hier mal schauen:
http://www.tinywebgallery.com/de/demo2.php

Was mit bei dir noch aufgefallen ist:

bei dem iframe kannst du noch
scrolling = "no"
hinzufügen dann ist rechts der Rand weg.

und beim thumbnail flash kann man auch die hintergrundfarbe setzen! Dann sieht das deutlich schöner aus.

Gruß, Michael


Top
 Profile  
 
PostPosted: 30. Apr 2011, 14:49 
Offline

Joined: 27. Apr 2011, 09:38
Posts: 9
hallo Michael, link geht leider nicht,

Einstellungen in der style.css - nur noch diese Werte geändert
/* Needed for IE to resizes tables to the full height */
html, body.twg {
vertical-align:top;
width: 960px;
height: 690px;
margin: 0px;
padding: 0px;
}

und noch
<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" /> in meiner galerie.html eingefügt

sowie
scrolling = "no"
eingefügt.

Im Firefox alles besten, habe das iframe auf 1000px vergrößert, wenn nun ein Kommentar kommt verlängert sich das Fenster automatisch,

beim IE9 wird leider die ganze Höhe sofort angezeigt (1000px), aber damit kann ich leben, schaut trotzdem gut aus.

#removed_broken_link

dann warte ich mal auf die Enterprise Edition :wink:

gruß, herbert


Top
 Profile  
 
PostPosted: 30. Apr 2011, 15:36 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10497
so - mein link war lokal. ist jetzt der von meiner Demo.

den Metatag setz ich in der Galerie auch - weil sonst ist der IE ja noch unberechenbarer ;).

- Michael


Top
 Profile  
 
PostPosted: 6. Oct 2011, 09:53 
Offline

Joined: 25. May 2011, 17:05
Posts: 11
Hi zusammen.

Ich habe auch ein Darstellungsproblem im IE.
Es ist auch nicht gut zu beschreiben, deswegen werde ich einfach mal den direkten Link posten.

#removed_broken_link

Im IE ist alles verschoben und es ist nen 2. Table zu sehen.
Ich hoffe es kann jemand helfen! Und warum bekommt IE so etwas nicht geregelt?!
Ich kann mich nicht erinnern schon einmal eine Seite gehabt zu haben die von anfang an im IE lief...


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 28 posts ]  Go to page 1, 2  Next

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO