Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 22. Oct 2017, 21:09

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 6 posts ] 
Author Message
PostPosted: 4. Nov 2010, 16:26 
Offline

Joined: 4. Nov 2010, 16:11
Posts: 3
Hello. I've been using JFU on my OVH account. It was working perfectly well until recently. Log file:
Code:
11.04.2010 15:10:16 - Config call, illegal direct access or missing session settings - your browser has to be closed to get a new session.
11.04.2010 15:10:27 - Config call, illegal direct access or missing session settings - your browser has to be closed to get a new session.

In JFU config, the "Enable upload debug" and "Enable enhanced debug" are set to YES.

I'm almost certain I didn't mess with Joomla config in past few days, but a week ago it worked and now it doesn't. I called OVH and they've said they didn't change anything in server setup.

To narrow the problem down: I can upload files via HTML form + PHP. I installed Extplorer, and it's flash uploader also doesn't work for me. Please somebody help me work it out.


Top
 Profile  
 
PostPosted: 4. Nov 2010, 16:55 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10498
Please read howto 1 of the tfu faq. There are a couple of things you can try.

I think someone has changed something but does not know this anymore ;).

Best,
Michael


Top
 Profile  
 
PostPosted: 4. Nov 2010, 17:27 
Offline

Joined: 4. Nov 2010, 16:11
Posts: 3
I added the session_cache directory with the 0755 rights (every folder on my server has such rights). It worked. I can upload again. My question is: if I didn't create this folder before and I was able to upload, why can't I upload any more?

I wonder if there's a similar workaround for Extplorer. but then again, I hate workarounds, if something doesn't work on default I want to know why.


Top
 Profile  
 
PostPosted: 4. Nov 2010, 17:46 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10498
The problem is that flash does not send cookies properly. And if the server does additionally block session ids in the url (or encrypt them) there is a problem.
For TFU I have implemented an internal session handling because of this and therefore this extra directory is needed. If possible I create this automatically but on many server I don't have the rights to do so.

This is a know bug (since years) and this is the best way to handle it right now. I have tried almost all other workarounds which most of the time are not working or only for one request.

- Michael


Top
 Profile  
 
PostPosted: 4. Nov 2010, 22:24 
Offline

Joined: 4. Nov 2010, 16:11
Posts: 3
I understand that this is not a bug of JFU. What I can't understand is that the JFU worked fine for half a year and suddenly it got broken, and I had to make workarounds. Do you think my web host changed something recently, like introducing the session encryption?


Top
 Profile  
 
PostPosted: 5. Nov 2010, 01:11 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10498
JFU has not changed if you didn't ;). Many hosters do updates or change security settings and don't tell anyone even if they do...

- Michael


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO