Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 16. Dec 2017, 01:37

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: 9. Dec 2010, 13:08 
Offline

Joined: 9. Dec 2010, 12:02
Posts: 4
BTW I purchased the enterprise edition, so I guess I have a full working version.

I watch the video, read again and again and again all the documentation.

I simply unable to GET RID of the error - "The folder has no write permissions. All actions are disabled."

My Settings
- Inside frontend profile, I switched ON "master profile".
- CHMOD new files = 0777
- CHMOD new directories = 0777
- My default folder is already 0777

What I wish to achieve?
- A new user create an account with the Joomla registration form.
- Activate the new account.
- Login
- And able to upload file to his own folder (named with his username)
- JFU did create a folder in the username.
- BUT with error "The folder has no write permissions. All actions are disabled."

I wonder how to resolve this issue?

BTW I have used another FREE file-Upload-System which able to auto-create a folder in username with 777 permission. So I guess is not my server PHP.ini configuration problem.


Top
 Profile  
 
PostPosted: 9. Dec 2010, 13:38 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10573
is safe mode enabled?
It's not the problem to create a directory! It's the issue to be able to write to this directory it it belongs e.g. to an other owner and safe mode is enabled!

Can you upload to the automatically created folder with the internal html uploader of Joomla?

you can disable the directory create detection in the profile! It works on most server but not on all! So give it a try.

- Michael


Top
 Profile  
 
PostPosted: 9. Dec 2010, 16:49 
Offline

Joined: 9. Dec 2010, 12:02
Posts: 4
Resolved!
I have to remove all file permission settings and let my server decide.
- CHMOD new files =
- CHMOD new directories =

I have created a default folder for JFU to duplicate, which it did and retaining all permission setting I set for default. Excellence!!!
The default folder didn't work earlier also, until I remove all the permission setting.

Btw "directory create detection" is not the cause so remain "yes" for this.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO