Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 17. Dec 2017, 15:50

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 14 posts ] 
Author Message
PostPosted: 1. Nov 2007, 14:26 
Offline

Joined: 1. Nov 2007, 14:23
Posts: 4
Good afternoon,

I finally found a component that does exactly what i needed but unfortunately...i can not make it work properly. I have downloaded and installed version 2.5.3 and created a profile, added users to the profile, added the component to the menu, l go to the component through the frontend menu and although it loads nothing appears at the directory list. Same thing happens from the backend as well.

I had a look at the manuals but i couldn't find a possible reason why this can be happening. Any ideas ?


Top
 Profile  
 
 Post subject:
PostPosted: 1. Nov 2007, 22:36 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10573
is there a log file tfu.log in the administrator/components/joomla_flash_uploader/tfu folder?

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 2. Nov 2007, 09:17 
Offline

Joined: 1. Nov 2007, 14:23
Posts: 4
Hello Michael,

There is indeed. I am copy pasting the contents:

Quote:
11.01.2007 12:32:27 - Missing session settings - browser has to be closed to get a new session: PHPSESSID=76c05de9bdc87314a485607fd98cbe4b

11.01.2007 12:33:42 - Missing session settings - browser has to be closed to get a new session: PHPSESSID=76c05de9bdc87314a485607fd98cbe4b

11.01.2007 12:34:54 - Missing session settings - browser has to be closed to get a new session: PHPSESSID=76c05de9bdc87314a485607fd98cbe4b

11.01.2007 12:36:03 - Missing session settings - browser has to be closed to get a new session: PHPSESSID=76c05de9bdc87314a485607fd98cbe4b

11.01.2007 12:36:37 - Missing session settings - browser has to be closed to get a new session: PHPSESSID=76c05de9bdc87314a485607fd98cbe4b

11.01.2007 13:18:18 - Missing session settings - browser has to be closed to get a new session: PHPSESSID=76c05de9bdc87314a485607fd98cbe4b

11.01.2007 13:22:04 - Missing session settings - browser has to be closed to get a new session: PHPSESSID=76c05de9bdc87314a485607fd98cbe4b

11.01.2007 13:34:55 - Missing session settings - browser has to be closed to get a new session: PHPSESSID=76c05de9bdc87314a485607fd98cbe4b

11.01.2007 13:35:45 - Missing session settings - browser has to be closed to get a new session: PHPSESSID=76c05de9bdc87314a485607fd98cbe4b

11.01.2007 13:41:48 - Missing session settings - browser has to be closed to get a new session: PHPSESSID=76c05de9bdc87314a485607fd98cbe4b

11.01.2007 13:43:35 - Missing session settings - browser has to be closed to get a new session: PHPSESSID=76c05de9bdc87314a485607fd98cbe4b

11.01.2007 13:57:39 - Missing session settings - browser has to be closed to get a new session: PHPSESSID=f7212e5c5a5a422f4d62a5fcc0b7da3c

11.01.2007 14:00:13 - Missing session settings - browser has to be closed to get a new session: PHPSESSID=f7212e5c5a5a422f4d62a5fcc0b7da3c

11.01.2007 14:00:58 - Missing session settings - browser has to be closed to get a new session: PHPSESSID=76c05de9bdc87314a485607fd98cbe4b


Regards,

Alexander


Top
 Profile  
 
 Post subject:
PostPosted: 2. Nov 2007, 10:22 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10573
jfu cannot read the settings becuase the session is not passed properly by your php (server).

I know this problem by a user where the server removes the session id from the url to avoid session riding.
I have implemented a workaround in TFU 2.6 - for jfu I wanted to add this to in the 2.6 version.
but I wanted to make 2.6 if joomla 1.5 is available and then make jfu 2.6 for 1.1.x and 1.5

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 2. Nov 2007, 10:36 
Offline

Joined: 1. Nov 2007, 14:23
Posts: 4
Hello Michael,

Thank you for your quick response. May i ask when will this be available since your components would be very helpful for a project i need and i do not want to give FTP access to people ?

Is it possible to send me a pre-release version ?

Alexander


Top
 Profile  
 
 Post subject:
PostPosted: 2. Nov 2007, 11:01 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10573
Problem is that from tfu 2.5 to 2.6 I have optimized very much.
Therefore it's not a simple update.

And I don't know if this would solve the problem.

What we can do. I can send you a version of tfu where jfu is based on.
You try the version and check if the problem is there too.
then you try with the current tfu version.

If the problem is gone in the standalone version I at least know that updateing JFU right away would help.

Send me an email that I can send you the older standalone version of tfu if you like to test.

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 2. Nov 2007, 11:53 
Offline

Joined: 1. Nov 2007, 14:23
Posts: 4
Sounds good Michael. I'll PM you my email so we can do some proper testing.

Alexander


Top
 Profile  
 
 Post subject:
PostPosted: 5. Nov 2007, 13:56 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10573
Hi everyone.

This problem was a session problem (bug in php) and in 2.5.4 is a worakround for this. If you have the same problem please update to the latest version.

/Michael


Top
 Profile  
 
PostPosted: 17. Jan 2008, 13:28 
Offline

Joined: 17. Jan 2008, 13:25
Posts: 3
I have version 2.5.4, but I am getting the same error code. What can I do?


Top
 Profile  
 
 Post subject:
PostPosted: 17. Jan 2008, 13:46 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10573
you get the same entries in the tfu.log file?

/Michael


Top
 Profile  
 
PostPosted: 17. Jan 2008, 14:05 
Offline

Joined: 17. Jan 2008, 13:25
Posts: 3
Yes, exactly the same.

Example:
01.16.2008 23:40:50 - Missing session settings - browser has to be closed to get a new session: PHPSESSID=qpvcq61ef4pgnd3pb80um6jpj4

In the joomla admin component it says "JFU version 2.5.4"

When I open up tfu/tfu_config.php I get a blank screen and tfu/tfu_readDir.php says "Not logged in!"


Top
 Profile  
 
 Post subject:
PostPosted: 17. Jan 2008, 14:26 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10573
If the workaround does not help then unfortunately you have to wait until I update JFU to 2.7 because there I don't use the phpsessionid anymore. There I use an internal variable.

You can try the 2.7 version in the forum and test if the standalone version of 2.7 does work. If this is the case then You only have to wait until i'm finished with JFU 2.7 (I start working on this when the new versions are online)

/Michael


Top
 Profile  
 
PostPosted: 17. Jan 2008, 14:33 
Offline

Joined: 17. Jan 2008, 13:25
Posts: 3
Is the workaround in the version I installed? If so, then I will try the standalone.

Thanks.


Top
 Profile  
 
 Post subject:
PostPosted: 17. Jan 2008, 14:46 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10573
in the latest 2.5.4: yes.

Since 2.6 I don't use the phpsessionid variable anymore because this gets filtered by some servers and then I get a different session which leads to errors.

Try the 2.7 in the forum. If this works than JFU 2.7 should work too.

/Michael


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 14 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO