Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 18. Oct 2017, 07:40

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 11 posts ] 
Author Message
PostPosted: 27. Dec 2007, 09:07 
Offline

Joined: 11. Oct 2007, 17:42
Posts: 11
Location: Montréal
Me and some of my clients tryed many times to upload files over 100mb, the upload starts without problem, but never complete, it gives this error message : "Placement échoué. 1 fichier(s) de 1 ne peuvent être placés."

I have set up the "Site Session Lifetime" into the Joomla admin panel to 2700 seconds to see if it's because the session is timing out during the transfert, but it still doing this error, maybe I'll have to set it a higher level, but before I'd like to know if it's related to that or not.

The max size and the limit of the upload queue (in the config panel) are both set to 5000000, witch is big enough for the 600mb file I'm trying to upload.

Maybe it's related to my server, how can I know ?

Thanks !


Top
 Profile  
 
 Post subject:
PostPosted: 3. Jan 2008, 18:32 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10494
Leave the maximum limit in the config to autodetection!

Then the flash tells you the limit of the server.
On the help/registration panel you get the limits of your server as well.

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 7. Jan 2008, 20:41 
Offline

Joined: 11. Oct 2007, 17:42
Posts: 11
Location: Montréal
I left the max limit to autodetection, and adapted the php.ini file to a higher value, but now I get this error message in the middle of the transfert :

Erreur : undefined - io

I also inserted the .htacess file (the one that comes from the TFU download) into the swf directory because I was getting a message telling me to upload it. Now I'm a little confused about all those problems..

How do I correct that ?

Thanks !


Top
 Profile  
 
 Post subject:
PostPosted: 7. Jan 2008, 20:46 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10494
are the limits now shown correctly on the help page?

Because depending on the webserver it needs to be restarted that the values are taken.
The help page shows the settings of php.ini - not te one actually loaded (if you change it when the server on on)

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 7. Jan 2008, 20:46 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10494
but you can upload small images without the .htaccess?

Normally the .htaccess is only needed if the upload does not work at all!

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 7. Jan 2008, 20:56 
Offline

Joined: 11. Oct 2007, 17:42
Posts: 11
Location: Montréal
If I remove the .htaccess file, I get an "Http 403/406" that tells me to copie the .htaccess file into the twg_file_uploader.swf directory. It's happening with a small weight jpg.

The limits are shown correctly in the help page. And I cannot restart the server :) I don't have control on the servers of my webhosting !


Top
 Profile  
 
 Post subject:
PostPosted: 7. Jan 2008, 21:41 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10494
Small files do work with the .htaccess file?

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 7. Jan 2008, 21:47 
Offline

Joined: 11. Oct 2007, 17:42
Posts: 11
Location: Montréal
yes, small files works with .htacess


Top
 Profile  
 
 Post subject:
PostPosted: 7. Jan 2008, 21:54 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10494
o.k - How do you then modify php.ini?

Do you have a local one you can set?

What was the limit before? Maybe it's a timing problem. How long does the upload run until it fails? PHP has a default of 30 sec.

And have you set both settings in php.ini - like describe in the FAQ?

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 8. Jan 2008, 00:53 
Offline

Joined: 11. Oct 2007, 17:42
Posts: 11
Location: Montréal
and I have two php.ini files, one in my admin folder and another one in the TFU folder, and I did what it was written in the FAQ, and had some help from my hoster.

my php.ini file looks like that:

register_globals = Off
upload_max_filesize = 200M
post_max_size = 200M

I have a local version of my website, I can surely do some testing with it, if it's necessary.

Thanks !


Top
 Profile  
 
 Post subject:
PostPosted: 8. Jan 2008, 01:23 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10494
I don't think you have a problem with uploading on your local version, don't you?

if you have different php.ini files around it's best to call the tfu_config.php directly. It'll tell you the limit JFU is using. In the tfu folder in the administrator/compontent/com_joomla_flash_uploader folder.

I had this problem on a web server too. There it had to be restarted once to use the new settings. But this is normally not needed if local php.ini files are supported.

Does it fail after certan time (30 sec) maybe?

/Michael


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 11 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO