Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 15. Dec 2017, 20:02

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 8 posts ] 
Author Message
PostPosted: 19. Mar 2011, 20:56 
Offline

Joined: 19. Mar 2011, 20:45
Posts: 4
I've probably configured it incorrectly because my master profile mode front end profile is creating user directories but is not giving them permissions to upload files.

Can you tell me what the settings are supposed to be?

my settings are attached


Top
 Profile  
 
PostPosted: 19. Mar 2011, 21:53 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10573
1. are you sure you need the ftp mode?
2. On the main config page of JFU you can define with which rights folders are created. Simply set the setting like for folders you can upload. check also the owner! Then you see if you need the ftp oder the normal mode.

Best,
Michael


Top
 Profile  
 
PostPosted: 20. Mar 2011, 19:36 
Offline

Joined: 19. Mar 2011, 20:45
Posts: 4
I tried that but the directory is still created with incorrect permissons (see below output of ls -la) any other hints?

dr-----rwt 2 apache apache


Attachments:
screen.png
screen.png [ 23.22 KiB | Viewed 1293 times ]
Top
 Profile  
 
PostPosted: 20. Mar 2011, 19:39 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10573
which php version do you use? because chmod with ftp is only available in newer versions of php.
have you tried without using ftp mode for directories?

- Michael


Top
 Profile  
 
PostPosted: 20. Mar 2011, 21:21 
Offline

Joined: 19. Mar 2011, 20:45
Posts: 4
The strange thing about my setup is that if I create directories in the back end admin component, it works perfectly fine and the directory permissions are correct. The problem occurs when a new user tries to use it from the front end for the first time and the front end plugin creates the directory, it does it with the incorrect permissions. If I go back and fix the permissions manually, the user is now able to create other folders within his "home" directory with no problems.


Top
 Profile  
 
PostPosted: 20. Mar 2011, 21:30 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10573
which version do you use exactly?

In the master profile the ftp directory creation is not implemented yet.
I should add this there too ;).

Does it work in the backend if you disable the ftp mode ?

- Michael


Top
 Profile  
 
PostPosted: 20. Mar 2011, 21:35 
Offline

Joined: 19. Mar 2011, 20:45
Posts: 4
My bad. Sorry for taking up your time ... someone else had the same problem and posted the solution.

The solution is to remove the file create permissions from the site config ... I did that and it now works.

Thanks for the awesome component and the even more awesome response to issues with the component.

Chris


Top
 Profile  
 
PostPosted: 20. Mar 2011, 21:58 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10573
:) - like described at the parameters ;).

But I'll add the ftp mode support for master profiles the next version JFU anyway.

Best,
Michael


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: Google [Bot] and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO