Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 24. Oct 2017, 04:08

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 21 posts ]  Go to page 1, 2  Next
Author Message
PostPosted: 28. Sep 2010, 17:36 
Offline

Joined: 28. Sep 2010, 17:12
Posts: 15
Hi Im new to joomla and JFU but ive installed the component and all seems to have gone reasonably smoothly thanks to your tutorial videos. So far I can upload from the back end and from the front end but JFU tells me my server is restricting the size upload, Server infos:
Server name: http://www.stitchdiva.co.uk
PHP upload limit (in KB): 102400
PHP memory limit (in KB): 131072
Max. resize resolution: ~ 5461 x 4101
PHP max input time: 60 s
PHP max execution time: 180 s
Default socket timeout: 60 s
We dont need a masive file upload just about 3mb for the present, tho that may change once were familiar with your program and what its capable of.
I understand I have to increase 'upload_max_filesize' and 'post_max_size' in php.ini but mine are already fixed way above whats recommended, my settings are as follows :-

recomended --- My settings
upload_max_filesize = 20M --- 100M
post_max_size = 20M --- 105M
memory_limit=64M --- 128M
max_input_time=1800 --- 60
max_execution_time=1800 --- 180
default_socket_timeout=180 --- Missing

yet it wont upload anything higher than 1 mb .. any ideas where the problem may lie? I'm using Joomla 1.5.20 and JFU 2.11, I've tried searching for the error log but it doesnt seem to be where you menioned it would be in an earlier post, do I have to enable it in settings somewhere?
I cant access my php.ini file directly so I'll have to contact my ISP which is why I wanted the correct settings/things to tell them before hand ..
many thanks
glenn


Top
 Profile  
 
PostPosted: 29. Sep 2010, 09:39 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10502
1 MB seems a very small and your setting seems to be o.k.

You can enable the upload debug on the config page oj JFU. Then you see exactly where it fails.

- Michael


Top
 Profile  
 
PostPosted: 29. Sep 2010, 12:01 
Offline

Joined: 28. Sep 2010, 17:12
Posts: 15
TinyWebGallery wrote:
1 MB seems a very small and your setting seems to be o.k.

You can enable the upload debug on the config page oj JFU. Then you see exactly where it fails.

- Michael

Hi Michael, well Ive enabled the debug but it isnt creating a file, its as tho it doesnt see a problem ( and to be honest Im not getting any error mesage at all ) so Ive no idea where to turn now ...


Top
 Profile  
 
PostPosted: 29. Sep 2010, 12:40 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10502
check if the tfu folder is writeable. If not the log cannot be written and I write it to the system log then.

- Michael


Top
 Profile  
 
PostPosted: 29. Sep 2010, 12:55 
Offline

Joined: 28. Sep 2010, 17:12
Posts: 15
TinyWebGallery wrote:
check if the tfu folder is writeable. If not the log cannot be written and I write it to the system log then.

- Michael

Hi Michael, well the folder is set to 755 so it should be ok shouldnt it ?


Top
 Profile  
 
PostPosted: 29. Sep 2010, 13:49 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10502
depends - if php is not the owner than not. Then you have to use 777

- Michael


Top
 Profile  
 
PostPosted: 29. Sep 2010, 14:01 
Offline

Joined: 28. Sep 2010, 17:12
Posts: 15
TinyWebGallery wrote:
depends - if php is not the owner than not. Then you have to use 777

- Michael

Ok Michael thanks for that i'll change it and test it again ..

right changed the main folder ( /public_html/administrator/components/com_jfuploader/tfu) to 777 and i now get the following error :-
'you are trying to use TWG upload flash without authentication, the server login failed, expired or could not be found !' do i need to set the tfu folder files also to 777?


Top
 Profile  
 
PostPosted: 29. Sep 2010, 14:18 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10502
No,

your server does not allow 777 for directories. Change it back and create an empty file tfu.log in the tfu directory and set the permissions of this file to 777.

- Michael


Top
 Profile  
 
PostPosted: 29. Sep 2010, 15:08 
Offline

Joined: 28. Sep 2010, 17:12
Posts: 15
TinyWebGallery wrote:
No,

your server does not allow 777 for directories. Change it back and create an empty file tfu.log in the tfu directory and set the permissions of this file to 777.

- Michael


Hi Michael done that but its still showing nothing I'm afraid. No error mesages at all. The log file shows as blank in the info/limits section ...


Top
 Profile  
 
PostPosted: 29. Sep 2010, 15:11 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10502
Even if you enable the enhanced debug? Because otherwise nothing is written to the log.

- Michael


Top
 Profile  
 
PostPosted: 29. Sep 2010, 15:43 
Offline

Joined: 28. Sep 2010, 17:12
Posts: 15
TinyWebGallery wrote:
Even if you enable the enhanced debug? Because otherwise nothing is written to the log.

- Michael

yes I did that when we first started and you told me to enable the basic debug, but I thought id upload a small file in case that gives you any clue as to whats happening .. the small ones work obviously and heres the debug log :-

09.29.2010 14:40:34 - 1. Config loaded
Request: /administrator/components/com_jfuploader/tfu/tfu_upload.php?dir=&TFUSESSID=86150c7a8b08d6f2320705c9debd2568&size=100000&firstStart=true&zeit=1285767623437&tfu_rn=1281950146757610884865767744860&tfu_is_flash_10=1&remaining=1
Stack: tfu_upload.php:42:tfu_debug:1. Config loaded
09.29.2010 14:40:34 - 2. Authenification sucessfull
Request: /administrator/components/com_jfuploader/tfu/tfu_upload.php?dir=&TFUSESSID=86150c7a8b08d6f2320705c9debd2568&size=100000&firstStart=true&zeit=1285767623437&tfu_rn=1281950146757610884865767744860&tfu_is_flash_10=1&remaining=1
Stack: tfu_upload.php:58:tfu_debug:2. Authenification sucessfull
09.29.2010 14:40:34 - 3. Directory read: ./__/__/__/__/images/stories/uploads/sam
Request: /administrator/components/com_jfuploader/tfu/tfu_upload.php?dir=&TFUSESSID=86150c7a8b08d6f2320705c9debd2568&size=100000&firstStart=true&zeit=1285767623437&tfu_rn=1281950146757610884865767744860&tfu_is_flash_10=1&remaining=1
Stack: tfu_upload.php:60:tfu_debug:3. Directory read: ./../../../../images/stories/uploads/sam
09.29.2010 14:40:34 - 4. Check valid extension: Photo-0004.jpg
Request: /administrator/components/com_jfuploader/tfu/tfu_upload.php?dir=&TFUSESSID=86150c7a8b08d6f2320705c9debd2568&size=100000&firstStart=true&zeit=1285767623437&tfu_rn=1281950146757610884865767744860&tfu_is_flash_10=1&remaining=1
Stack: tfu_upload.php:76:tfu_debug:4. Check valid extension: Photo-0004.jpg
09.29.2010 14:40:34 - 4a. Extension valid.
Request: /administrator/components/com_jfuploader/tfu/tfu_upload.php?dir=&TFUSESSID=86150c7a8b08d6f2320705c9debd2568&size=100000&firstStart=true&zeit=1285767623437&tfu_rn=1281950146757610884865767744860&tfu_is_flash_10=1&remaining=1
Stack: tfu_upload.php:78:tfu_debug:4a. Extension valid.
09.29.2010 14:40:34 - 5. Before move_uploaded_file : /tmp/phpKeOJSR -_ ./__/__/__/__/images/stories/uploads/sam/Photo-0004.jpg
Request: /administrator/components/com_jfuploader/tfu/tfu_upload.php?dir=&TFUSESSID=86150c7a8b08d6f2320705c9debd2568&size=100000&firstStart=true&zeit=1285767623437&tfu_rn=1281950146757610884865767744860&tfu_is_flash_10=1&remaining=1
Stack: tfu_upload.php:101:tfu_debug:5. Before move_uploaded_file : /tmp/phpKeOJSR -> ./../../../../images/stories/uploads/sam/Photo-0004
09.29.2010 14:40:34 - 5a. after move_uploaded_file.
Request: /administrator/components/com_jfuploader/tfu/tfu_upload.php?dir=&TFUSESSID=86150c7a8b08d6f2320705c9debd2568&size=100000&firstStart=true&zeit=1285767623437&tfu_rn=1281950146757610884865767744860&tfu_is_flash_10=1&remaining=1
Stack: tfu_upload.php:113:tfu_debug:5a. after move_uploaded_file.
09.29.2010 14:40:34 - 6. Uploaded.
Request: /administrator/components/com_jfuploader/tfu/tfu_upload.php?dir=&TFUSESSID=86150c7a8b08d6f2320705c9debd2568&size=100000&firstStart=true&zeit=1285767623437&tfu_rn=1281950146757610884865767744860&tfu_is_flash_10=1&remaining=1
Stack: tfu_upload.php:125:tfu_debug:6. Uploaded.
09.29.2010 14:40:34 - 7. Internal processing done.
Request: /administrator/components/com_jfuploader/tfu/tfu_upload.php?dir=&TFUSESSID=86150c7a8b08d6f2320705c9debd2568&size=100000&firstStart=true&zeit=1285767623437&tfu_rn=1281950146757610884865767744860&tfu_is_flash_10=1&remaining=1
Stack: tfu_upload.php:139:tfu_debug:7. Internal processing done.
09.29.2010 14:40:34 - 9. End upload
Request: /administrator/components/com_jfuploader/tfu/tfu_upload.php?dir=&TFUSESSID=86150c7a8b08d6f2320705c9debd2568&size=100000&firstStart=true&zeit=1285767623437&tfu_rn=1281950146757610884865767744860&tfu_is_flash_10=1&remaining=1
Stack: tfu_upload.php:227:tfu_debug:9. End upload
09.29.2010 14:40:34 - 10. End store session
Request: /administrator/components/com_jfuploader/tfu/tfu_upload.php?dir=&TFUSESSID=86150c7a8b08d6f2320705c9debd2568&size=100000&firstStart=true&zeit=1285767623437&tfu_rn=1281950146757610884865767744860&tfu_is_flash_10=1&remaining=1
Stack: tfu_upload.php:229:tfu_debug:10. End store session

hope this helps .. glenn


Top
 Profile  
 
PostPosted: 29. Sep 2010, 15:48 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10502
o.k. and what is the output when you upload a bigger file?

- Michael


Top
 Profile  
 
PostPosted: 29. Sep 2010, 16:15 
Offline

Joined: 28. Sep 2010, 17:12
Posts: 15
TinyWebGallery wrote:
o.k. and what is the output when you upload a bigger file?

- Michael


none, when i browse for a file and select it nothing happens at all, I've tried with various files on my drive and the result is the same. I goto the file, select it and click ok but nothing shows at all in the upload window, and theres no message, error or otherwise. If i select 2 small fles and a large one all i get is the smaller files in the upload window. Its as tho it isnt recognising any file above 1 mb .. even tho i can see and select it.


Top
 Profile  
 
PostPosted: 29. Sep 2010, 20:53 
Offline

Joined: 28. Sep 2010, 17:12
Posts: 15
Hi Michael, I've sorted it mate! I was looking through the settings in the Flash Uploader Setting and I noticed that the Max file size in KB was set to 1000 !
So I altered this to 3000 and I'm now able to upload the larger file size.
many thanks for all your help today, its much appreciated.
Can I ask a couple of other questions?? I find that if I use 3 columns in my site it 'covers' the right hand side of the flash uploader so obsquring the upload button, can I alter the size of the uploader? or is there a way to get around this ?
I also wanted to make some of the files uploaded by users private can i do this by using groups and if so how ?
Once again many thanks for all your assistance today
glenn


Top
 Profile  
 
PostPosted: 30. Sep 2010, 12:29 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10502
you can set the width of the flash in the profile.
And for groups simply read the help how to use groups.

- Michael


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 21 posts ]  Go to page 1, 2  Next

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO