Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 24. Oct 2017, 02:13

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 23 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: creating a php.ini file
PostPosted: 18. Aug 2010, 20:57 
Offline

Joined: 18. Aug 2010, 20:34
Posts: 36
Location: California
I have the JFU Professional Edition and trying to up the max file size. I'm presently trying to go the route as explained in the 'how to' number 14 (Where to find php.ini and how to use it), but I'm not exactly sure if or how to make the php.ini file. What I've done is just copied the 'simple example for a custom php.ini' in to DreamWeaver saved as php and with the extension .ini
Do I have to set the 'simple example for a custom php.ini' in a particular way?

I've placed the php.ini files I've created the way explained above in both the: <joomla root>/administrator and administrator/components/com_jfuploader/tfu/

No success. :(


Top
 Profile  
 
 Post subject:
PostPosted: 18. Aug 2010, 21:00 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10502
The file should be a simple text file with the name php.ini.

If this does not work please ask you hoster how to increase server limits.
This can be different on different systems.
Using php.ini or .htaccess are only the most commons ones.

Some hosters (espacially free hosters) do not allow to change this settings at all.

If you already use JFU 2.11 please download it again - I fixed a small bug there.

- Michael


Last edited by TinyWebGallery on 18. Aug 2010, 21:30, edited 1 time in total.

Top
 Profile  
 
 Post subject:
PostPosted: 18. Aug 2010, 21:26 
Offline

Joined: 18. Aug 2010, 20:34
Posts: 36
Location: California
Cool, it sounds like I did it correct then. And the two folders I mentioned I put them in are correct? How would I add that 'simple example for a custom php.ini' to the .htaccess (where would I put the info. in the file, anywhere)?

Yep, already installed 2.11. :)

P.s. thanks for the super quick reply.


Top
 Profile  
 
 Post subject:
PostPosted: 18. Aug 2010, 21:30 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10502
They are fine.

First you should talk to you hoster what is the right way.

- Michael


Top
 Profile  
 
 Post subject:
PostPosted: 19. Aug 2010, 17:02 
Offline

Joined: 18. Aug 2010, 20:34
Posts: 36
Location: California
I got it straighten out. With my host provider I could create a custom php.ini in the root (which I tried early). But I noticed with there info on this subject that they said for php5 the file had to be php5.ini which worked like a charm.

So anyone running php5 on their server having problems with, change the file in the root to php5.ini and see if that helps. :)


Top
 Profile  
 
 Post subject:
PostPosted: 19. Aug 2010, 17:15 
Offline

Joined: 18. Aug 2010, 20:34
Posts: 36
Location: California
TinyWebGallery wrote:
If you already use JFU 2.11 please download it again - I fixed a small bug there.

- Michael
Strange, but now with JFU 2.11, all I'm getting in the artcle that should be showing the flash upload is the code: i.e {joomla_flash_uploader type=0 id=2}

I have the individual plugin enabled.


Top
 Profile  
 
 Post subject:
PostPosted: 19. Aug 2010, 17:17 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10502
Please check the documentation.

It shoulde be

{jfuploader type=0 id=2}

since 2.11 because I had to rename JFU.

PS: Have you seen the new plugin page?

- Michael


Last edited by TinyWebGallery on 19. Aug 2010, 17:20, edited 2 times in total.

Top
 Profile  
 
 Post subject:
PostPosted: 19. Aug 2010, 17:19 
Offline

Joined: 18. Aug 2010, 20:34
Posts: 36
Location: California
TinyWebGallery wrote:
Please check the documentation.

It shoulde be

{jfuploader type=0 id=2}

since 2.11 because I had to rename JFU.

- Michael
Gotcha, thanks. I figured that changed so I tried {jfu type...} I'll check next time. :oops:


Top
 Profile  
 
 Post subject:
PostPosted: 25. Aug 2010, 02:10 
Offline

Joined: 18. Aug 2010, 20:34
Posts: 36
Location: California
I've got everything up and running with the php.ini settings and such, but I'm getting a 'Retry failed. Please check your timeouts.' But in my log it's nothing special. From my log:

08.24.2010 16:33:05 - 1. Config loaded
08.24.2010 16:33:05 - 2. Authenification sucessfull
08.24.2010 16:33:05 - 3. Directory read: ./__/__/__/__blah blah blah
08.24.2010 16:33:05 - 4. Check valid extension: July24_2010.mov
08.24.2010 16:33:05 - 4a. Extension valid.
08.24.2010 16:33:05 - 5. Before move_uploaded_file : -_ ./__/__/__/__july24_2010.mov
08.24.2010 16:33:05 - 5a. after move_uploaded_file.
08.24.2010 16:33:05 - 5b. retry move_uploaded_file : ./__/__/__/__/july24_2010.mov
08.24.2010 16:33:05 - 6. NOT uploaded.
08.24.2010 16:33:05 - 9. End upload
08.24.2010 16:33:05 - 10. End store session


Top
 Profile  
 
 Post subject:
PostPosted: 25. Aug 2010, 08:10 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10502
you get this for every file?

How is you error level set? Because normally move_uploaded_file does give a message what is the problem. Maybe this is written to the server log. You have to check there then.

- Michael


Top
 Profile  
 
 Post subject:
PostPosted: 25. Aug 2010, 16:37 
Offline

Joined: 18. Aug 2010, 20:34
Posts: 36
Location: California
Not for every file, I just tried a 46mb file and it got all the way to the end but errored out:
Error : http - 500

Error level set? Where is that? Is that like the 'Enable upload debug'?


Last edited by larry_g1s on 25. Aug 2010, 16:39, edited 1 time in total.

Top
 Profile  
 
 Post subject:
PostPosted: 25. Aug 2010, 16:38 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10502
this is a server error - check the server error log file. It should givve you more details.

- Michael


Top
 Profile  
 
 Post subject:
PostPosted: 25. Aug 2010, 16:48 
Offline

Joined: 18. Aug 2010, 20:34
Posts: 36
Location: California
I'll check that, but like I mentioned I don't get that for the large upload file issue. I'll check the server log. What about the Error level set? Where is that?


Top
 Profile  
 
 Post subject:
PostPosted: 25. Aug 2010, 16:53 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10502
I think there a different timeout maybe kills you ;).

Which server do you use
http://www.tinywebgallery.com/en/tfu/web_faq.php#4
has a few server dependant settings as well!.

- Michael


Top
 Profile  
 
 Post subject:
PostPosted: 4. Sep 2010, 22:22 
Offline

Joined: 18. Aug 2010, 20:34
Posts: 36
Location: California
Ok, major bummer. I'm still getting the time out error and because this site is hosted on a shared plan the hoster cannot change the time out restriction on the server. If we go to a more dedicated one they can. But I want to try this site with a different host provider I have to see if it'll work there. If so I'll just swap the site there. How can I temporarily change the jfu lic to a domain I already have, just to test it with this host provider?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 23 posts ]  Go to page 1, 2  Next

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO