Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 24. Oct 2017, 02:22

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 12 posts ] 
Author Message
PostPosted: 12. Feb 2011, 00:14 
Offline

Joined: 20. Jan 2011, 22:49
Posts: 11
I've been trying to set up a website for the Geneva Camera Club at http://genevacameraclub.org.

I have NO experience with Joomla or any other CMS before now, been writing websites in HTML or using WYSIWYG website services until now.

So the main reason I'm trying Joomla is to get it set up so that club members can set up their own individual webpages there, then upload upload their image files to their
own page. I can upload files to a single folder, but ever time I try to create a new directory with the Options button in JFU it says it can't create that directory.

I checked with the server (Siteground) and they have a policy of NOT having Safemode loaded for any site, so that's not the problem.

So what should I try?

Ted Quick


Top
 Profile  
 
PostPosted: 12. Feb 2011, 01:53 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10502
first look in to log file of JFU. if you get the option that foldrs can be created it tries to do this - if this fails you should get a message which tells you why.

- Michael


Top
 Profile  
 
PostPosted: 12. Feb 2011, 05:27 
Offline

Joined: 20. Jan 2011, 22:49
Posts: 11
Here's the end of the tfu.log file:

Request: /components/com_jfuploader/tfu/tfu_file.php?action=dir&createdir=true&newdir=marline&dir=&ts=1297478919331&tfu_rn=1292108486882912505657471940388&tfu_is_flash_10=1&TFUSESSID=jmmdd82uh58hklpgnohgodktt7
Stack: tfu_helper.php:131:tfu_debug:ERROR 2 in onents/com_jfuploader/tfu/tfu_helper.php, line 2109: ftp_close() expects parameter 1 to b
Stack: ::on_error:2:ftp_close() expects parameter 1 to be resource, boolean given:/home/genevaca/public_html/components/com_jfuploader/tfu/tfu_helper.php:2109:Array( [dir] => ./../../../images/stories/ted quick [enable_folder_creation] => true [fix_u
Stack: tfu_helper.php:2109:ftp_close:
Stack: tfu_file.php:136:create_dir:./../../../images/stories/ted quick:true:
02.11.2011 21:11:43 - Action:dir; Directory: ./__/__/__
Request: /components/com_jfuploader/tfu/tfu_file.php?action=dir&dir=&ts=1297491103878&tfu_rn=1298671896110376708307495708082&tfu_is_flash_10=1&tfu_ut=-1&TFUSESSID=ps6acgrpffab6bdc5d1iss5ka6
Stack: tfu_file.php:52:tfu_debug:Action:dir; Directory: ./../../..
02.11.2011 21:12:05 - Action:dir; Directory: ./__/__/__
Request: /components/com_jfuploader/tfu/tfu_file.php?action=dir&dir=&ts=1297491125315&tfu_rn=1295748410112466153347491759514&tfu_is_flash_10=1&tfu_ut=-1&TFUSESSID=ps6acgrpffab6bdc5d1iss5ka6
Stack: tfu_file.php:52:tfu_debug:Action:dir; Directory: ./../../..
-----------------------------------------------------------
So do I have something set wrong?

Ted Quick


Top
 Profile  
 
PostPosted: 12. Feb 2011, 13:12 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10502
which version do you use exaclty? Because I have to match the line numbers...

- Michael


Top
 Profile  
 
PostPosted: 12. Feb 2011, 15:28 
Offline

Joined: 20. Jan 2011, 22:49
Posts: 11
JFU version from: jfu_212_J15.zip
Joomla: 1.5. from: Joomla_1.5.22-Stable-Full_Package.zip

Ted Quick


Top
 Profile  
 
PostPosted: 12. Feb 2011, 19:23 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10502
why have you enabled the ftp mode for creating directories?

- Michael


Top
 Profile  
 
PostPosted: 14. Feb 2011, 00:57 
Offline

Joined: 20. Jan 2011, 22:49
Posts: 11
Trying too much at once. Largely did so because I didn't know it causes a conflict with your program.
So I turned off the ftp mode, and can still only upload single files to the same folder. It doesn't even list subfolders that were set up by using cPanel, and won't create any folders either.


Top
 Profile  
 
PostPosted: 14. Feb 2011, 09:14 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10502
I'm talking about the ftp-mode for creating directories in JFU. Not the one from Joomla. Because you get an error in ftp_close which mean you have configured JFU to use FTP for creating directories.

simply enable the upload debug in the config of JFU. Then you see each step of the upload and also if there is a problem if you can only upload one file at a time. But this is a new problem or ?

- Michael


Top
 Profile  
 
PostPosted: 14. Feb 2011, 21:19 
Offline

Joined: 20. Jan 2011, 22:49
Posts: 11
I looked in ftp_close, but the last error there was on February 1, 2011 and looked like it was from a different cause which hasn't repeated since then, or maybe I turned it off then.

Just enabled the upload debug in the config of JFU. Now that I also changed the ftp-mode it refuses to do anything and gives me this:

Error
You are trying to use the TWG Upload Flash without
authentication, the server login failed, expired or the
configuration could not be found!

So I need to change a configuration fire to correct this, what configuration file and how?


Top
 Profile  
 
PostPosted: 15. Feb 2011, 00:14 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10502
Seems you have changed the config file and you have an error in your php code.
call tfu_login.php or tfu_config.php directly. Then the error message should be displayed if your php is not valid.

I don't think you need the ftp mode to create directories if safe mode is turned off.

- Michael


Top
 Profile  
 
PostPosted: 15. Feb 2011, 06:33 
Offline

Joined: 20. Jan 2011, 22:49
Posts: 11
I decided to upload copies of all the files in that folder from a backup, from when it at least worked somewhat better. Now it does Create new folds and upload files from both Frontend and Backend. I have yet to see about it making separate folders for each User. Hopefully that will work, I'll let you know if there's any problem here.

Thanks,
Ted Quick


Top
 Profile  
 
PostPosted: 15. Feb 2011, 09:15 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10502
check the master profile mode. There is also help about his on the help page available.

- Michael


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 12 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO