Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 23. Oct 2017, 13:46

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 9 posts ] 
Author Message
PostPosted: 12. Nov 2007, 14:05 
Offline

Joined: 12. Nov 2007, 14:02
Posts: 17
Is this a pure connection issue? Is there something I can tell my users to do to reduce this? Some users cannot upload at all without getting this error (usually file over 10 megs). I am using the licensed version of 2.51... will 2.6 be better? Thank you.


Top
 Profile  
 
 Post subject:
PostPosted: 12. Nov 2007, 14:35 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10499
this error normally happens when tfu_upload.php cannot be found or when you set the maximum upload size bigger than the values set in php.ini

Do big downloads work from your pc?

and if they upload smaller files it works?

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 12. Nov 2007, 14:47 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10499
And another issue with big uploads - make sure the

max_execution_time
max_input_time
default_socket_timeout

are high enough!

and of course

upload_max_filesize
post_max_size

are high enough too;).



/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 12. Nov 2007, 19:16 
Offline

Joined: 12. Nov 2007, 14:02
Posts: 17
I increased all those values, and it does not appear to have made a difference. Thsi from a user in Austraila (server is in Boston):

Quote:
Still the same. I even had my administrator in Holland to try it from there since I know, the NZ hub is slow. He has the same problem. It seems the file just stops half way. Some times I am lucky and it goes through. The longer the file , the bigger chance of it locking up. My file is 40,000K


Here are my php.ini settings:

max_execution_time = 60
max_input_time = 120
default_socket_timeout = 60
upload_max_filesize = 252M
post_max_size = 500M

Any other suggestions?


Top
 Profile  
 
 Post subject:
PostPosted: 12. Nov 2007, 20:37 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10499
why other ;).

The times are still only one minute.
I have set the times to 10 min on my test server.

On my local machine this times are ignored - therefore I can not do this tests right now.
I currently improving some ot the upload progress displays. But this should not affect your problem.

are you using TFU only or TWG as well? Then you could try the html upload form an check if this upload fails too.

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 12. Nov 2007, 21:35 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10499
something else - I tested and I think I have a synconisation problems sometimes when big files are uploaded (they are uploaded but TFU tells it it not!).

Can you ask if maybe the uploaded file is there but the flash says upload failed?

I try to reproduce this on my local machine (had this on one of my test servers).

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 12. Nov 2007, 21:51 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10499
I got the problem because I decreased my

max_execution_time
max_input_time

to 6 sec. Then it fails.

I increased the time bach to my 1200 and then it worked fine.

Look if you find something like:

Maximum execution time of x seconds exceeded in \tfu\tfu_upload.php on line xx

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 13. Nov 2007, 01:38 
Offline

Joined: 12. Nov 2007, 14:02
Posts: 17
OK, I increased

max_execution_time = 1200
max_input_time = 1200

Will ask users with trouble to test again. Thank you.


Top
 Profile  
 
 Post subject:
PostPosted: 13. Nov 2007, 09:44 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10499
good.

I will post the new version of TFU today in the forum.
This is the first beta of TFU 2.7 where I have improved the message handling for big files as well.

You can give this a try.

/Michael


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO