Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 18. Oct 2017, 03:58

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 20 posts ]  Go to page 1, 2  Next
Author Message
PostPosted: 12. May 2008, 16:50 
Offline

Joined: 20. Nov 2006, 17:40
Posts: 45
Hi Michael,

I created a new user who is allowed for frontend upload. After login (frontend) the twgflash uploader appears, I can see the files in the folder but if I want to add a picture, the status turns to "not allowed File-Extension: jpg

My log shows the following:

Code:
/filefunctions.inc.php, line 1550: opendir(album/buttons/smilies) [<a href='function.opendir'>function.opendir</a>]: failed to open dir: No such file or directory
/filefunctions.inc.php, line 1552: readdir(): supplied argument is not a valid Directory resource
/filefunctions.inc.php, line 1560: closedir(): supplied argument is not a valid Directory resource
/readxml.inc.php, line 209: Undefined index:  NAME


See ya
Martin


Top
 Profile  
 
 Post subject:
PostPosted: 12. May 2008, 17:55 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10494
this is right - I removed the default extensions for TFU in one of the last versions ;).

Add added this to
$admin_user_allowed_file_extensions

but I missed one build and I think you have this one.

add the extensions to

$admin_user_allowed_file_extensions

and then it works again.

The log entry is not related to this. Seems the smilies directory is not uploaded.

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 13. May 2008, 15:38 
Offline

Joined: 20. Nov 2006, 17:40
Posts: 45
I had 1.7.2. so I updated to 1.7.3. Seems, that everything is working now.

BTW: 1.7.3 zip-version: there is a twg.lic.php file inside the zip-file. I nearly overwrote my own license-file. Perhaps you should mention in faq to save a personal twg.lic.php file.

see ya
Martin


Top
 Profile  
 
 Post subject:
PostPosted: 13. May 2008, 15:57 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10494
the twg.licx.php should not be there. It had an extra x therefore nothing would have happened.

I have removed it - thanks for the hint.

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 26. May 2008, 10:10 
Offline

Joined: 20. Nov 2006, 17:40
Posts: 45
Hi Michael,
as I wrote, I updated to your latest version and thought, the errors were gone... my fault :(

Code:
/album/inc/filefunctions.inc.php, line 1544: opendir(album/buttons/smilies) [<a href='function.opendir'>function.opendir</a>]: failed to open dir: No such file or directory
/album/inc/filefunctions.inc.php, line 1546: readdir(): supplied argument is not a valid Directory resource
/album/inc/filefunctions.inc.php, line 1554: closedir(): supplied argument is not a valid Directory resource
/album/inc/readxml.inc.php, line 213: Undefined index:  NAME


The smilies-directory is at the right place. E.g.
#removed_broken_linkhtml/album/but ... ies/a(.gif

See ya
Martin


Top
 Profile  
 
 Post subject:
PostPosted: 26. May 2008, 10:25 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10494
are you using php include?

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 26. May 2008, 11:51 
Offline

Joined: 20. Nov 2006, 17:40
Posts: 45
yes. Part of my config.php

$iframe_include=false;
$iframe_height_ie='100%';
$php_include=true;
$install_dir = 'album/';
/* additional parameters for php_include can be found in config_internal.php - section php_include */
$basedir = 'pictures';
$cachedir = 'cache';
$counterdir = 'counter';
$xmldir = 'xml';


Top
 Profile  
 
 Post subject:
PostPosted: 26. May 2008, 12:11 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10494
o.k. i'll check - are smilies shown in the comments iframe?

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 26. May 2008, 12:49 
Offline

Joined: 20. Nov 2006, 17:40
Posts: 45
Wow Michael - that's fast.

Yes, smilies are shown.


Top
 Profile  
 
 Post subject:
PostPosted: 26. May 2008, 12:50 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10494
and if you use them are they shown too?

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 26. May 2008, 15:43 
Offline

Joined: 20. Nov 2006, 17:40
Posts: 45
Sorry, I had an appointment.

We are talking about the smilies in the comments-section?

Smilies are shown, if I enter a comment
If I click on a smilie the tag is inserted in comments-field
Smilies are shown in comments, if I view a picture

#removed_broken_link ... 0=comments

Seems, that everything works as it should - but I get the error-messages

Tia
Martin


Top
 Profile  
 
 Post subject:
PostPosted: 26. May 2008, 15:49 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10494
i play around a little bit - i have it on my todo list ;).

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 28. May 2008, 10:22 
Offline

Joined: 20. Nov 2006, 17:40
Posts: 45
I investigated a little deeper: my access.log says

GET /html/buttons/smilies/8).gif HTTP/1.1 > 404

it should be

GET /html/album/buttons/smilies/8).gif HTTP/1.1

album is the folder with the twg-script - remember: everything works fine except for the smilies


Top
 Profile  
 
 Post subject:
PostPosted: 28. May 2008, 18:56 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10494
i check - i only have to find the place where the folder is missing :)

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 2. Jun 2008, 08:04 
Offline

Joined: 20. Nov 2006, 17:40
Posts: 45
Hi Michael,

thanks for sending the new ajaxserver.inc.php. I uploaded, deleted the session cache (and the browser cache) but the error remains

/album/inc/filefunctions.inc.php, line 1544: opendir(album/buttons/smilies) [<a href='function.opendir'>function.opendir</a>]: failed to open dir: No such file or directory
/album/inc/filefunctions.inc.php, line 1546: readdir(): supplied argument is not a valid Directory resource
/album/inc/filefunctions.inc.php, line 1554: closedir(): supplied argument is not a valid Directory resource

This has a very low priority - the gallery is working.

Tia
Martin


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 20 posts ]  Go to page 1, 2  Next

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO