Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 23. Oct 2017, 15:20

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 12 posts ] 
Author Message
PostPosted: 11. Jun 2008, 06:55 
Offline

Joined: 11. Jun 2008, 06:52
Posts: 13
This has been bugging me for a while. This error shows up in the tfu.log file after I try uploading something. The worst part is, that it comes and goes.... quite randomly.

06.11.2008 0:02:03 - ERROR 8 in /home/users/abc/public/tfu_helper.php, line 493: date_default_timezone_set() [<a href='function.date-default-timezone-set'>function.date-default-timezone-set</a>]: Timezone ID '' is invalid

06.11.2008 0:02:03 - ERROR 2048 in /home/users/abc/public/tfu_helper.php, line 495: phpinfo() [<a href='function.phpinfo'>function.phpinfo</a>]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/Chicago' for 'CDT/-5.0/DST' instead


Top
 Profile  
 
 Post subject:
PostPosted: 11. Jun 2008, 08:21 
Online
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10500
Hi,

Which version are you using? Because I do set the timezone but the line numbers are like 300 lines different.
I think I have changed this like a year ago ...

And this is nomally not a problem at all because only the timezone cannot be set then.

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 11. Jun 2008, 17:20 
Offline

Joined: 11. Jun 2008, 06:52
Posts: 13
Im using 2.4

I forgot to mention that the upload fails when the error comes up. It shows the ok message, but the files are not there, nor does the mysql query execute in tfu_upload.php


Top
 Profile  
 
 Post subject:
PostPosted: 11. Jun 2008, 17:28 
Online
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10500
in 2.4 (now ~ 1 1/2 years old) the timezone was not set yet. This was needed by one of the 5.x versions of php.

You should update to the latest version of TFU.
Especially because 2.7.1 was a security update!

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 11. Jun 2008, 18:53 
Offline

Joined: 11. Jun 2008, 06:52
Posts: 13
I have the script extensively modified, and it would be a huge bitch to redo it all.

Is there any work around I can do to prevent this from happening? I dont use this script in public, its only used for an admin function, so security isnt really a huge issue, since its all protected already.


Top
 Profile  
 
 Post subject:
PostPosted: 11. Jun 2008, 20:09 
Online
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10500
then simply set the timezone like I do in the latest version.
Download it and look how this can be done. tfu_helper.php

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 12. Jun 2008, 07:11 
Offline

Joined: 11. Jun 2008, 06:52
Posts: 13
Well, that stopped the error from showing up, but the files are still not being uploaded.

This is insane, because I have 2 other instances running on the same server, and they work perfectly.


Top
 Profile  
 
 Post subject:
PostPosted: 12. Jun 2008, 08:43 
Online
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10500
weired - there is no tfu.log or any other message in the server log that shows any problems?


/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 12. Jun 2008, 19:26 
Offline

Joined: 11. Jun 2008, 06:52
Posts: 13
Nope, none at all. Upload bar goes to 100%, says complete, but nothing is uploaded, and the mysql query at the end of the upload is not ran either. Its as if it doesnt even get to tfu_upload.php file to do any work.


Top
 Profile  
 
 Post subject:
PostPosted: 13. Jun 2008, 08:29 
Online
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10500
after the include of the tfu_helper.php you can debug to the tfu.log by simply adding e.g.
debug('enter tfu_upload.php');

there you can check if the file is called properly. If you call the tfu_upload.php directly: is there maybe an error shown?

/Michael


Top
 Profile  
 
 Post subject:
PostPosted: 13. Jun 2008, 16:05 
Offline

Joined: 11. Jun 2008, 06:52
Posts: 13
Ahh why didnt I think of that!


It says "not logged in", so that means $_SESSION["TFU_LOGIN"] doesnt get set.

I can remove that check, but what sets $_SESSION["TFU_LOGIN"]?


Top
 Profile  
 
 Post subject:
PostPosted: 13. Jun 2008, 16:10 
Online
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10500
it is set in the tfu_config.php.

Quite some servers have a problem transfering the session properly through the flash. I have a lot of workarounds in the newer versions to make this work without problems. Depending on the server different solutions are needed which I try one after another ;).

Your problem is that the upload directory is in the session too! in 2.4 it could be possssile that it is in the request as well. should be sent a parameter 'dir'.

Have you really made that many modifications? tfu_upload.php is not really big ;).

/Michael


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 12 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO