Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 14. Dec 2017, 15:11

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 22 posts ]  Go to page Previous  1, 2
Author Message
 Post subject:
PostPosted: 21. Sep 2009, 22:59 
Offline

Joined: 9. Feb 2009, 18:16
Posts: 80
Location: Rochester, MN USA
OK, I'm an idiot. Which patch in which forum.

Sorry,

T.


Top
 Profile  
 
 Post subject:
PostPosted: 22. Sep 2009, 20:19 
Offline

Joined: 9. Feb 2009, 18:16
Posts: 80
Location: Rochester, MN USA
I uploaded the patched files this morning (and I think I did it correctly). I tried an upload and got the same errors.

The flash said: "Upload failed. 1 file(s) of 1 could not be uploaded."

admin/upload/error_log said "PHP Fatal error: Cannot redeclare class phpExifReader in /home2/rochesu2/public_html/gallery/inc/exifReader.inc.php on line 215"

Just for yucks I tried moving inc/exifReader.inc.php so it couldn't be found and tried another upload. I didn't get either error, but I didn't get a cache file either. I have moved it back and the error is back.

Any more guesses? Is there something in the patched files that I could check to verify I have the correct files on the server?

Your login is still enabled if you need to get back in.

Thanks so much for looking into this.

T.


Top
 Profile  
 
 Post subject:
PostPosted: 22. Sep 2009, 21:35 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10572
can you please check if in the admin/upload folder the file
twg_plugin.php

does not call the exif class anymore?

- Michael


Top
 Profile  
 
 Post subject:
PostPosted: 22. Sep 2009, 22:21 
Offline

Joined: 9. Feb 2009, 18:16
Posts: 80
Location: Rochester, MN USA
I compared the current twg_plugin.php to a backup I have and neither file has "exif" anything in it. The only difference I found between the two was:
Code:
// not needed - we use the one from TFU
// include realpath(dirname(__FILE__) . "/../../inc/readxml.inc.php");

in the current one at line 57.


Top
 Profile  
 
 Post subject:
PostPosted: 23. Sep 2009, 00:24 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10572
this was a change that did not change anything :(.

I have wrapped the exif reader class not if it is defined it is not defined again.

I have uploaded the newest change.

Let me know ;).

- Michael


Top
 Profile  
 
 Post subject:
PostPosted: 23. Sep 2009, 12:59 
Offline

Joined: 9. Feb 2009, 18:16
Posts: 80
Location: Rochester, MN USA
"Upload completed."

That is the message I received in the Flash when I tried uploading a couple of files after last night's update.

No errors in admin/upload/error_log and no other error logs that I could find.

And . . . wait for it . . . cache files were created.

I'll keep an eye on it for awhile, but I don't expect any changes.

OK, that's done. Now what are you going to do with yourself 8)

Michael, thanks. Now I can get a bunch of skating mothers off my back.

Excellent gallery. Excellent support. Just plain excellent.

T.


Top
 Profile  
 
 Post subject:
PostPosted: 23. Sep 2009, 13:17 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10572
good - then it's time of release 1.7.8 on the website...

- Michael


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 22 posts ]  Go to page Previous  1, 2

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO