Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 18. Oct 2017, 00:24

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 18 posts ]  Go to page 1, 2  Next
Author Message
PostPosted: 29. Jan 2016, 16:44 
Offline

Joined: 5. Mar 2015, 22:53
Posts: 27
Hi, I am attempting to display an iframed form page from one part of my site in an iframe with a tab on the homepage.

I'm using the Pro Edition.
When I enter the div ID into the hide-elemnt field, it hides the main website's header but not the header of the page in the frame. There is a class ID available on the form page 'not home page' but I can't find the correct fromat to make it work alongside the hide #header-wrapper instruction.


Thanks


Top
 Profile  
 
PostPosted: 29. Jan 2016, 17:20 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10494
hiding stuff in the iframe is a different field you have to use.

But are you really on the same domain? Or do you need to use the external workaround?

Best, Michael


Top
 Profile  
 
PostPosted: 31. Jan 2016, 17:49 
Offline

Joined: 5. Mar 2015, 22:53
Posts: 27
Thanks, I was adding the ID to the Parent page field instead of the iframed page. So much text on the page I got lost!

Now the correct div is showing in the tabbed page element, the form isn't working properly. I can entr text in the firts few fields but the 'Attach file', TinyMCE box and the 'Submit' button don't work. Do I have to alter any URL parameters?


Regards,

Kev


Top
 Profile  
 
PostPosted: 31. Jan 2016, 21:45 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10494
Does the form work in the iframe if you show all elements?
Because you first have to check if the form does work in an iframe at all.

How is your configuration now?
Click on the "generate shortcode" button to see the full configuration.

Best, Michael


Top
 Profile  
 
PostPosted: 31. Jan 2016, 22:02 
Offline

Joined: 5. Mar 2015, 22:53
Posts: 27
Good call on trying it without hidden element, the form works 100%.

#blog-page is the only area of the page which I'd like to display. It's this page, minus the header (logo, dark blue bar and menus) which is in the iFrame - but I realise the scripts are in the header, D'Oh!



Thanks for the tip on generating new shortcode, I didn't know that was required because the basic shortcode seemed to be transferring each new setting I edited.


Top
 Profile  
 
PostPosted: 31. Jan 2016, 22:10 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10494
In the administration are the defaults and the shortcode attributes do overwrite this.

All my demos use use_shortcode_attrobutes_only where no settings from the administration is used.

What is strange is that the scripts in the header don't work as the script does only set the display to none.
show only one part of the iframe does really remove the elements.

Best, Michael


Top
 Profile  
 
PostPosted: 1. Feb 2016, 10:39 
Offline

Joined: 5. Mar 2015, 22:53
Posts: 27
Hi,
does this mean there is no way to have the form working while the heaer is hidden in the frame?

I think the theme has option to put the page's .JS in the footer, I'll try hiding just the #header in the framed page. Does that sound like it would work?


Thanks,


Top
 Profile  
 
PostPosted: 1. Feb 2016, 11:02 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10494
you can try this.


Top
 Profile  
 
PostPosted: 4. Feb 2016, 13:14 
Offline

Joined: 5. Mar 2015, 22:53
Posts: 27
Hi, unfortunately no success with the form working within the iFrame. Can you think of any options, would it work using on of the more advanced features of TWG iFrame such as a layer?


Regards,

Kevin


Top
 Profile  
 
PostPosted: 4. Feb 2016, 14:16 
Offline

Joined: 5. Mar 2015, 22:53
Posts: 27
https://developer.wordpress.org/reference/functions/wp_enqueue_script/

Hi, does this 'enqueue script' sound like a solution?


Top
 Profile  
 
PostPosted: 4. Feb 2016, 15:00 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10494
wp_enqueue_script is a method to include Javascript files to the parent (I use thie for ai.js for example).

Why your form does not work would have to be evaluated...

Best, Michael


Top
 Profile  
 
PostPosted: 4. Feb 2016, 16:05 
Offline

Joined: 5. Mar 2015, 22:53
Posts: 27
To clarify, are you going to evaluate the form please?


Top
 Profile  
 
PostPosted: 4. Feb 2016, 16:45 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10494
I don't even know which url ;).


Top
 Profile  
 
PostPosted: 4. Feb 2016, 17:14 
Offline

Joined: 5. Mar 2015, 22:53
Posts: 27
Hi,

this is the homepage http://tradezen.co.uk/ the light green centre tab has the iFrame in it.

The page/form which should be in that iframe is here http://tradezen.co.uk/submit-project/

Regards,

Kev


Top
 Profile  
 
PostPosted: 4. Feb 2016, 17:16 
Offline

Joined: 5. Mar 2015, 22:53
Posts: 27
w-usr: xxx
PASS: xxx

Never post credentials ;). I have removed them...


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 18 posts ]  Go to page 1, 2  Next

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO