Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 15. Dec 2017, 16:02

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 14 posts ] 
Author Message
PostPosted: 27. Sep 2017, 08:59 
Offline

Joined: 25. Sep 2017, 13:21
Posts: 7
Hey
The script embeded on the external page.
still not working...


Top
 Profile  
 
PostPosted: 27. Sep 2017, 09:26 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10573
Can you provide more information? Do you have a link?
Which configuration do you have? Any errors in the console (F12)?
Free or pro?

Best, Michael


Top
 Profile  
 
PostPosted: 27. Sep 2017, 16:59 
Offline

Joined: 25. Sep 2017, 13:21
Posts: 7
Hi
the url is:
http://adeco2.s47.upress.link/


Top
 Profile  
 
PostPosted: 27. Sep 2017, 17:33 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10573
It seems that the whole content is set by Javascript after the page loads.

Please try the following.

Go to the external workaround tab and:

Enable post message comuncation -> debug.
Set the element to measure -> .wrapper
Resize/ css modification delay -> 200

Go to the advanced tab -> Resize the iframe to the content height/width
Set Resize on element resize: -> .wrapper

The 2nd one is needed as your page in the iframe is a one page application.

Best, Michael


Top
 Profile  
 
PostPosted: 27. Sep 2017, 17:46 
Offline

Joined: 25. Sep 2017, 13:21
Posts: 7
Thanks, but still not working...


Top
 Profile  
 
PostPosted: 27. Sep 2017, 22:06 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10573
Check your Javascript console:

The configuration of "resize_on_element_resize" is invalid. The specified element .wrapper could not be found. Please check your configuration.
ai_external.js:489 The configuration of "element_to_measure" is invalid. The specified element .wrapper could not be found. Please check your configuration. As fallback "default" is used which measures the first child of the body.
ai_external.js:304 Advanced iframe configuration problem: The height of the page cannot be detected with the current settings. Please check the documentation of 'element_to_measure' how to define an alternative element to detect the height.

As your code is generated dynamically you might still have to increase the delay until the element to measure is searched for.

Also you should include ai_external.js before the </body> as written in the instructions because then the code is executed later when is should be. Then your page has maybe rendered already.

Best, Michael


Top
 Profile  
 
PostPosted: 27. Sep 2017, 23:14 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10573
I checked your code.

You have an older version of advanced iframe pro running. Please upgrade to 7.5.1 - there is a fix for the delay which could also work for your site.
I tried with
Resize/ css modification delay -> 2000

which works fine for me then.

Please set this also and save the settings so that ai_external.js is regenerated. Make sure that ai_external.js is reloaded (clear the browser cache or reload the page IN the iframe with F5).

Best, Michael


Top
 Profile  
 
PostPosted: 28. Sep 2017, 19:38 
Offline

Joined: 25. Sep 2017, 13:21
Posts: 7
Hi
Thanks, it works better with the new version, still i have a problem on resize...
If you see, the resize on load is working well but not working on click or size change...


Top
 Profile  
 
PostPosted: 30. Sep 2017, 20:38 
Offline

Joined: 25. Sep 2017, 13:21
Posts: 7
??


Top
 Profile  
 
PostPosted: 1. Oct 2017, 12:00 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10573
You still have the same message.

Is seems for me that you need to set #ember273 as element to measure and also for the resize to element resize.

See

The configuration of "element_to_measure" is invalid. The specified element could not be found. Please check your configuration. As fallback "default" is used which measures the first child of the body.
ai_external.js:315 Advanced iframe configuration problem: The height of the page cannot be detected with the current settings. Please check the documentation of 'element_to_measure' how to define an alternative element to detect the height.

and
onload_resize_delay = 200 seems not enough for me. I checked ai_external.js and also resize to element resize is not set at all! check what I have written before how to set this!

Best, Michael
.


Top
 Profile  
 
PostPosted: 1. Oct 2017, 13:01 
Offline

Joined: 25. Sep 2017, 13:21
Posts: 7
Hi
I just go over all the setting and changed it as you say...
It still have the same error.


Top
 Profile  
 
PostPosted: 1. Oct 2017, 21:16 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10573
Now only one error is left:

The configuration of "resize_on_element_resize" is invalid. The specified element #ember273 could not be found. Please check your configuration.

This is because this part is loaded dynamically. I have to also connect this init to delay. Can I send you a new version of the ai_external.js template? Where should I send it to. You would then need to replace this file in your configuration.

Auto height for the first page works fine now.

Best, Michael


Top
 Profile  
 
PostPosted: 1. Oct 2017, 21:19 
Offline

Joined: 25. Sep 2017, 13:21
Posts: 7
Great...
You can send me to skitsa@gmail.com
Just to replace it?


Top
 Profile  
 
PostPosted: 1. Oct 2017, 21:37 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10573
I just tried to send it. Check if you got it and follow the instructions there.

Best, Michael


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 14 posts ] 

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: Bing [Bot] and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO