Php photo gallery TWG | JFUploader | TWG Flash upload | WFU | Forum

Get help for TinyWebGallery, the best image gallery. The forum is also home for the Joomla JFUploader, TWG Flash Uploader and the Wordpress flash uploader.
It is currently 13. Dec 2017, 11:20

All times are UTC + 1 hour [ DST ]




Post new topic Reply to topic  [ 18 posts ]  Go to page 1, 2  Next
Author Message
PostPosted: 2. Aug 2016, 12:29 
Offline

Joined: 2. Aug 2016, 12:06
Posts: 9
I have tried to create auto re-size iFrame with code given by Advanced iFrame Pro examples

[advanced_iframe securitykey="MYSECURITYKEY" frameborder="0" src="https://example.com" width="100%" height="20" use_shortcode_attributes_only="true" onload_resize="true" ]

But this code is not displaying the full height of page in front end.
The source link is from external site
Please provide the solution to detect the height of the page and auto resize the iFrame to display complete page without scrolling.

I can provide my purchase code if needed.

Thanks


Top
 Profile  
 
PostPosted: 2. Aug 2016, 15:08 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10571
You use the solution for the same domain.

you need to use the solution for the external doamin:
http://www.tinywebgallery.com/blog/advanced-iframe/advanced-iframe-pro-demo/external-workaround-auto-height-and-css-modifications

Check the tab "external workaund" tab in the administraiton.

Best, Michael


Top
 Profile  
 
PostPosted: 6. Aug 2016, 04:40 
Offline

Joined: 2. Aug 2016, 12:06
Posts: 9
TinyWebGallery wrote:
You use the solution for the same domain.

you need to use the solution for the external doamin:
http://www.tinywebgallery.com/blog/advanced-iframe/advanced-iframe-pro-demo/external-workaround-auto-height-and-css-modifications

Check the tab "external workaund" tab in the administraiton.

Best, Michael


As you can see, I have done this, but it does not work. The height does not adjust, the frame is simply cut off. Here's an example page that I've done http://www.webengin.com.au/test-page-2/


Top
 Profile  
 
PostPosted: 6. Aug 2016, 22:07 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10571
No. You have used MY example with MY domains.

You need to use YOUR pages and YOUR domains.

Please go to the "external Workaround" tab an follow the instructions there.
You need to use the Javascript provided there.

Best, Michael


Top
 Profile  
 
PostPosted: 9. Aug 2016, 11:57 
Offline

Joined: 2. Aug 2016, 12:06
Posts: 9
TinyWebGallery wrote:
No. You have used MY example with MY domains.

You need to use YOUR pages and YOUR domains.

Please go to the "external Workaround" tab an follow the instructions there.
You need to use the Javascript provided there.

Best, Michael


Tried the Code as mentioned in External Workaround page
http://www.tinywebgallery.com/blog/advanced-iframe/advanced-iframe-pro-demo/external-workaround-auto-height-and-css-modifications

<script>
var iframe_id = "iframe";
var updateIframeHeight = "true";
var iframe_content_id = "#iframe";
var hide_page_until_loaded_external = "true";
</script>

Above is the script inserted in external source page “https://webengin.partnerconsole.net/execute/logonDispatch “

[advanced_iframe securitykey="My-key" use_shortcode_attributes_only="true" src="https://webengin.partnerconsole.net/execute/logonDispatch" width="800" id="iframe" height="300" height scrolling="no" enable_external_height_workaround="true"]

iFrame Code Applied in the page
Please see the page where iFrame is applied
http://www.webengin.com.au/test-page-2/

Followed all the instructions Mentioned in “External Workaround” page


Top
 Profile  
 
PostPosted: 23. Aug 2016, 10:49 
Offline

Joined: 2. Aug 2016, 12:06
Posts: 9
Bump


Top
 Profile  
 
PostPosted: 24. Aug 2016, 02:08 
Offline

Joined: 2. Aug 2016, 12:06
Posts: 9
Unfortunately this plugin is not working.
Your support has unfortunately not helped to get it working as advertised.
I have not heard from you in 3 weeks.
It is time I request a refund.
All the best.


Top
 Profile  
 
PostPosted: 24. Aug 2016, 22:38 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10571
Sorry - I was on vacation and missed your last answer.

as you use a https iframe in a http page you need to use
"Use post message for communication" as written on the top of the external workaround "If you mix http and https pages you NEED to enable "Use post message for communication"!"

Simply enable this on the "external workaround" tab and refresh the browser cache.

Best, Michael


Top
 Profile  
 
PostPosted: 24. Aug 2016, 23:35 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10571
I just enhanced the plugin that your configuration issue can be detected an a message is shown then.
This will be available in v7.3.

Best, Michael


Top
 Profile  
 
PostPosted: 27. Aug 2016, 03:43 
Offline

Joined: 2. Aug 2016, 12:06
Posts: 9
I have enabled 'Use post message for communication', put in the correct Javascript in the head section of the external page, and cleared my browser cache, and it is still not working as you can see: http://www.webengin.com.au/test-page-2/ (it's the top frame, ignore the bottom)

Am I doing something wrong? If you view the frame source, you can see that the correct Javascript is there, so I simply don't understand why it is not working.


Top
 Profile  
 
PostPosted: 29. Aug 2016, 22:34 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10571
Hi. I only have limited Internet till Saturday.
I will check your website on Sunday.

Best Michael


Top
 Profile  
 
PostPosted: 4. Sep 2016, 21:05 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10571
The problem is that the page in the iframe tries to load the ai_external.js from a https domain which is now blocked by e.g. chrome.
this is why I recommend in my blog not to mix http and https.

You get the following error message right now:
Mixed Content: The page at 'https://webengin.partnerconsole.net/execute/logonDispatch' was loaded over HTTPS, but requested an insecure script 'http://www.webengin.com.au/wp-content/plugins/advanced-iframe/js/ai_external.js'. This request has been blocked; the content must be served over HTTPS.

The solution is to copy the ai_external.js to a https domain. in your case I would recommend https://webengin.partnerconsole.net if possible.

I currently enhance the description in 7.3 how this setup can be done and also create a working example.

Best, Michael


Top
 Profile  
 
PostPosted: 20. Sep 2016, 01:33 
Offline

Joined: 2. Aug 2016, 12:06
Posts: 9
Thank you for reply. I appreciate you trying to help out. It is still not working.

https://www.webengin.com.au/test-page-2/

We have forced HTTPS on the webengin.com.au domain so that the scripts are being served over HTTPS.


Top
 Profile  
 
PostPosted: 20. Sep 2016, 10:16 
Offline
Site Admin
User avatar

Joined: 1. Aug 2005, 12:53
Posts: 10571
You get the following message in the console:
Advanced iframe configuration error: The id of the parent and the external workaround are different! Check your settings.
ai.js?ver=889996:124 T

You have added

<script src="https://www.webengin.com.au/wp-content/plugins/advanced-iframe/js/ai_external.js">
<script>
var iframe_id = "iframe";
var updateIframeHeight = "true";
var iframe_content_id = "#iframe";
var hide_page_until_loaded_external = "true";
</script>


Which meas you have included the ai_external.js and AFTER that you try to configure it. you first need to set the settings and then you need to include the file

<script>
var iframe_id = "iframe";
var updateIframeHeight = "true";
var iframe_content_id = "#iframe";
var hide_page_until_loaded_external = "true";
</script>
<script src="https://www.webengin.com.au/wp-content/plugins/advanced-iframe/js/ai_external.js">


is correct.

Best, Michael


Top
 Profile  
 
PostPosted: 22. Sep 2016, 00:06 
Offline

Joined: 2. Aug 2016, 12:06
Posts: 9
TinyWebGallery wrote:
You get the following message in the console:
Advanced iframe configuration error: The id of the parent and the external workaround are different! Check your settings.
ai.js?ver=889996:124 T

You have added

<script src="https://www.webengin.com.au/wp-content/plugins/advanced-iframe/js/ai_external.js">
<script>
var iframe_id = "iframe";
var updateIframeHeight = "true";
var iframe_content_id = "#iframe";
var hide_page_until_loaded_external = "true";
</script>


Which meas you have included the ai_external.js and AFTER that you try to configure it. you first need to set the settings and then you need to include the file

<script>
var iframe_id = "iframe";
var updateIframeHeight = "true";
var iframe_content_id = "#iframe";
var hide_page_until_loaded_external = "true";
</script>
<script src="https://www.webengin.com.au/wp-content/plugins/advanced-iframe/js/ai_external.js">


is correct.

Best, Michael


I have done this, it is still not working. What is wrong now?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 18 posts ]  Go to page 1, 2  Next

All times are UTC + 1 hour [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
cron
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO